Board index FlightGear Support Compiling

download_and_compile.sh doesn't work  Topic is solved

Building FlightGear from source, and in the need for help?

download_and_compile.sh doesn't work

Postby E-HEC » Tue Feb 26, 2013 4:32 pm

Hi everyone,
I tried to compile flightgear 2.10 on ubuntu 12.14 using the script on http://www.gitorious.org/fg/fgmeta/blob ... compile.sh.
Unfortunatly the installation aborted whith the following message:

Code: Select all
christian@christian-MS-7728:~/flightgear 2.10$ sh download_and_compile.sh
**************************************
*                                    *
* Warning, the compilation process   *
* is going to use 12 or more Gbytes  *
* of space and at least a couple of  *
* hours to download and build FG.    *
*                                    *
* Please, be patient ......          *
*                                    *
**************************************
Asking your password to perform an apt-get update
[sudo] password for christian:
Ign http://security.ubuntu.com precise-security InRelease
Ign http://dl.google.com stable InRelease                                     
Ign http://archive.canonical.com precise InRelease                             
Ign http://extras.ubuntu.com precise InRelease                                 
Ign http://ppa.launchpad.net precise InRelease                                 
Hole:1 http://security.ubuntu.com precise-security Release.gpg [198 B]         
Ign http://de.archive.ubuntu.com precise InRelease                             
Ign http://de.archive.ubuntu.com precise-updates InRelease                     
Ign http://de.archive.ubuntu.com precise-backports InRelease                   
OK   http://dl.google.com stable Release.gpg                                   
OK   http://archive.canonical.com precise Release.gpg                         
Hole:2 http://extras.ubuntu.com precise Release.gpg [72 B]                     
OK   http://ppa.launchpad.net precise Release.gpg                             
Hole:3 http://security.ubuntu.com precise-security Release [49,6 kB]           
OK   http://dl.google.com stable Release                                       
OK   http://de.archive.ubuntu.com precise Release.gpg                         
OK   http://archive.canonical.com precise Release                             
OK   http://extras.ubuntu.com precise Release                                 
OK   http://ppa.launchpad.net precise Release                                 
Hole:4 http://de.archive.ubuntu.com precise-updates Release.gpg [198 B]       
OK   http://de.archive.ubuntu.com precise-backports Release.gpg               
OK   http://de.archive.ubuntu.com precise Release                             
OK   http://dl.google.com stable/main i386 Packages                           
OK   http://archive.canonical.com precise/partner Sources                     
OK   http://extras.ubuntu.com precise/main Sources                             
OK   http://ppa.launchpad.net precise/main Sources                             
Hole:5 http://security.ubuntu.com precise-security/main Sources [63,1 kB]     
Hole:6 http://de.archive.ubuntu.com precise-updates Release [49,6 kB]         
Ign http://dl.google.com stable/main TranslationIndex                         
OK   http://archive.canonical.com precise/partner i386 Packages               
Ign http://archive.canonical.com precise/partner TranslationIndex             
OK   http://extras.ubuntu.com precise/main i386 Packages                       
Ign http://extras.ubuntu.com precise/main TranslationIndex                     
OK   http://ppa.launchpad.net precise/main i386 Packages                       
Ign http://ppa.launchpad.net precise/main TranslationIndex                     
OK   http://de.archive.ubuntu.com precise-backports Release                   
Hole:7 http://security.ubuntu.com precise-security/restricted Sources [1.950 B]
Hole:8 http://security.ubuntu.com precise-security/universe Sources [22,2 kB] 
Hole:9 http://security.ubuntu.com precise-security/multiverse Sources [1.382 B]
Hole:10 http://security.ubuntu.com precise-security/main i386 Packages [237 kB]
OK   http://de.archive.ubuntu.com precise/main Sources                         
OK   http://de.archive.ubuntu.com precise/restricted Sources                   
OK   http://de.archive.ubuntu.com precise/universe Sources                     
OK   http://de.archive.ubuntu.com precise/multiverse Sources                   
OK   http://de.archive.ubuntu.com precise/main i386 Packages                   
OK   http://de.archive.ubuntu.com precise/restricted i386 Packages             
OK   http://de.archive.ubuntu.com precise/universe i386 Packages               
OK   http://de.archive.ubuntu.com precise/multiverse i386 Packages             
OK   http://de.archive.ubuntu.com precise/main TranslationIndex               
OK   http://de.archive.ubuntu.com precise/multiverse TranslationIndex         
OK   http://de.archive.ubuntu.com precise/restricted TranslationIndex         
OK   http://de.archive.ubuntu.com precise/universe TranslationIndex           
Hole:11 http://de.archive.ubuntu.com precise-updates/main Sources [367 kB]     
Ign http://archive.canonical.com precise/partner Translation-de_DE             
Ign http://ppa.launchpad.net precise/main Translation-de_DE                   
Ign http://archive.canonical.com precise/partner Translation-de               
Ign http://ppa.launchpad.net precise/main Translation-de                       
Ign http://extras.ubuntu.com precise/main Translation-de_DE                   
Ign http://archive.canonical.com precise/partner Translation-en               
Ign http://ppa.launchpad.net precise/main Translation-en                       
Ign http://extras.ubuntu.com precise/main Translation-de                       
Hole:12 http://security.ubuntu.com precise-security/restricted i386 Packages [3.968 B]
Hole:13 http://security.ubuntu.com precise-security/universe i386 Packages [69,9 kB]
Ign http://extras.ubuntu.com precise/main Translation-en                       
Hole:14 http://security.ubuntu.com precise-security/multiverse i386 Packages [2.368 B]
OK   http://security.ubuntu.com precise-security/main TranslationIndex         
OK   http://security.ubuntu.com precise-security/multiverse TranslationIndex   
OK   http://security.ubuntu.com precise-security/restricted TranslationIndex   
OK   http://security.ubuntu.com precise-security/universe TranslationIndex     
OK   http://security.ubuntu.com precise-security/main Translation-en           
OK   http://security.ubuntu.com precise-security/multiverse Translation-en     
OK   http://security.ubuntu.com precise-security/restricted Translation-en     
Hole:15 http://de.archive.ubuntu.com precise-updates/restricted Sources [5.135 B]
OK   http://security.ubuntu.com precise-security/universe Translation-en       
Hole:16 http://de.archive.ubuntu.com precise-updates/universe Sources [79,2 kB]
Hole:17 http://de.archive.ubuntu.com precise-updates/multiverse Sources [4.725 B]
Hole:18 http://de.archive.ubuntu.com precise-updates/main i386 Packages [593 kB]
Ign http://dl.google.com stable/main Translation-de_DE                         
Ign http://dl.google.com stable/main Translation-de       
Ign http://dl.google.com stable/main Translation-en
Hole:19 http://de.archive.ubuntu.com precise-updates/restricted i386 Packages [9.503 B]
Hole:20 http://de.archive.ubuntu.com precise-updates/universe i386 Packages [184 kB]
Hole:21 http://de.archive.ubuntu.com precise-updates/multiverse i386 Packages [10,4 kB]
Hole:22 http://de.archive.ubuntu.com precise-updates/main TranslationIndex [3.564 B]
Hole:23 http://de.archive.ubuntu.com precise-updates/multiverse TranslationIndex [2.605 B]
Hole:24 http://de.archive.ubuntu.com precise-updates/restricted TranslationIndex [2.461 B]
Hole:25 http://de.archive.ubuntu.com precise-updates/universe TranslationIndex [2.850 B]
OK   http://de.archive.ubuntu.com precise-backports/main Sources   
OK   http://de.archive.ubuntu.com precise-backports/restricted Sources
OK   http://de.archive.ubuntu.com precise-backports/universe Sources
OK   http://de.archive.ubuntu.com precise-backports/multiverse Sources
OK   http://de.archive.ubuntu.com precise-backports/main i386 Packages
OK   http://de.archive.ubuntu.com precise-backports/restricted i386 Packages
OK   http://de.archive.ubuntu.com precise-backports/universe i386 Packages
OK   http://de.archive.ubuntu.com precise-backports/multiverse i386 Packages
OK   http://de.archive.ubuntu.com precise-backports/main TranslationIndex
OK   http://de.archive.ubuntu.com precise-backports/multiverse TranslationIndex
OK   http://de.archive.ubuntu.com precise-backports/restricted TranslationIndex
OK   http://de.archive.ubuntu.com precise-backports/universe TranslationIndex
OK   http://de.archive.ubuntu.com precise/main Translation-de
OK   http://de.archive.ubuntu.com precise/main Translation-en
OK   http://de.archive.ubuntu.com precise/multiverse Translation-de
OK   http://de.archive.ubuntu.com precise/multiverse Translation-en
OK   http://de.archive.ubuntu.com precise/restricted Translation-de
OK   http://de.archive.ubuntu.com precise/restricted Translation-en
OK   http://de.archive.ubuntu.com precise/universe Translation-de
OK   http://de.archive.ubuntu.com precise/universe Translation-en
OK   http://de.archive.ubuntu.com precise-updates/main Translation-de
OK   http://de.archive.ubuntu.com precise-updates/main Translation-en
OK   http://de.archive.ubuntu.com precise-updates/multiverse Translation-de
OK   http://de.archive.ubuntu.com precise-updates/multiverse Translation-en
OK   http://de.archive.ubuntu.com precise-updates/restricted Translation-de
OK   http://de.archive.ubuntu.com precise-updates/restricted Translation-en
OK   http://de.archive.ubuntu.com precise-updates/universe Translation-de
OK   http://de.archive.ubuntu.com precise-updates/universe Translation-en
OK   http://de.archive.ubuntu.com precise-backports/main Translation-en
OK   http://de.archive.ubuntu.com precise-backports/multiverse Translation-en
OK   http://de.archive.ubuntu.com precise-backports/restricted Translation-en
OK   http://de.archive.ubuntu.com precise-backports/universe Translation-en
Es wurden 1.766 kB in 4 s geholt (424 kB/s)
Paketlisten werden gelesen... Fertig
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner i386 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages)
W: Probieren Sie »apt-get update«, um diese Probleme zu korrigieren
Asking your password to perform an apt-get install ...
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
automake ist schon die neueste Version.
cvs ist schon die neueste Version.
gawk ist schon die neueste Version.
gettext ist schon die neueste Version.
git-core ist schon die neueste Version.
libapr1-dev ist schon die neueste Version.
libboost-dev ist schon die neueste Version.
libboost-serialization-dev ist schon die neueste Version.
libglew1.5-dev ist schon die neueste Version.
libjasper-dev ist schon die neueste Version.
libjasper1 ist schon die neueste Version.
libjpeg62 ist schon die neueste Version.
libjpeg62-dev ist schon die neueste Version.
libopenal-dev ist schon die neueste Version.
libopenal1 ist schon die neueste Version.
libopenexr-dev ist schon die neueste Version.
libpng12-0 ist schon die neueste Version.
libpng12-dev ist schon die neueste Version.
libsvn-dev ist schon die neueste Version.
libxft-dev ist schon die neueste Version.
libxft2 ist schon die neueste Version.
libxi-dev ist schon die neueste Version.
libxi6 ist schon die neueste Version.
libxinerama-dev ist schon die neueste Version.
libxinerama1 ist schon die neueste Version.
libxmu-dev ist schon die neueste Version.
libxmu6 ist schon die neueste Version.
python-imaging-tk ist schon die neueste Version.
python-tk ist schon die neueste Version.
scons ist schon die neueste Version.
subversion ist schon die neueste Version.
zlib1g ist schon die neueste Version.
zlib1g-dev ist schon die neueste Version.
fluid ist schon die neueste Version.
libalut-dev ist schon die neueste Version.
libalut0 ist schon die neueste Version.
libfltk1.3 ist schon die neueste Version.
libfltk1.3-dev ist schon die neueste Version.
libhal-dev ist schon die neueste Version.
libwxgtk2.8-0 ist schon die neueste Version.
libwxgtk2.8-dev ist schon die neueste Version.
build-essential ist schon die neueste Version.
cmake ist schon die neueste Version.
freeglut3-dev ist schon die neueste Version.
libasound2 ist schon die neueste Version.
libasound2-dev ist schon die neueste Version.
libqt4-dev ist schon die neueste Version.
make ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 2 nicht aktualisiert.
tee: 2.10/compilation_log.txt: Datei oder Verzeichnis nicht gefunden
****************************************
christian@christian-MS-7728:~/flightgear 2.10$


The file compilation_log.txt exists and has the following content:
Code: Select all
download_and_compile.sh
APT_GET_UPDATE=y
DOWNLOAD_PACKAGES=y
COMPILE=y
RECONFIGURE=y
DOWNLOAD=y
JOPTION=
OOPTION=
DEBUG=
***********************************
Ubuntu 12.04
***********************************
PACKAGE INSTALLATION ...  OK
DIRECTORY= /home/christian/flightgear 2.10
***********************************


The folders "build" and "install" exists also but are empty.

Can anybody help?

Christian
E-HEC
 
Posts: 19
Joined: Mon Apr 16, 2012 3:14 pm

Re: download_and_compile.sh doesn't work  

Postby F-JJTH » Tue Feb 26, 2013 4:47 pm

Hi,

Your directory "flightgear 2.10" contains a space. Try to execute the script in a directory without space (e.g flightgear-git)
It seems that download_and_compile.sh doesn't support space

Cheers,
Clément
User avatar
F-JJTH
 
Posts: 696
Joined: Fri Sep 09, 2011 11:02 am

Re: download_and_compile.sh doesn't work

Postby E-HEC » Wed Feb 27, 2013 8:22 pm

Thank you,

that was the solution. Now everything compiled as it should. :D

Many thanks,
Christian
E-HEC
 
Posts: 19
Joined: Mon Apr 16, 2012 3:14 pm

Re: download_and_compile.sh doesn't work

Postby Hooray » Wed Feb 27, 2013 8:48 pm

should send a heads-up to brisa to fix that or at least detect the situation and issue a warning.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 12059
Joined: Tue Mar 25, 2008 8:40 am


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest