Board index FlightGear Support Compiling

Trouble getting my windows build running.

Building FlightGear from source, and in the need for help?

Trouble getting my windows build running.

Postby chriscalef » Wed Feb 20, 2013 9:41 pm

(Apologies for cross posting with devel mailing list, not sure what has more eyes on it...)

Hey everybody,

Thanks for all of your great work! I'm new to this project, but very impressed so far!

My issue is on my Windows 7 box... I downloaded all the git sources over the weekend and got it building and running just fine on my Ubuntu machine (12.10) but I'm having issues running my build in Windows. I got everything to compile (finally) but when it came to run time I realized I did not have any of the dlls that should live next to the executable, so I tried grabbing them all from my flightgear 2.8.0.5 binary install.

Of course, it turned out those were all outdated, so I grabbed all new ones out of the OSG and libsvn projects. That covered almost all of the dlls in use, with the exceptions of iconv.dll, gettextlib.dll, gettextsrc.dll, the msvcr & msvcp dlls, and the PocoFoundation and PocoNet dlls. (I think that's all of them anyway.)

The really weird thing is I built it in debug, and when it crashed it was in msvcr90.dll... I have two versions of msvcr in my game directory actually, but they are msvcr71 and msvcr100. I searched around and found several copies of msvcr90 in my windows system folders, but they seemed to be mostly in archive folders, while in my system32 and system64 folders I have only msvcr100 and 110 versions. [EDIT: these archive-looking folders are indeed where the file is being accessed from... I am using Visual Studio 9.0 so perhaps it has to use the 90 version to stay compatible?]

EDIT: in release mode, I also notice that I am apparently loading 64 bit versions of several dlls, or at least dlls from the SysWOW64 directory in Windows... (winmm.dll and others) Could this be my problem?

Any advice would be much appreciated!

Cheers,
Chris Calef
BrokeAss Games
chriscalef
 
Posts: 279
Joined: Wed Feb 20, 2013 9:28 pm

Re: Trouble getting my windows build running.

Postby Hooray » Thu Feb 21, 2013 12:12 pm

Hi & welcome

I would advise to be careful with regard to mixing DLLs from different sources

could you try again with the DLLs from the build server first ?
http://wiki.flightgear.org/FlightGear_Build_Server
http://flightgear.simpits.org:8080/

Otherwise, there's also the 3rdparty.zip file with all required DLLs for Windows.

Also, which build instructions/tutorial did you follow ?
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 12058
Joined: Tue Mar 25, 2008 8:40 am

Re: Trouble getting my windows build running.

Postby chriscalef » Thu Feb 21, 2013 5:29 pm

Thanks for the response!

Re: which build instructions, hehe I think probably all of them, but I centered around this one:

http://wiki.flightgear.org/Building_usi ... _-_Windows

I didn't use the command lines specified for cmake because I already had a CMake GUI in play and it seemed to be doing it's job, hope I didn't lose anything vital there... I also just noticed that while I have installed boost 1_53 I was actually using headers from an earlier install of 1_42... I saw a 1_44 number floating around for that, is FG still on 1_44 or would I be fine with the latest one?

I didn't know about the build server, thank you very much for that valuable bit of data!

I did all my main building in VS2008, but yesterday tried starting over again from scratch in VS2010, I almost made it but ended up with a handful of linker errors similar to the other guy who just posted re: 2010, will bring those up in that other thread soon.

Thanks again, hopefully we'll get this ironed out and get me flying on the windows machine soon. It's sweet having it up and running in ubuntu (!!) but of the two my windows box has the much better hardware. ;-)
chriscalef
 
Posts: 279
Joined: Wed Feb 20, 2013 9:28 pm


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest