Board index FlightGear Support Compiling

Compiling 2.8.0 on ubuntu  Topic is solved

Building FlightGear from source, and in the need for help?

Compiling 2.8.0 on ubuntu

Postby wil » Thu Feb 07, 2013 12:27 am

When I tried to compile flightgear 2.8.0 on ubuntu 12.04 lts i goy this error
Code: Select all
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
GLUT_Xmu_LIBRARY (ADVANCED)
    linked by target "fgpanel" in directory /home/wil/Downloads/flightgear-2.8.0/utils/fgpanel

-- Configuring incomplete, errors occurred!
wil
 
Posts: 22
Joined: Sat Dec 08, 2012 1:51 pm

Re: Compiling 2.8.0 on ubuntu  

Postby Hooray » Thu Feb 07, 2013 1:19 am

Xmu is often required for X11 applications - and apparently not found in your case ?
Are you using brisa's d&c script ?

run apt-cache search xmu to see which libs you can install to satisfy such missing requirements.

That said, you don't necessarily need to build fgpanel, but Xmu will probably also be linked in by fgfs.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 12058
Joined: Tue Mar 25, 2008 8:40 am

Re: Compiling 2.8.0 on ubuntu

Postby wil » Thu Feb 07, 2013 1:32 am

Thanks that fixed my problem
wil
 
Posts: 22
Joined: Sat Dec 08, 2012 1:51 pm


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest