Board index FlightGear Support Compiling

libsvn not found - change cmake module

Building FlightGear from source, and in the need for help?

libsvn not found - change cmake module

Postby mase » Sat Nov 24, 2012 2:22 pm

Hi!
On my Debian Wheezy amd64 system, the svn libraries could
not be found. As a fix I changed FindSvnClient.cmake and added
x86_64-linux-gnu to the PATH_SUFFIXES.
Maybe you could add this to the repo.
mase
 
Posts: 55
Joined: Sun Sep 25, 2011 1:43 pm
Callsign: mase1
Version: GIT
OS: Debian Gnu / Linux

Re: libsvn not found - change cmake module

Postby Hooray » Sun Nov 25, 2012 7:03 am

Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 12058
Joined: Tue Mar 25, 2008 8:40 am

Re: libsvn not found - change cmake module

Postby sa7k » Wed Nov 28, 2012 11:52 pm

It is already being worked on, it can be a cmake bug, you can check here:
http://code.google.com/p/flightgear-bugs/issues/detail?id=946
sa7k
 
Posts: 380
Joined: Fri Mar 16, 2012 2:24 pm
Location: SA7K
Callsign: LV-EPM
IRC name: sa7k
Version: git
OS: debian

Re: libsvn not found - change cmake module

Postby Alant » Thu Nov 29, 2012 9:07 am

I am seeing the same on 32 bit Ubuntu. It is not quite as simple as just adding x86_64-linux-gnu to the PATH_SUFFIXES in FindSvnClient.cmake, as on a 32 bit build i386-linux-gnu is needed instead.

Adding both could cause problems on a system where both 32bit and 64 bit libraries are installed.

I have posted on the devel mail list, and also added my bit to http://code.google.com/p/flightgear-bug ... ail?id=946. Ubuntu think that the bug has been fixed, but they are clearly mistaken.
Alant
 
Posts: 1013
Joined: Wed Jun 23, 2010 5:58 am
Location: Portugal
Callsign: Tarnish99
Version: from Git
OS: Windows 10

Re: libsvn not found - change cmake module

Postby sa7k » Thu Nov 29, 2012 12:26 pm

Alant, there is a new workaround for more than one archs in the last comment
http://code.google.com/p/flightgear-bugs/issues/detail?id=946#c8
you could try that and comment there if it works for you.
sa7k
 
Posts: 380
Joined: Fri Mar 16, 2012 2:24 pm
Location: SA7K
Callsign: LV-EPM
IRC name: sa7k
Version: git
OS: debian

Re: libsvn not found - change cmake module

Postby F-JJTH » Thu Nov 29, 2012 9:26 pm

sa7k wrote in Thu Nov 29, 2012 12:26 pm:Alant, there is a new workaround for more than one archs in the last comment
http://code.google.com/p/flightgear-bugs/issues/detail?id=946#c8
you could try that and comment there if it works for you.


Here it works for me : http://code.google.com/p/flightgear-bug ... ?id=946#c9
User avatar
F-JJTH
 
Posts: 696
Joined: Fri Sep 09, 2011 11:02 am


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest