Board index FlightGear Support Compiling

FGRun repository moved for download_and_compile.sh

Building FlightGear from source, and in the need for help?

FGRun repository moved for download_and_compile.sh

Postby lsimons » Wed Sep 05, 2012 1:02 am

In the latest download_and_compile.sh, the fgrun section is looking for the repository to be at http://fgrun.svn.sourceforge.net/svnroot/fgrun/trunk, but this location specifies that the repository has moved to git://gitorious.org/fg/fgrun.git. I was wondering if the script needs to be updated to reflect this, or if there is a compilation flag I'm missing?

Thanks,
Louis
lsimons
 
Posts: 14
Joined: Thu Aug 30, 2012 12:53 pm

Re: FGRun repository moved for download_and_compile.sh

Postby Alant » Wed Sep 05, 2012 9:55 am

Try to clone from this instead.
https://git.gitorious.org/fg/fgrun.git
For a non-developer, the https:// protocol is often easier to use than the git:// one.

Alan
Alant
 
Posts: 1017
Joined: Wed Jun 23, 2010 5:58 am
Location: Portugal
Callsign: Tarnish99
Version: from Git
OS: Windows 10

Re: FGRun repository moved for download_and_compile.sh

Postby lsimons » Wed Sep 05, 2012 11:36 pm

I was able to clone it without problem, but I'm not familiar with cmake and had trouble getting it to compile. Is there anything inherently different from what the script expects, or should the scripted compile be able to run after git clone?
lsimons
 
Posts: 14
Joined: Thu Aug 30, 2012 12:53 pm

Re: FGRun repository moved for download_and_compile.sh

Postby F-JJTH » Wed Sep 05, 2012 11:49 pm

Hi,

For information I sent a merge request in order to update the FGRun repository and solve this problem.
https://gitorious.org/fg/fgmeta/merge_requests/1

Now we just need to be patient and wait that someone merge it.

Cheers,
Clément
User avatar
F-JJTH
 
Posts: 696
Joined: Fri Sep 09, 2011 11:02 am

Re: FGRun repository moved for download_and_compile.sh

Postby lsimons » Thu Sep 06, 2012 12:13 pm

Thanks! Not in a hurry, just figured I'd mention it since I couldn't find it referenced on the forum.
lsimons
 
Posts: 14
Joined: Thu Aug 30, 2012 12:53 pm

Re: FGRun repository moved for download_and_compile.sh

Postby nacho » Sun Sep 16, 2012 1:03 am

I am in the same boat here. FGRUN is not compiling and I am waiting for the udpated download and compile script.

IB
nacho
 
Posts: 14
Joined: Mon Jan 23, 2012 1:25 am
Version: 2.8
OS: Ubuntu

Re: FGRun repository moved for download_and_compile.sh

Postby Soitanen » Thu Oct 25, 2012 9:00 am

You can change code in FGRUN section to this:
Code: Select all
#######################################################
# FGRUN
#######################################################
FGRUN_INSTALL_DIR=fgrun
INSTALL_DIR_FGRUN=$INSTALL_DIR/$FGRUN_INSTALL_DIR
cd "$CBD"

if [ "$WHATTOBUILD" = "" -o "$WHATTOBUILD" = "FGRUN" -o "$WHATTOBUILD" = "ALL" ]
then
   echo "****************************************" | tee -a $LOGFILE
   echo "**************** FGRUN *****************" | tee -a $LOGFILE
   echo "****************************************" | tee -a $LOGFILE

if [ ! -d "fgrun" ]
then
   mkdir "fgrun"
fi
cd fgrun/
            if [ -d "fgrun" ]
            then
               echo "fgrun exists already."
            else
               # no repository yet - need to clone a fresh one
               git clone git://gitorious.org/fg/fgrun.git fgrun
            fi

            cd fgrun

            git fetch origin
            
            
            # switch to stable branch
               # create local stable branch, ignore errors if it exists
               git branch -f master origin/master 2> /dev/null || true
               # switch to stable branch. No error is reported if we're already on the branch.
               git checkout -f master
               # get indicated stable version
               git reset --hard master
            



   if [ ! "$UPDATE" = "UPDATE" ]
   then
      if [ "$RECONFIGURE" = "y" ]
      then
                        cd "$CBD"
                        mkdir -p build/fgrun
                        cd "$CBD"/build/fgrun

         echo -n "RECONFIGURE FGRUN ... " >> $LOGFILE
         rm -f ../../fgrun/fgrun/CMakeCache.txt
         
         cmake -D CMAKE_BUILD_TYPE="Release" -D CMAKE_CXX_FLAGS="-O3 -D__STDC_CONSTANT_MACROS" -D CMAKE_C_FLAGS="-O3" -D CMAKE_INSTALL_PREFIX:PATH="$INSTALL_DIR_FGRUN" -D "CMAKE_PREFIX_PATH=$INSTALL_DIR_OSG;$INSTALL_DIR_PLIB;$INSTALL_DIR_SIMGEAR" ../../fgrun/fgrun/ 2>&1 | tee -a $LOGFILE

         echo " OK" >> $LOGFILE
      fi
   fi
   
   if [ "$COMPILE" = "y" ]
   then
      cd "$CBD"/build/fgrun

      echo "MAKE FGRUN" >> $LOGFILE
      echo "make $JOPTION $OOPTION" >> $LOGFILE
      make $JOPTION $OOPTION 2>1 | tee -a $LOGFILE

      echo "INSTALL FGRUN" >> $LOGFILE
      make install 2>&1 | tee -a $LOGFILE
   fi

   cd "$CBD"

   SCRIPT=run_fgrun.sh
   echo "#!/bin/sh" > $SCRIPT
   echo "cd \$(dirname \$0)" >> $SCRIPT
   echo "cd $SUB_INSTALL_DIR/$FGRUN_INSTALL_DIR/bin" >> $SCRIPT
   echo "export LD_LIBRARY_PATH=../../$PLIB_INSTALL_DIR/lib:../../$OSG_INSTALL_DIR/lib:../../$SIMGEAR_INSTALL_DIR/lib" >> $SCRIPT
   #echo "export FG_AIRCRAFTS=\$PWD/../../$FGFS_INSTALL_DIR/aircrafts" >> $SCRIPT
   echo "./fgrun --fg-exe=\$PWD/../../$FGFS_INSTALL_DIR/bin/fgfs --fg-root=\$PWD/../../$FGFS_INSTALL_DIR/fgdata   \$@" >> $SCRIPT
   chmod 755 $SCRIPT


fi


In my case FGRUN downloads normally, but fault in compiling with error:
Code: Select all
-- Using FLTK_LIBRARIES for fgrun: fltk_images;fltk_forms;fltk_gl;/usr/lib/i386-linux-gnu/libGL.so;fltk;/usr/lib/i386-linux-gnu/libSM.so;/usr/lib/i386-linux-gnu/libICE.so;/usr/lib/i386-linux-gnu/libX11.so;/usr/lib/i386-linux-gnu/libXext.so;/usr/lib/i386-linux-gnu/libm.so
CMake Error at CMakeLists.txt:222 (message):
  FLTK 1.3 is required

Seems to be strange, because FLTK 1.3 is installed...
Boeing 737-300. Reworked cockpit, FDM, autopilot and much more. WIP.
Boeing 737-800. WIP. Canvas PFD and ND.
Antonov An-24B. Made from scratch. Very good FDM. 3D model by Adrian. WIP.
Project Russia (some cities, based on OSM with custom objects).
Soitanen
 
Posts: 489
Joined: Sat Jun 16, 2012 6:50 am
Location: Saint-Petersburg, Russia
Version: git
OS: Linux Mint 17

Re: FGRun repository moved for download_and_compile.sh

Postby koubi » Thu Oct 25, 2012 9:40 am

Image

libfltk1.3-dev is needed,if it don't work you can try to compile libfltk yourself: http://www.fltk.org/software.php
User avatar
koubi
 
Posts: 38
Joined: Thu Oct 27, 2011 9:21 pm

Re: FGRun repository moved for download_and_compile.sh

Postby Soitanen » Thu Oct 25, 2012 9:49 am

libfltk1.3-dev is installed, version is the same, as on your screenshot. So right way is only manual compilation?
Boeing 737-300. Reworked cockpit, FDM, autopilot and much more. WIP.
Boeing 737-800. WIP. Canvas PFD and ND.
Antonov An-24B. Made from scratch. Very good FDM. 3D model by Adrian. WIP.
Project Russia (some cities, based on OSM with custom objects).
Soitanen
 
Posts: 489
Joined: Sat Jun 16, 2012 6:50 am
Location: Saint-Petersburg, Russia
Version: git
OS: Linux Mint 17

Re: FGRun repository moved for download_and_compile.sh

Postby koubi » Thu Oct 25, 2012 10:36 am

sorry in fact it work well with fgrun 1.6.2 (svn) i try now to compile fgrun git,and i will tell you if i meet the same problem
User avatar
koubi
 
Posts: 38
Joined: Thu Oct 27, 2011 9:21 pm

Re: FGRun repository moved for download_and_compile.sh

Postby F-JJTH » Thu Oct 25, 2012 11:45 am

Just remove the cmake cachde (build/CMakeCache.txt). Here this action solved the problem.

Cheers,
Clément
User avatar
F-JJTH
 
Posts: 696
Joined: Fri Sep 09, 2011 11:02 am

Re: FGRun repository moved for download_and_compile.sh

Postby Soitanen » Thu Oct 25, 2012 11:53 am

F-JJTH wrote in Thu Oct 25, 2012 11:45 am:Just remove the cmake cachde (build/CMakeCache.txt). Here this action solved the problem.

Found cache, deleted it, but the same error.
Boeing 737-300. Reworked cockpit, FDM, autopilot and much more. WIP.
Boeing 737-800. WIP. Canvas PFD and ND.
Antonov An-24B. Made from scratch. Very good FDM. 3D model by Adrian. WIP.
Project Russia (some cities, based on OSM with custom objects).
Soitanen
 
Posts: 489
Joined: Sat Jun 16, 2012 6:50 am
Location: Saint-Petersburg, Russia
Version: git
OS: Linux Mint 17

Re: FGRun repository moved for download_and_compile.sh

Postby koubi » Thu Oct 25, 2012 7:06 pm

i've compiled fgrun 1.7 git and it work well here.
did you tried to use cmake-gui?:

Image

look at /usr/lib/fltk and/or /usr/lib/x86_64-linux-gnu/
try to uninstall and reinstall libfltk-dev with your package manager

i've not other ideas at the moment. :(
User avatar
koubi
 
Posts: 38
Joined: Thu Oct 27, 2011 9:21 pm

Re: FGRun repository moved for download_and_compile.sh

Postby richter » Thu Apr 11, 2013 4:09 am

I had the same problem with not finding FLTK 1.3, on my Slackware system.

I build FLTK from source with "./configure -enable-shared" (use the configure script rather than cmake), and that solved the problem.
Aircraft: Britten-Norman BN-2 Islander
Airports: RJTT
richter
 
Posts: 115
Joined: Tue Jan 27, 2009 4:58 pm
Location: Tokyo
Version: 2
OS: Slackware Linux 12.2

Re: FGRun repository moved for download_and_compile.sh

Postby ludomotico » Tue Apr 30, 2013 12:34 am

richter wrote in Thu Apr 11, 2013 4:09 am:I had the same problem with not finding FLTK 1.3, on my Slackware system.

I build FLTK from source with "./configure -enable-shared" (use the configure script rather than cmake), and that solved the problem.


I don't know if you fixed your problem. I found this thread after finding the same error. I bypassed the ckeck for FLTK1.3 in CMakeList.txt (by commenting the lines that compile a test source) and cmake worked, but make didn't. Fortunately, make output a hint about the problem: missing xinerama, fontconfig and xft.

Then,

sudo apt-get install libxinerama-dev libfontconfig1-dev libxft-dev

and fgrun compiled. Maybe the cmake in fgrun should check if these libraries are present?
User avatar
ludomotico
 
Posts: 1172
Joined: Tue Apr 24, 2012 1:01 pm
Version: nightly
OS: Windows 10


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest