Board index FlightGear Support Compiling

Oops, you have installed SimGear includes, however test comp

Building FlightGear from source, and in the need for help?

Oops, you have installed SimGear includes, however test comp

Postby belnac » Fri Aug 24, 2012 7:26 am

Trying to compile FlightGear on Xubuntu fails with the following error message:

Code: Select all
-- Performing Test SIMGEAR_COMPILE_TEST
-- Performing Test SIMGEAR_COMPILE_TEST - Failed
CMake Error at CMakeModules/FindSimGear.cmake:265 (message):
  Oops, you have installed SimGear includes, however test compiling failed.
  Try removing 'CMakeCache.txt' and reconfigure with 'cmake'.


Removing CMakeCache.txt doesn't solve it, BTW. Simgear-dev 2.4.0-1 is currently installed (via apt-get.)

Anyone come across this sort of error?

Full cmake log at: http://paste.ubuntu.com/1163960/
belnac
 
Posts: 5
Joined: Fri Aug 24, 2012 7:20 am

Re: Oops, you have installed SimGear includes, however test

Postby islandmonkey » Fri Aug 24, 2012 8:26 am

SimGear version is too old (you can't use 2.4 for 2.8 ). PlayDeb provides the latest [stable] version of all things FlightGear - you should use that: http://www.playdeb.net/software/FlightGear
User avatar
islandmonkey
 
Posts: 787
Joined: Mon Jan 30, 2012 8:51 pm
Location: EGCN (uni), EGHI (home)
Callsign: G-MNKY
OS: Ubuntu 20.04

Re: Oops, you have installed SimGear includes, however test

Postby belnac » Fri Aug 24, 2012 9:54 am

Unfortunately v2.8 isn't available for amd64 on playdeb so I had no choice but to compile it from source.

Solution for the simgear problem was to get it off the flightgear website [0], compiling it and then compilation of flightgear went ahead without a hitch.


[0] http://mirrors.ibiblio.org/simgear/ftp/Source/
belnac
 
Posts: 5
Joined: Fri Aug 24, 2012 7:20 am


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest