Board index FlightGear Support Compiling

crash when compil (46%) version git/next (2.7.0)

Building FlightGear from source, and in the need for help?

crash when compil (46%) version git/next (2.7.0)

Postby maxt » Tue May 01, 2012 8:55 am

hello

when i'm compil flightgear last git version (git 01/05/2012), I have this message
46%] Building CXX object src/Main/CMakeFiles/fgfs.dir/__/GUI/AirportList.cxx.o
In file included from /mnt/arch/flightgear/src/GUI/AirportList.hxx:8:0,
from /mnt/arch/flightgear/src/GUI/AirportList.cxx:8:
/mnt/arch/flightgear/src/GUI/FGPUIDialog.hxx:245:50: erreur: expected class-name before ‘,’ token
/mnt/arch/flightgear/src/GUI/FGPUIDialog.hxx: In constructor ‘fgList::fgList(int, int, int, int, SGPropertyNode*, int)’:
/mnt/arch/flightgear/src/GUI/FGPUIDialog.hxx:248:29: erreur: class ‘fgList’ does not have any field named ‘puaList’
In file included from /mnt/arch/flightgear/src/GUI/AirportList.cxx:8:0:
/mnt/arch/flightgear/src/GUI/AirportList.hxx: At global scope:
/mnt/arch/flightgear/src/GUI/AirportList.hxx:12:35: erreur: expected class-name before ‘,’ token
/mnt/arch/flightgear/src/GUI/AirportList.cxx: In constructor ‘AirportList::AirportList(int, int, int, int)’:
/mnt/arch/flightgear/src/GUI/AirportList.cxx:11:5: erreur: class ‘AirportList’ does not have any field named ‘puaList’
/mnt/arch/flightgear/src/GUI/AirportList.cxx: In member function ‘virtual void AirportList::create_list()’:
/mnt/arch/flightgear/src/GUI/AirportList.cxx:32:32: erreur: ‘newList’ was not declared in this scope
make[2]: *** [src/Main/CMakeFiles/fgfs.dir/__/GUI/AirportList.cxx.o] Erreur 1
make[1]: *** [src/Main/CMakeFiles/fgfs.dir/all] Erreur 2
make: *** [all] Erreur 2
I have this message for several versions of git, in fact I never finish a compile flightgear, I always got this message (several months)
I git erase, then re download the latest branch
kernel 3.2.5, gcc 4.7.0,
distribution zenwalk 7.2 in snapshot
thanks
good day
maxt
 
Posts: 2
Joined: Tue May 01, 2012 8:40 am

Re: crash when compil (46%) version git/next (2.7.0)

Postby zakalawe » Tue May 01, 2012 4:46 pm

You need to build against a newer version of PLIB. (1.8.6 I think) - presumably your distribution is supplying some older version.
zakalawe
 
Posts: 1164
Joined: Sat Jul 19, 2008 4:48 pm
Location: Edinburgh, Scotland
Callsign: G-ZKLW
Version: next
OS: Mac

Re: crash when compil (46%) version git/next (2.7.0)

Postby maxt » Wed May 02, 2012 5:00 am

hello

thank you for your reply, I will compile this version of plib, because it is not even a day in my distrib

thank you
maxt
 
Posts: 2
Joined: Tue May 01, 2012 8:40 am


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest