Board index FlightGear Support Compiling

"Auto-compile" 2.6 on Squeeze

Building FlightGear from source, and in the need for help?

"Auto-compile" 2.6 on Squeeze

Postby statto » Mon Mar 26, 2012 4:12 pm

Howdy everyone,

Running download_and_compile.sh on Debian Squeeze, I keep getting an error:
E: Unable to locate package libboost1.46-dev
E: Couldn't find any package by regex 'libboost1.46-dev'

It doesn't look like this package is available for Squeeze. I've got 1.42 installed, and being relatively new to Debian for stability purposes I'm still slightly nervous about doing a manual upgrade.

Anyone have any hints?
Custom Scenery available from http://www.stattosoftware.com/flightgear
statto
 
Posts: 2096
Joined: Fri Jan 25, 2008 9:57 pm

Re: "Auto-compile" 2.6 on Squeeze

Postby Bjoern » Tue Mar 27, 2012 2:35 pm

According to Google newer versions of libboost-dev are only available for Wheezy and Sid. With Squeeze, you're stuck on 1.42.
http://packages.debian.org/wheezy/libboost-dev

Enabling the repository for Sid and Wheezy in Debian's package manager and updating libboost might solve your problem.
Do a barrel roll!
User avatar
Bjoern
 
Posts: 384
Joined: Fri Jan 06, 2012 10:00 pm
Location: Nearest: THF
Version: Next
OS: ArchLinux, Win 7

Re: "Auto-compile" 2.6 on Squeeze

Postby statto » Tue Mar 27, 2012 3:53 pm

I'll try that, thank you.
Custom Scenery available from http://www.stattosoftware.com/flightgear
statto
 
Posts: 2096
Joined: Fri Jan 25, 2008 9:57 pm


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest

cron