Board index FlightGear Support Compiling

compile error with simgear  Topic is solved

Building FlightGear from source, and in the need for help?

compile error with simgear  

Postby chris_blues » Mon Jan 23, 2012 7:54 am

Hi!

Just wanted to report an compilation error, which occured after I pulled latest git and tried to compile it with brisas script. FGFS aborted, saying it couldn't find simgear 2.7.0, which I saw being compiled seconds before.
So I edited /simgear/simgear/simgear/version.h (it still had 2.5.0 in it) and recompiled simgear. After that FGFS compilation began running...

Hope someone sees this...

Cheers
chris
Don't hesitate to let me know if I'm incorrect or just annoying! As long as you do it gently! :)
Debian testing 64bit - Athlon II 2x2.6GHz - 8GB RAM - GeForce GTS 450
Citation II
User avatar
chris_blues
 
Posts: 1526
Joined: Mon May 03, 2010 1:30 pm
Location: claws of real life
Callsign: chris_blues
Version: GIT
OS: Debian 8 64

Re: compile error with simgear

Postby ThorstenB » Mon Jan 23, 2012 11:58 am

Must be a local problem. Probably you forgot "make install" for simgear - or have several simgear install directories, and flightgear is configured for the wrong one. Certainly sg+fg from git are certainly building fine.
User avatar
ThorstenB
 
Posts: 160
Joined: Fri Nov 19, 2010 9:49 am
Location: Germany
Callsign: D-TB7
Version: GIT
OS: openSUSE

Re: compile error with simgear

Postby chris_blues » Mon Jan 23, 2012 12:32 pm

Don't know why this happened. Maybe there was a problem with the synchronization with git. Brisa's script does all the typing for me, so I don't think it forgot to cmake install. This is how I called up the compilation:
Code: Select all
./download_and_comile.sh -u -a n -p n -j 2 OSG
then
Code: Select all
./download_and_comile.sh -u -a n -p n -j 2 SIMGEAR
which showed up during the compilation as simgear 2.7.0
then
Code: Select all
./download_and_comile.sh -a n -p n -j 2 FGFS
produced the error mentioned above...
Maybe just bad timing, when all commits were in it, except for the version number in version.h ... don't know...
Don't hesitate to let me know if I'm incorrect or just annoying! As long as you do it gently! :)
Debian testing 64bit - Athlon II 2x2.6GHz - 8GB RAM - GeForce GTS 450
Citation II
User avatar
chris_blues
 
Posts: 1526
Joined: Mon May 03, 2010 1:30 pm
Location: claws of real life
Callsign: chris_blues
Version: GIT
OS: Debian 8 64


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest