Board index FlightGear Support Compiling

Compiling GIT on Ubuntu 11.10 via Brisa Script

Building FlightGear from source, and in the need for help?

Compiling GIT on Ubuntu 11.10 via Brisa Script

Postby hihihi100 » Fri Nov 11, 2011 9:57 pm

Hi there:

I am using FGFS GIT without problems, I just need to update it via the Brisa script (sh download_and_compile.sh PLIB and similar ones).
What my terminal shows is:

Package boost-build is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libboost1.46-dev

E: Package 'boost-build' has no installation candidate

That package has been manually installed by me, but I still get that message, plus the most annoying last line about the installation candidate.

How do I contact Brisa to tell him/hear about this?

git pulls to the data folder work fine.

Cheers
hihihi100
 
Posts: 66
Joined: Sat Dec 11, 2010 3:22 pm
IRC name: Flyer
Version: GIT
OS: Ubuntu 11.10

Re: Compiling GIT on Ubuntu 11.10 via Brisa Script

Postby Sealbhach » Fri Nov 11, 2011 10:41 pm

Did you install the replacement package libboost1.46-dev ?

I have Brisa's script running OK on 10.10 64-bit, though I did have a few issues to sort out, the details of which I have forgotten unfortunately.

.
Sealbhach
 
Posts: 942
Joined: Wed Jun 30, 2010 9:17 am

Re: Compiling GIT on Ubuntu 11.10 via Brisa Script

Postby hihihi100 » Fri Nov 11, 2011 11:35 pm

Yes, that package has been installed
hihihi100
 
Posts: 66
Joined: Sat Dec 11, 2010 3:22 pm
IRC name: Flyer
Version: GIT
OS: Ubuntu 11.10

Re: Compiling GIT on Ubuntu 11.10 via Brisa Script

Postby Sealbhach » Sat Nov 12, 2011 12:18 am

Well firstly make sure you have the very latest version of the script

http://www.gitorious.org/fg/fgmeta/blob ... compile.sh

and if you still get that error just remove any reference to "boost-build" in the Distro Packages or Ubuntu Packages section, making sure the replacement package libboost1.46-dev is in those lists.

.
Sealbhach
 
Posts: 942
Joined: Wed Jun 30, 2010 9:17 am

Re: Compiling GIT on Ubuntu 11.10 via Brisa Script

Postby Blairdean » Fri Nov 18, 2011 4:35 am

The PLIB Stable Revision is now 2166.

In the script

PLIB_STABLE_REVISION="2166"

Blair
Blairdean
 
Posts: 27
Joined: Sun May 08, 2011 2:51 pm
Location: Fitzroy Harbour, Ontario
Callsign: CAblair
Version: GIT
OS: Ubuntu

Re: Compiling GIT on Ubuntu 11.10 via Brisa Script

Postby adrian » Fri Nov 18, 2011 12:07 pm

Well, AFAIK FG is being de-PLIB-ified, with most of the old dependencies removed or replace with Openscenegraph. So the old PLIB should be ok to compile against. At least I know I haven't upgraded plib in a long while and it compiles just fine.
adrian
 
Posts: 362
Joined: Wed Sep 15, 2010 2:15 pm

Re: Compiling GIT on Ubuntu 11.10 via Brisa Script

Postby hihihi100 » Fri Nov 18, 2011 8:47 pm

I opened synaptic and got rid of the lib-boost files, all of them. Then I opened a terminal and executed sh download_and_compile.sh OSG, which reinstalled most of the deleted files, plus this line:

svn: 'OpenSceneGraph' is already a working copy for a different URL

I then proceded to execute sh download_and_compile.sh SIMGEAR, only to get:

CMake Error at /usr/share/cmake-2.8/Modules/FindOpenSceneGraph.cmake:199 (message):
ERROR: Version 3.0.0 or higher of the OSG is required. Version 2.9.9 was
found.
Call Stack (most recent call first):
CMakeLists.txt:108 (find_package)


-- Configuring incomplete, errors occurred!
make: *** No rule to make target `Makefile.am', needed by `Makefile.in'. Stop.
make: *** No rule to make target `Makefile.am', needed by `Makefile.in'. Stop.

From the suggested link in this same thread I donwloaded brisa 1.6
hihihi100
 
Posts: 66
Joined: Sat Dec 11, 2010 3:22 pm
IRC name: Flyer
Version: GIT
OS: Ubuntu 11.10

Re: Compiling GIT on Ubuntu 11.10 via Brisa Script

Postby Blairdean » Sun Nov 20, 2011 4:22 pm

On a fresh install of Ubuntu 11.04 (64-bit).

I also had to install libglew1.5-dev package to satisfy a "Map.cxx:58:21: fatal error: GL/glew.h: No such file or directory" error.

Now I just have to figure out how to compile simgear & fgfs/terragear to not use the internal svn calls. For whatever reason the internal svn calls don't work for me. In the log window I get

Code: Select all
1 - '/usr/local/share/flightgear/install/fgfs/TerreSync/'
Airports/K ... terrasync: /build/buildd/subversion-1.6.12dfsg/subversion/libsvn_subr/path.c:114: svn_path_join: Assertion `svn_path_is_canonical(base, pool)' failed.


I got around it by compiling simgear & fgfs with the --without-libsvn switch. With the new CMAKE process, I don't know where to put it... Yet... :?

Blair
Blairdean
 
Posts: 27
Joined: Sun May 08, 2011 2:51 pm
Location: Fitzroy Harbour, Ontario
Callsign: CAblair
Version: GIT
OS: Ubuntu

Re: Compiling GIT on Ubuntu 11.10 via Brisa Script

Postby planetacancun » Sun Feb 05, 2012 6:52 pm

On my Ubuntu 11.10 64 bit I did:
Code: Select all
sudo apt-get install libglew1.5-dev


Then:

Code: Select all
sudo find /usr/ -name glew.h


And there it is:
Code: Select all
/usr/include/GL/glew.h


so ran again:

Code: Select all
sh download_and_compile.sh -j 2 ATLAS


And it worked, Atlas compiles. Why libglew1.5-dev is not included on the download_and_compile.sh script so just works?

Btw, I will share my
Code: Select all
/usr/local/bin/fgupdate.sh
so you guys update easier ;)

Code: Select all
cd ~/fgfs
now=$(date +"%m_%d_%Y")
mv download_and_compile.sh download_and_compile.sh_$now
wget http://www.gitorious.org/fg/fgmeta/blobs/raw/master/download_and_compile.sh
chmod 755 download_and_compile.sh
sh download_and_compile.sh -j 2 ALL
Callsign:Fallen-
Videos: http://youtube.com/planetacancun2
planetacancun
 
Posts: 323
Joined: Thu Jul 30, 2009 4:52 pm
Callsign: Fallen-
IRC name: Fallen-
Version: GIT
OS: Ubuntu

Re: Compiling GIT on Ubuntu 11.10 via Brisa Script

Postby F-JJTH » Sun Feb 05, 2012 11:30 pm

Hi planetacancun,

Thanks you for your report, it helps me ! Now, with libglew1.5-dev, compilation of Atlas is correct ;)
I hope Brisa will see this post and add this package in his script.

Maybe you can send an MP to Brisa to be sure.

Cheers,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: Compiling GIT on Ubuntu 11.10 via Brisa Script

Postby brisa » Mon Feb 06, 2012 9:47 am

Hi, thanks for the error log...

sorry, I have seen the post only today (My fault)
feel free to contact me even on private message if you need something urgent (I will be notified by email).

btw, I have update and tested the script, with your suggestion now Atlas compiles fine :-)

I am sending the script to torsten too (To push it on git)

Thanks and cheers
Francesco Angelo Brisa
User avatar
brisa
 
Posts: 269
Joined: Fri May 16, 2008 7:32 pm
Location: Olgiate Comasco (CO) Italy
Callsign: brisa


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest