Board index FlightGear Support Compiling

VS2017 Compilation Issues (C1083)

Building FlightGear from source, and in the need for help?

VS2017 Compilation Issues (C1083)

Postby FightOrFlight » Fri Oct 04, 2019 9:01 pm

I am trying to compile the Superbuild on Windows 7 and encountered a couple of errors I cannot resolve.
Image

I am not sure if I am missing something or not, or how to resolve it telling me those files cannot be opened.
FightOrFlight
 
Posts: 4
Joined: Fri Oct 04, 2019 8:57 pm

Re: VS2017 Compilation Issues (C1083)

Postby wkitty42 » Fri Oct 04, 2019 9:23 pm

it is saying that they don't exist... non-existent files cannot be opened ;)
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5695
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: VS2017 Compilation Issues (C1083)

Postby FightOrFlight » Fri Oct 04, 2019 9:32 pm

Except the files appear in my explorer, so I'm not sure what to do to make VS recognize them
Image
FightOrFlight
 
Posts: 4
Joined: Fri Oct 04, 2019 8:57 pm

Re: VS2017 Compilation Issues (C1083)

Postby legoboyvdlp » Fri Oct 04, 2019 10:24 pm

Looks like curl itself is not installed, same for the other libraries. It's finding the OSG plugins ok but they reference the other libraries including curl. Did you point cmake to curl with CURL_INCLUDE_DIR etc?
User avatar
legoboyvdlp
 
Posts: 7087
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: VS2017 Compilation Issues (C1083)

Postby FightOrFlight » Fri Oct 04, 2019 11:43 pm

I just made it point to where curl.exe is located but it doesn't seem to have changed anything. I also added it to PATH.
Image
FightOrFlight
 
Posts: 4
Joined: Fri Oct 04, 2019 8:57 pm

Re: VS2017 Compilation Issues (C1083)

Postby legoboyvdlp » Sat Oct 05, 2019 9:07 am

There'll be other commands to run too - libraries usually have a include directory and a lib directory

If you run CMAKE it shouldn't generate a build solution if it can't find what it needs so I'm not sure how you got as far as Visual Studio
User avatar
legoboyvdlp
 
Posts: 7087
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: VS2017 Compilation Issues (C1083)

Postby FightOrFlight » Fri Oct 11, 2019 2:11 pm

I tried adding the missing libraries to CMake GUI as I discovered them, but the generated project doesn't seem to care. It gives me an OPENAL_LIBRARY warning despite having it defined in CMake GUI.
Image
FightOrFlight
 
Posts: 4
Joined: Fri Oct 04, 2019 8:57 pm


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest