Board index FlightGear The FlightGear project

Please stop ATIS playing always when loading

Questions about the FlightGear organisation, website, wiki etc.

Please stop ATIS playing always when loading

Postby it0uchpods » Sun Jun 04, 2017 1:02 am

Hi,
I don't know about others, but this thing which plays the ATIS when loading the default airport (for the last 2-3 FGFSs) needs to go. It's really annoying to constantly turn it off. Can't it at least be optional?

Kind Regards,
Josh
it0uchpods/WTF411

Do not expect immediate responses. I do not log in often. I do not answer PMs from non-admins.
I only monitor IDG Development and Support Threads. Everything else is ignored.
Download High Quality Aircraft from it0uchpods Hanger
User avatar
it0uchpods
 
Posts: 3304
Joined: Tue Oct 06, 2015 12:51 pm
Version: 2018.1.1
OS: Windows 10 Pro x64

Re: Please stop ATIS playing always when loading

Postby wkitty42 » Wed Jun 07, 2017 9:13 pm

the defaults for the airport are loaded at startup... these defaults include the radios being tuned... if you don't want to hear the ATIS on the radio, your craft should start with the radios turned off or their volume turned all the way down... that's my experience, anyway...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4300
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Please stop ATIS playing always when loading

Postby it0uchpods » Wed Jun 07, 2017 9:17 pm

But I can't do that for all planes.

Why does the ATIS play when you get to the default airport? That is quite unrealistic. The pilot needs to tune the ATIS in himself, it doesn't just appear when the plane is powered.
it0uchpods/WTF411

Do not expect immediate responses. I do not log in often. I do not answer PMs from non-admins.
I only monitor IDG Development and Support Threads. Everything else is ignored.
Download High Quality Aircraft from it0uchpods Hanger
User avatar
it0uchpods
 
Posts: 3304
Joined: Tue Oct 06, 2015 12:51 pm
Version: 2018.1.1
OS: Windows 10 Pro x64

Re: Please stop ATIS playing always when loading

Postby wkitty42 » Wed Jun 07, 2017 11:07 pm

i didn't say anything about the default airport ;)

the frequencies are loaded by default for whatever airport you choose to start at... this all comes from the data in the apt.dat or similar...

remember, many folks just want to play a game... they want to just jump in and go flying with everything working as if they had done it themselves... if you don't want your craft to pop up with the radio playing, then someone has to adjust the craft to allow for starting with the radio off or forcing it off all the time or the same for the volume... some might even force the radio off and to start at the lowest frequency the radio can handle... some might have an option to retain the last frequency and have it in place when starting anew... i remember the c172p going through the steps to do this and be able to save or not for the next start...

remember, not all craft have the same realism standards or settings... many, it seems, go for the FDM being the first realistic thing and then maybe the model and animations... eventually, they might get around to the external world realism stuff like the radios and such...

[EDIT]

i forgot to suggest that maybe you can do what you want via a property? --prop=/sim/radio/volume=0 or something like that... you'll have to find the actual properties, though... remember that there's two radios in may craft so there may be more than one radio volume property to be set...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4300
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Please stop ATIS playing always when loading

Postby it0uchpods » Thu Jun 08, 2017 3:08 am

*ANGRY FACE*

I am disabling this on my planes, and forcing other radio values. I find it unrealistic and silly.
it0uchpods/WTF411

Do not expect immediate responses. I do not log in often. I do not answer PMs from non-admins.
I only monitor IDG Development and Support Threads. Everything else is ignored.
Download High Quality Aircraft from it0uchpods Hanger
User avatar
it0uchpods
 
Posts: 3304
Joined: Tue Oct 06, 2015 12:51 pm
Version: 2018.1.1
OS: Windows 10 Pro x64

Re: Please stop ATIS playing always when loading

Postby MMW » Thu Jun 08, 2017 4:04 am

it0uchpods wrote in Thu Jun 08, 2017 3:08 am:
I am disabling this on my planes, and forcing other radio values.


How do you do this on your planes?
DrivingGear - Automobile for Flightgear: https://dgcarz.wordpress.com/
MMW
 
Posts: 81
Joined: Sun Apr 16, 2017 5:52 am

Re: Please stop ATIS playing always when loading

Postby Thorsten » Thu Jun 08, 2017 5:53 am

Why does the ATIS play when you get to the default airport? That is quite unrealistic. The pilot needs to tune the ATIS in himself, it doesn't just appear when the plane is powered.


I dunno... usually a radio stays at the last frequency tuned in when you switch it off. The default FG setting sort of assume you're based at the default airport, so pretend that you parked your aircraft there last time (which is why it is there) and switched the radio off without selecting a different frequency - and suddenly it all becomes realistic.

If you don't like that, use

--com1=<frequency> and
--com2=<frequency>

on the commandline to pre-set to whatever you fancy.
Thorsten
 
Posts: 9434
Joined: Mon Nov 02, 2009 8:33 am

Re: Please stop ATIS playing always when loading

Postby dg-505 » Thu Jun 08, 2017 11:48 am

With every new FG release every com and nav radio, the ADFs and the DME get a new frequency preset that suits the respective default airport.
This presets are stored in $FGData/location-presets.xml: https://sourceforge.net/p/flightgear/fgdata/ci/next/tree/location-presets.xml

For the last two or three release cycles it was my humble self who set these presets. I used the frequencies that were in my opinion quite suitable for that airport.
For Comms: GND, TWR, ATIS, etc...
For Navs: nearby VOR-DME, ILS Localizer, another VOR, etc.....
For DME: A DME selected on one nav radio....
For ADFs: A few nearby NDBs....

If you think you have a better idea for these presets you are very welcome to submit a corresponding merge request to the FGData repository
It's not just a hobby. I'ts a passion: FLYING !!

DHC-6 Twin Otter development
User avatar
dg-505
 
Posts: 614
Joined: Mon Jun 02, 2014 2:36 pm
Location: Hessen, Germany
Version: next
OS: Ubuntu 16.04

Re: Please stop ATIS playing always when loading

Postby D-ECHO » Thu Jun 08, 2017 1:55 pm

What would you think about Tuning the Radio to EG twr Frequency when starting FG? Considering RL flows that seems more realistic to me...
User avatar
D-ECHO
 
Posts: 1333
Joined: Sat May 09, 2015 12:31 pm

Re: Please stop ATIS playing always when loading

Postby dg-505 » Thu Jun 08, 2017 2:44 pm

Well, that sounds good to me.
Currently the second comm radio has Boston ATIS as active frequency, and Boston GND as standby freq.

I see that it can be a bit annoying when you start FG and ATIS does always babble in the background.

As I currently have absolutely no time for FG (unfortunately), would you mind to change this (maybe just change active and standby freq in location-presets.xml) and make a merge request?
It's not just a hobby. I'ts a passion: FLYING !!

DHC-6 Twin Otter development
User avatar
dg-505
 
Posts: 614
Joined: Mon Jun 02, 2014 2:36 pm
Location: Hessen, Germany
Version: next
OS: Ubuntu 16.04

Re: Please stop ATIS playing always when loading

Postby D-ECHO » Thu Jun 08, 2017 3:43 pm

Im away for two weeks and very stressed afterwards but after that I can try
User avatar
D-ECHO
 
Posts: 1333
Joined: Sat May 09, 2015 12:31 pm

Re: Please stop ATIS playing always when loading

Postby Torsten » Mon Jun 12, 2017 12:23 pm

It was me who invented the comm/nav frequency scheme for our first non-SFO release and the rationale behind it was to preset useful frequencies in the order they might come in handy and to reduce workload when the pilot is probably busy taxiing or flying. This was based on a habit built in approx. 1000h of single-hand IFR flying in GA-type aircraft.
The result is:
on the first radio
1. use ATIS - this is the first thing you want to do after feeling comfortable in the cockpit.
2. stby GND or DELIVERY - whatever is needed to get the startup clearance.
on the second radio
1. use TWR - usually handed over by GND while taxiing or sitting at the holding point doing the runup.
2. stby DEP to switch it on while climbing shortly after TO

This enables to switch between radio stations by either flip USE/STBY or by selecting the radio on the intercom. If you have the capacity, you can also listen to TWR while still being on GND to get an idea of airport activities.

I still think this is quite a useful setup, of course other pilots may have better ideas. But I would like to keep it unless somebody has a good argument against it.
I also think spoken atis reflecting actual weather is a pretty cool feature (but I - as the developer - am biased, of course)

If you don't like the spoken ATIS, simply don't tune to an ATIS frequency when starting on an airport. Or switch off the radio. Or turn down the volume.

Torsten
flightgear.org - where development happens.
User avatar
Torsten
 
Posts: 607
Joined: Fri Feb 01, 2008 9:22 pm
Location: near Hamburg, Germany
Callsign: offline
Version: next
OS: Linux


Return to The FlightGear project

Who is online

Users browsing this forum: No registered users and 1 guest