Board index FlightGear The FlightGear project

FlightGear v3.4.1?

Questions about the FlightGear organisation, website, wiki etc.

FlightGear v3.4.1?

Postby Red Leader » Fri Feb 27, 2015 5:46 pm

Hi all,

I've noticed in the Git logs that recently the version of the 3.4 release branches (branch: release/3.4.0) for fg/flightgear, fg/fgdata, and fg/simgear have been bumped from 3.4.0 to 3.4.1.
Commits:
I have two questions on this:
  1. Does this mean that there will be a FlightGear v3.4.1 release?
  2. And if so, what has changed for this release? I'm guessing the stuff merged in from several merge requests recently.

Regards,
Red Leader
For once you have tasted flight you will walk the earth with your eyes turned skywards, for there you have been and there you will long to return.
Leonardo da Vinci

Projects:
BAe Sea Harrier FA2Scripted AI Objects frameworkDocumenting Nasal
Red Leader
 
Posts: 22
Joined: Sat Oct 25, 2014 7:52 pm
Location: United Kingdom
Callsign: Red-Led
Version: 2017.3.1
OS: Microsoft Windows 10

Re: FlightGear v3.4.1?

Postby Hooray » Fri Feb 27, 2015 5:58 pm

some pretty important bug fixes, as per the devel list archives (i.e fixing a massive memory leak and other stuff breaking features/FG for some users)

http://sourceforge.net/p/flightgear/mai ... /33468960/
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11469
Joined: Tue Mar 25, 2008 8:40 am

Re: FlightGear v3.4.1?

Postby Jabberwocky » Tue Mar 03, 2015 2:01 am

Does that mean, we get 3.4.1 also via the Saiarcot ppa? Or do we need a manual update?
Jabberwocky
Retired
 
Posts: 1319
Joined: Sat Mar 22, 2014 7:36 pm
Callsign: JWOCKY
Version: 3.0.0
OS: Ubuntu 14.04

Re: FlightGear v3.4.1?

Postby [Lemmy] » Sat Mar 14, 2015 8:31 am

So... will there be official 3.4.1 source tarballs? when?
[Lemmy]
 
Posts: 44
Joined: Mon Jun 18, 2012 7:58 pm

Re: FlightGear v3.4.1?

Postby OE-PH1 » Sat Mar 14, 2015 10:38 am

I don't know anything about building these versions and stuff. As many others, I am not able to compile a new version on my own (I'm just a MS win8 user ;-) ). Reading through the postings, I see that the VASI/PAPI problem is already solved and some experts build their new versions from source. I understand, that many things could be fixed and improved. But because it's VERY important to have the VASI/PAPI feature, why not just give us a 3.4.1? Is this too complicated? If not, I would suggest to provide this new version for official download (the download button on home page).
Thank you very much!
I am a member of the A330 dev team
User avatar
OE-PH1
 
Posts: 153
Joined: Sun Oct 26, 2014 1:14 pm
Location: LOWI
Callsign: OE-PH1
Version: 2016.4
OS: Win10

Re: FlightGear v3.4.1?

Postby VicMar » Sun Mar 15, 2015 8:49 am

Try downoading the latest Jenkins Nightly. It will include any improvements made to date. it might still contain some bugs, but be usable.

http://download.flightgear.org/builds/nightly/

HTH

Vic
Time flies like an arrow
Fruit flies like a banana
User avatar
VicMar
 
Posts: 2061
Joined: Sun Apr 06, 2008 5:53 pm
Location: Lancing. UK (EGKA)
Callsign: VicMar
Version: 2018.3.1
OS: OS X 10.12.6

Re: FlightGear v3.4.1?

Postby dutchman » Sun Mar 15, 2015 11:24 am

Jenkins nightly builds only shows 3.5 versions. Flightgear.org offers 3.4
So where is the 3.4.1 version?
A propeller is just a big fan in front of the plane used to keep the pilot cool.
When it stops, you can watch him start sweating.
dutchman
 
Posts: 52
Joined: Wed Feb 06, 2013 11:10 pm
Version: 2018.2.2
OS: WIN7-64

Re: FlightGear v3.4.1?

Postby zlsa » Sun Mar 15, 2015 4:03 pm

3.5 is the latest development version; it's newer than 3.4.1 and will have more issues related to new features and development.
zlsa
 
Posts: 145
Joined: Fri Feb 14, 2014 2:29 am
Callsign: N275A
Version: 3.5 git
OS: Linux

Re: FlightGear v3.4.1?

Postby clrCoda » Sun Mar 15, 2015 4:54 pm

the 3.4.1 version is currently disabled at jenkins. I was able to get one days ago, but now that I've heard that the point sprites are fixed, I have only found the disabled 3.4.1 there. It might even be listed as 3.4
Ray St. Marie
clrCoda
 
Posts: 1228
Joined: Wed Apr 07, 2010 11:04 am


Return to The FlightGear project

Who is online

Users browsing this forum: No registered users and 1 guest