Board index FlightGear Development Aircraft

Textures get handled wrongly by FG?

Questions and discussion about creating aircraft. Flight dynamics, 3d models, cockpits, systems, animation, textures.

Textures get handled wrongly by FG?

Postby Necolatis » Thu Oct 04, 2018 7:45 pm

Unless I am zoomed very much in, textures seems to have trouble in FG, this has irritated me for years.

1 - Its not UV, the UV I test is fine.
2 - Its not shaders, even without model shaders on I get it.
3 - Its not the textures, they are fine. And its not alpha in the textures.
4 - The option --texture-filtering= does not help.

It happen at specific angles and distances. (which leads me to think the textures are loaded wrongly, mipmapping gone wrong or something)

Look at picture 1, see the strange light artifact left of the decal? Well when I zoom in in picture 2 it goes away.
Another issue is extreme widening of decals. Look at the wing numbers in picture 3. When I change the angle in picture 4 the number '3' get to be double as wide.

When I use normal mapping, I get tons of artifacts, and yes the normal maps is fine, I test them in blender. I tried replace the normal mapping algorithm in the GLSL model-deffered shaders by different algorithms, even tried bypassing the Binormal and Tangent generation and do it myself in the shader. Also tried different filters. The artifacts is still there (at certain viewing angles). I suspect this is the same problem as on the liveries.

Now if I disable livery selection in the aircraft, voila, the texture that is loaded by OSG AC3D loader works perfect. So its something in FG, not OSG.

Have anyone observed the same?

Image
Image
Image
Image
"Airplane travel is nature's way of making you look like your passport photo."
— Al Gore


Hangar: https://sites.google.com/site/fghangar/
User avatar
Necolatis
 
Posts: 1872
Joined: Mon Oct 29, 2012 12:40 am
Location: EKOD
Callsign: Leto
IRC name: Neco
Version: 2018.2.2
OS: Windows 10 Pro

Re: Textures get handled wrongly by FG?

Postby Necolatis » Fri Oct 05, 2018 4:07 am

From the mailing-list:

This is the 'fast' on the fly mipmap generator coupled with the on-the-fly
texture compressor.
There are two ways around the issue:
1. disable texture compression (if you have the GPU resources)
--prop:/sim/rendering/texture-compression=off
or
2. use dds textures with precomputed mipmaps.

Regards,
Emilian
"Airplane travel is nature's way of making you look like your passport photo."
— Al Gore


Hangar: https://sites.google.com/site/fghangar/
User avatar
Necolatis
 
Posts: 1872
Joined: Mon Oct 29, 2012 12:40 am
Location: EKOD
Callsign: Leto
IRC name: Neco
Version: 2018.2.2
OS: Windows 10 Pro


Return to Aircraft

Who is online

Users browsing this forum: No registered users and 11 guests