Board index FlightGear Development Aircraft

EC130-B4: major update

Questions and discussion about creating aircraft. Flight dynamics, 3d models, cockpits, systems, animation, textures.

EC130-B4: major update

Postby mhab » Thu Mar 27, 2014 11:55 pm

Hello

For the fans of helicopters in general and the fans of the Airbus Helicopters EC130-B4 in particular I am happy to announce that work continued after FG 3.0 release.

Some interesting additions were done since January 2014 with
    o three new liveries
    o an exciting new searchlight (Trakkabeam A 800)
    o improved Rembrandt behavior of the searchlights
    o many additonal antennas
    o new dialogs / extended and updated User Interface
    ...

See a more comprehensive description at: http://wiki.flightgear.org/Eurocopter_EC130_B4#Updates_after_FG_3.0_release
If you want to try it check it out from the development repository: https://gitorious.org/ec130/

Have fun and let me know if something is not working as expected or should otherwise be corrected ...

B.T.W.: My twitter postings of EC130-B4 screenshots (see https://twitter.com/mhabtwi) received some honorable acceptance from both

Mike-DE
mhab
 
Posts: 410
Joined: Thu Apr 18, 2013 10:59 pm
Callsign: D-MIKE
Version: 2019.1.1
OS: Win10

Re: EC130-B4: major update

Postby Thorsten » Fri Mar 28, 2014 7:15 am

I don't know if I'm the only one, but I get random crashes with the EC-130, unpredictably, but with a frequency of on average perhaps once every 2-3 hours. The symptom is that the screen gets grey and FG hangs. The log file seems to indicate that there's a NaN generated somewhere in the Nasal which then propagates through various systems and ultimately makes the position NaN, at which point the FG core doesn't seem to know what to do.

Very nice work otherwise.
Thorsten
 
Posts: 11206
Joined: Mon Nov 02, 2009 8:33 am

Re: EC130-B4: major update

Postby mhab » Fri Mar 28, 2014 2:00 pm

Hello

Thanks for the remark and flowers :)

Did you notice if the Nasal NaN problem comes in conjunction with a red ENG P warning on the control panel ?

I noticed that every now and then the red ENG P warning doesn't go away even if a proper startup routine is followed, and I always thought it is a planned failure to have a more realistic behavior ... (it is also mentioned on the Wiki page ...).

Sometimes in autostart I also need to turn on the FUEL pump again after the rotor reached 200+ rpm and most of the time not ...

This behaviour was there since I came across the EC130 and I have not yet analized the background of it.

Mike-DE
mhab
 
Posts: 410
Joined: Thu Apr 18, 2013 10:59 pm
Callsign: D-MIKE
Version: 2019.1.1
OS: Win10

Re: EC130-B4: major update

Postby Thorsten » Sat Mar 29, 2014 7:26 am

Yes, I'm also getting the engine pressure NaN occasionally (maybe every 5th time I start the engines?), but I believe that's unrelated. I have completed an hour of flight with the warning light on and no crash, and I've had a crash without the light on.

I have never tried autostart, so I can't comment about that.

There is something funky going on in the EC-130 Nasal, and perhaps Heiko should be pinged to have a look. I really like taking the EC-130 for a spin (in fact I like the flight dynamics better than the EC-135), but the problem that you might be going grey halfway into a flight is a spoiler...
Thorsten
 
Posts: 11206
Joined: Mon Nov 02, 2009 8:33 am

Re: EC130-B4: major update

Postby rominet » Tue Mar 24, 2015 12:50 pm

Hello,

This helicopter is great, it's a pity these crashes regularly spoil the experience. I also have the ENG P warning and the need to re-activate the fuel pump during autostart from time to time, but these are minor inconveniences. The seemingly-random crashes as described here are more annoying. I have captured the fgfs terminal output for two of them:

Code: Select all
Enabling ATI viewport hack
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/mm/flightgear-data/scenery-terrasync'.
default catalog not found, installing...
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
environment init
towing is active!

_____   _____      __   ____     ___       ____    _  _
 |  ____| / ____|    /_ | |___ \   / _ \     |  _ \  | || |
 | |__    | |         | |  __) |  | | | |    | |_) | | || |_
 |  __|   | |         | | |__ <   | | | |    |  _ <  |__   _|
 | |____  | |___      | |  __) |  | |_| |    | |_) |    | |
 |______| \_____|     |_| |____/   \___/     |____/     |_|

CS55 pictorial navigation system initialized
catalog download failure:http://fgfs.goneabitbursar.com/pkg/3.4.0/default-catalog.xml
This aircraft does not use the latest yasim configuration version.
Electrical System ... ok
setting FLASH COUNTER
loading LOWI PAPI r26 r08
loading doors
setting lights
setting lights finished - use 121.875 Mhz on COM2 for LOJO - OAMTC main helipad lights
loading De-Iceing Truck
Multiplayer mode active!
Nasal getprop: property /position[0]/latitude-deg[0] is NaN
Nasal getprop: property /position[0]/longitude-deg[0] is NaN
Nasal getprop: property /position[0]/altitude-ft[0] is NaN
Nasal runtime error: nil used in numeric context
  at /usr/share/games/flightgear/Nasal/geo.nas, line 315
  called from: /mnt/mm/flightgear-data/scenery-misc/EDNY/Objects/e010n40/e011n47/LOWI_app_light_papi_rwy26_set.xml, line 28
  called from: /mnt/mm/flightgear-data/scenery-misc/EDNY/Objects/e010n40/e011n47/LOWI_app_light_papi_rwy26_set.xml, line 48
Nasal getValue: property /velocities[0]/vertical-speed-fps[0] is NaN
Nasal runtime error: nil used in numeric context
  at /mnt/mm/flightgear-data/Aircraft-3.4.extra/ec130/Nasal/ec130.nas, line 1005
Nasal getprop: property /velocities[0]/airspeed-kt[0] is NaN
Nasal runtime error: nil used in numeric context
  at /mnt/mm/flightgear-data/Aircraft-3.4.extra/ec130/Nasal/woolthread.nas, line 8
Nasal getValue: property /orientation[0]/roll-deg[0] is NaN
Nasal runtime error: nil used in numeric context
  at /mnt/mm/flightgear-data/Aircraft-3.4.extra/ec130/Systems/kcs55.nas, line 119
  called from: /mnt/mm/flightgear-data/Aircraft-3.4.extra/ec130/Systems/kcs55.nas, line 428
  called from: /mnt/mm/flightgear-data/Aircraft-3.4.extra/ec130/Systems/kcs55.nas, line 433
Nasal getprop: property /accelerations[0]/pilot-g[0] is NaN
Nasal getprop: property /rotors[0]/main[0]/blade[0]/incidence-deg[0] is NaN
Nasal getprop: property /rotors[0]/main[0]/blade[1]/incidence-deg[0] is NaN
Nasal getprop: property /rotors[0]/main[0]/blade[2]/incidence-deg[0] is NaN
Nasal runtime error: nil used in numeric context
  at /mnt/mm/flightgear-data/Aircraft-3.4.extra/ec130/Nasal/rotorloads.nas, line 29
AL Error (sound manager): Invalid Value at update


In this one, it seems the PAPI lights at LOWI were unhappy to be unable to know my position. In the second log, as reproduced below, no PAPI lights but two multiplayer issues:
  • errors caused by the Concorde;
  • unable to send my position since it is NaN.

In both cases (PAPI lights and FGMultiplayMgr::SendMyPosition), the NaN seems to be the cause of the problem, but what is causing it?

Code: Select all
Enabling ATI viewport hack
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/mm/flightgear-data/scenery-terrasync'.
default catalog not found, installing...
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
environment init
towing is active!

_____   _____      __   ____     ___       ____    _  _
 |  ____| / ____|    /_ | |___ \   / _ \     |  _ \  | || |
 | |__    | |         | |  __) |  | | | |    | |_) | | || |_
 |  __|   | |         | | |__ <   | | | |    |  _ <  |__   _|
 | |____  | |___      | |  __) |  | |_| |    | |_) |    | |
 |______| \_____|     |_| |____/   \___/     |____/     |_|

CS55 pictorial navigation system initialized
catalog download failure:http://fgfs.goneabitbursar.com/pkg/3.4.0/default-catalog.xml
This aircraft does not use the latest yasim configuration version.
Electrical System ... ok
Multiplayer mode active!
Error reading panel:
Cannot open file ../../Instruments/wxradar.xml
 at /mnt/mm/flightgear-data/Aircraft-3.4.extra/Concorde/Panels/Concorde-console-captain.xml,
line 55, column 2
 (reported by SimGear Property Reader)
Error reading panel:
Cannot open file ../../Instruments/wxradar.xml
 at /mnt/mm/flightgear-data/Aircraft-3.4.extra/Concorde/Panels/Concorde-console-copilot.xml,
line 55, column 2
 (reported by SimGear Property Reader)
Concorde livery update
Error reading panel:
Cannot open file ../../Instruments/wxradar.xml
 at /mnt/mm/flightgear-data/Aircraft-3.4.extra/Concorde/Panels/Concorde-console-captain.xml,
line 55, column 2
 (reported by SimGear Property Reader)
Error reading panel:
Cannot open file ../../Instruments/wxradar.xml
 at /mnt/mm/flightgear-data/Aircraft-3.4.extra/Concorde/Panels/Concorde-console-copilot.xml,
line 55, column 2
 (reported by SimGear Property Reader)
Concorde livery update
FGMultiplayMgr::SendMyPosition - Local data is invalid (NaN). Data not transmitted.
Nasal getValue: property /velocities[0]/vertical-speed-fps[0] is NaN
Nasal runtime error: nil used in numeric context
  at /mnt/mm/flightgear-data/Aircraft-3.4.extra/ec130/Nasal/ec130.nas, line 1005
Nasal getprop: property /velocities[0]/airspeed-kt[0] is NaN
Nasal runtime error: nil used in numeric context
  at /mnt/mm/flightgear-data/Aircraft-3.4.extra/ec130/Nasal/woolthread.nas, line 8
Nasal getValue: property /orientation[0]/roll-deg[0] is NaN
Nasal runtime error: nil used in numeric context
  at /mnt/mm/flightgear-data/Aircraft-3.4.extra/ec130/Systems/kcs55.nas, line 119
  called from: /mnt/mm/flightgear-data/Aircraft-3.4.extra/ec130/Systems/kcs55.nas, line 428
  called from: /mnt/mm/flightgear-data/Aircraft-3.4.extra/ec130/Systems/kcs55.nas, line 433
AL Error (sound manager): Invalid Value at update


It would be great if someone were able to fix this crash! :)

TIA
rominet
 
Posts: 557
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

Re: EC130-B4: major update

Postby mhab » Tue Mar 24, 2015 6:08 pm

Hello

Thanks for the detailed info and the positive feedback.

Some Info:
ENG P: The ENG P bug is already fixed in development version. (see below)

FUEL P: The need to reactivate FUEL P sometimes is described in the Wiki.
There is even a shortcut available to do that. As for now I consider this "normal behavior".

Development Repository:
As the EC130B4 is in steady progress, please check the Wiki http://wiki.flightgear.org/Eurocopter_EC130_B4 for ongoing development and latest updates.
The development repository has been moved to gitlab https://gitlab.com/mhab/ec130 (link also updated in Wiki) Please feel free to create "issues" in gitlab.
Just now I pushed some hopefully helpful code improvements related to these "nasty" bugs.

Also see this discussion http://forum.flightgear.org/viewtopic.php?f=30&t=25754 where I recently posted about my problems with the Nasal crashes.

EDIT: My impression is that "dynamic cockpit view" option set to OFF helps to avoid crashes.

About me: I picked up the EC130 about 2 years ago, after Heiko (HHS) had made fantastic work in building this heli. We are still in contact and discussion about ongoing changes.
I focussed on 3D model improvements, new liveries and animations up to now and try to slowly improve some of the Nasal issues.

Thanks for using this heli
and for any helpful contribution
Mike-DE
mhab
 
Posts: 410
Joined: Thu Apr 18, 2013 10:59 pm
Callsign: D-MIKE
Version: 2019.1.1
OS: Win10

Re: EC130-B4: major update

Postby rominet » Wed Mar 25, 2015 5:15 pm

Thanks for your answer, mhab!

mhab wrote in Tue Mar 24, 2015 6:08 pm:FUEL P: The need to reactivate FUEL P sometimes is described in the Wiki.
There is even a shortcut available to do that. As for now I consider this "normal behavior".


Well, none of the keyboard shortcuts using AltGr (ctrl+alt in the binding files) work here (Debian GNU/Linux unstable). In my personal bindings, I often use the <mod-super> modifier, which corresponds to the (Windows) Logo key in my setup. But this requires me to modify ec130b4-set.xml...

mhab wrote in Tue Mar 24, 2015 6:08 pm:Development Repository:
As the EC130B4 is in steady progress, please check the Wiki http://wiki.flightgear.org/Eurocopter_EC130_B4 for ongoing development and latest updates.
The development repository has been moved to gitlab https://gitlab.com/mhab/ec130 (link also updated in Wiki) Please feel free to create "issues" in gitlab.
Just now I pushed some hopefully helpful code improvements related to these "nasty" bugs.


Ah, I had tried a repository on SourceForge, found the soon-to-disappear one on gitorious.org, but didn't know about that one. Thanks for the info, I've tried it today with FG 3.4. More on this below.

mhab wrote in Tue Mar 24, 2015 6:08 pm:Also see this discussion http://forum.flightgear.org/viewtopic.php?f=30&t=25754 where I recently posted about my problems with the Nasal crashes.


Great to see you are working on this!

mhab wrote in Tue Mar 24, 2015 6:08 pm:EDIT: My impression is that "dynamic cockpit view" option set to OFF helps to avoid crashes.


I don't think this is the case. At least, I never have this option enabled and unfortunately had the dreaded crash with today's Git version of the repo you mentioned (d96fdafe05a7b2f17c1daa9c8c76f68d7b950205). I don't know if it's related, but I was in multiplayer mode and had the crash after about 15 minutes, while I have flown about one hour without any crash this morning with multiplayer mode off. Here is the log for the session that had the crash:

Code: Select all
Enabling ATI viewport hack
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/mm/flightgear-data/scenery-terrasync'.
default catalog not found, installing...
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
environment init
towing is active!

_____   _____      __   ____     ___       ____    _  _
 |  ____| /  ___|    /_ | |__  \   / _ \     |  _ \  | || |
 | |__    | |         | |  __) |  | | | |    | |_) | | || |_
 |  __|   | |         | | |__ <   | | | |    |  _ <  |__   _|
 | |____  | |___      | |  __) |  | |_| |    | |_) |    | |
 |______| \_____|     |_| |____/   \___/     |____/     |_|

CS55 pictorial navigation system initialized
catalog download failure:http://fgfs.goneabitbursar.com/pkg/3.4.0/default-catalog.xml
This aircraft does not use the latest yasim configuration version.
Electrical System ... ok
Multiplayer mode active!
Nasal getValue: property /velocities[0]/vertical-speed-fps[0] is NaN
Nasal runtime error: nil used in numeric context
  at /mnt/mm/flightgear-data/aircrafts-misc/ec130/Nasal/ec130.nas, line 2284
Nasal getprop: property /velocities[0]/airspeed-kt[0] is NaN
Nasal runtime error: nil used in numeric context
  at /mnt/mm/flightgear-data/aircrafts-misc/ec130/Nasal/ec130.nas, line 1119
Nasal getValue: property /orientation[0]/roll-deg[0] is NaN
Nasal runtime error: nil used in numeric context
  at /mnt/mm/flightgear-data/aircrafts-misc/ec130/Systems/kcs55.nas, line 119
  called from: /mnt/mm/flightgear-data/aircrafts-misc/ec130/Systems/kcs55.nas, line 428
  called from: /mnt/mm/flightgear-data/aircrafts-misc/ec130/Systems/kcs55.nas, line 433
AL Error (sound manager): Invalid Value at generate buffer
AL Error (sound manager): Invalid Value at generate buffer
AL Error (sound manager): Invalid Value at generate buffer
AL Error (sound manager): Invalid Value at generate buffer
AL Error (sound manager): Invalid Value at generate buffer
AL Error (sound manager): Invalid Value at update


Note that I have fixed a little bug before this session, otherwise you would also have seen this:

Code: Select all
16:35:38 : Attitude Indicator failure level 0%
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/mm/flightgear-data/scenery-terrasync'.
default catalog not found, installing...
Failed to load submodel: Model file not found: 'A800/searchlight_a800.ac'
        from:/mnt/mm/flightgear-data/aircrafts-misc/ec130/Models/SearchLight/searchlight_A800.xml
Could not find at least one of the following objects for animation: 'slight_mount'
Could not find at least one of the following objects for animation: 'searchlight_A800'
environment init
towing is active!


The problem is that the file in the Git repo is A800/searchlight_A800.ac and not A800/searchlight_a800.ac as indicated in Models/SearchLight/searchlight_A800.xml (Unix/Linux filesystems are case-sensitive). Should I file an issue or a pull request on gitlab about this?

Code: Select all
diff --git a/Models/SearchLight/searchlight_A800.xml b/Models/SearchLight/searchlight_A800.xml
index 7d48db6..9828e84 100644
--- a/Models/SearchLight/searchlight_A800.xml
+++ b/Models/SearchLight/searchlight_A800.xml
@@ -24,7 +24,7 @@
 
 <PropertyList>
 
-  <path>A800/searchlight_a800.ac</path>
+  <path>A800/searchlight_A800.ac</path>
 
   <!-- search light cone, derived from Alpha-Jet -->
 


Of course, I'm talking about problems here, but I like the new features (being able to set the altimeter with the mouse wheel on the knob, main rotor shadow, white arc representing its rotation speed...).

Concerning the altimeter setting: it would be very useful to display the QNH value while the knob is being rotated, as in the SenecaII, but with both units if possible (inHg and hPa)---the SenecaII only displays inHg here.

Thank you! :)
rominet
 
Posts: 557
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

Re: EC130-B4: major update

Postby mhab » Wed Mar 25, 2015 7:56 pm

Hello

Sourceforge Version of EC130 relates to git TAG FG_3.5 and was a near miss for FG 3.4 release :( .

I have fixed the typo in the Searchlight XML in gitlab. already pushed
I will take a look into QNH display ...
EDIT: QNH display is Issue #1 in gitlab EC130 project now

Sorry to hear about keyboard problems in Linux: please check that with FG development ...

Remark from developers' point of view:
I would really appreciate to deal with issues in gitlab, each one related to one specific problem. That way problems can be dealt with 1 by 1.

I can understand it is easier to collect everything in a composite mail, but that is troublesome for the one on the doing side, as it leaves lots of open ends for a long time ...

Thanks for the feedback and
wishing everyone a step by step improved flying experiece
Mike-DE
mhab
 
Posts: 410
Joined: Thu Apr 18, 2013 10:59 pm
Callsign: D-MIKE
Version: 2019.1.1
OS: Win10

Re: EC130-B4: major update

Postby rominet » Wed Mar 25, 2015 9:11 pm

mhab wrote in Wed Mar 25, 2015 7:56 pm:Sorry to hear about keyboard problems in Linux: please check that with FG development ...

Right, I understand it is not a problem specific to this helicopter.

mhab wrote in Wed Mar 25, 2015 7:56 pm:Remark from developers' point of view:
I would really appreciate to deal with issues in gitlab, each one related to one specific problem. That way problems can be dealt with 1 by 1.

I can understand it is easier to collect everything in a composite mail, but that is troublesome for the one on the doing side, as it leaves lots of open ends for a long time ...

OK, I did this way because it went with the discussion. I will use more specific gitlab functions next time.

Thanks, have a nice evening.
rominet
 
Posts: 557
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

Re: EC130-B4: major update

Postby mhab » Sat Mar 28, 2015 10:51 pm

Hello

I think some good news about the EC130 is here to present ... :)
I made a ton of improvements in the Nasal code and I think the situations for the crashes should have improved considerably, if not solved at all.

I would like to encourage everyone interested to test the latest gitlab version at: https://gitlab.com/mhab/ec130

Have fun
Mike-DE
mhab
 
Posts: 410
Joined: Thu Apr 18, 2013 10:59 pm
Callsign: D-MIKE
Version: 2019.1.1
OS: Win10

Re: EC130-B4: major update

Postby rominet » Sun Mar 29, 2015 1:25 pm

Hi,

Thank you for the updates! I am eager to see if you managed to fix the crash. I finished the QNH tooltip you started: now the value is displayed both in inHg and hPa. cf. merge request at https://gitlab.com/mhab/ec130/merge_requests/1.

See you
rominet
 
Posts: 557
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

Re: EC130-B4: major update

Postby mhab » Mon Mar 30, 2015 9:16 am

Hello

Merge was accepted, but now please see discussion http://forum.flightgear.org/viewtopic.php?f=4&t=25797 for problems with hover tooltips.
The change for altimeter tooltip causes Nasal runtime errors afterwards, for reasons unclear at the moment !
Also see Issue #3 in development repository on gitlab https://gitlab.com/mhab/ec130/issues/3

Thanks
Mike-DE
mhab
 
Posts: 410
Joined: Thu Apr 18, 2013 10:59 pm
Callsign: D-MIKE
Version: 2019.1.1
OS: Win10

Re: EC130-B4: major update

Postby rominet » Mon Mar 30, 2015 10:03 pm

Hello,

Thanks for the merge. As noted in the issue, I can reproduce the Nasal error. Seems like a bug in the tooltip system (or maybe it was not designed to display several tooltips at the same time, which would be a pity...).
rominet
 
Posts: 557
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

Re: EC130-B4: major update

Postby Johan G » Mon Mar 30, 2015 10:25 pm

rominet wrote in Mon Mar 30, 2015 10:03 pm:...or maybe [the tooltip system] was not designed to display several tooltips at the same time, which would be a pity...

That would be bad in more than one way. :? If you would find it to be the issue, please do not hold it to yourself.
Low-level flying — It's all fun and games till someone looses an engine. (Paraphrased from a YouTube video)
Improving the Dassault Mirage F1 (Wiki, Forum, GitLab. Work in slow progress)
Johan G
Moderator
 
Posts: 5546
Joined: Fri Aug 06, 2010 5:33 pm
Location: Sweden
Callsign: SE-JG
IRC name: Johan_G
Version: 3.0.0
OS: Windows 7, 32 bit

Re: EC130-B4: major update

Postby mhab » Mon Mar 30, 2015 11:00 pm

I don't think the problem is concurrent tooltips.
The problem is, if a hover Tooltip uses Nasal scripting, something is broken in the system for following tooltips.

@Johan: What do you mean by holding something to yourself ? It's quite open public here ...

Mike-DE
mhab
 
Posts: 410
Joined: Thu Apr 18, 2013 10:59 pm
Callsign: D-MIKE
Version: 2019.1.1
OS: Win10

Next

Return to Aircraft

Who is online

Users browsing this forum: No registered users and 4 guests