Board index FlightGear Development Aircraft

Landing lights showing up as near-solid white cones

Questions and discussion about creating aircraft. Flight dynamics, 3d models, cockpits, systems, animation, textures.

Re: Landing lights showing up as near-solid white cones

Postby Thorsten » Sun Mar 17, 2013 6:17 pm

So, it occurs specifically with Rembrandt-capable planes when Rembrandt is off, not with non-Rembrandt-capable planes? Is is peculiar for Atmospheric Light Scattering, or show everywhere? Does it work correctly when Rembrandt is on?
Thorsten
 
Posts: 10819
Joined: Mon Nov 02, 2009 8:33 am

Re: Landing lights showing up as near-solid white cones

Postby Gijs » Sun Mar 17, 2013 6:30 pm

Neilson wrote in Sun Mar 17, 2013 3:59 pm:I have this with any plane set up with Rembrant

I thought the issue was just with the light-cone hack and not with Rembrandt lights? Could you try the c172p to confirm that (it has Rembrandt lights, but no hacky light-cone)?
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9363
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: Landing lights showing up as near-solid white cones

Postby Thorsten » Mon Mar 18, 2013 8:38 am

I admit to the same confusion as Gijs...
Thorsten
 
Posts: 10819
Joined: Mon Nov 02, 2009 8:33 am

Re: Landing lights showing up as near-solid white cones

Postby StuartC » Mon Mar 18, 2013 9:00 am

I replied to this 5 min ago, but my rteply vanished?

Anyhoo, I will do it again.

It appears it is the Rembrandt lighting causing issues while in non rembrandt mode with older Mac OS + FG 2.8 and better. On other OS set ups, the rembrandt lighting gets ignored when rembrandt is turned off, but not in this case. Both lighting modes are present and creating the weird effects.
I have updated the light map for the next Tornado update thats due, which Neilson has to test. This appears to have cured the issue but I will need to apply it to another aircraft to verify the result. I have no idea why the lightmap has cured the problem though.
StuartC
 
Posts: 2723
Joined: Fri Jun 18, 2010 8:18 pm
Location: Arse end of the Universe
Callsign: WF01
Version: 2018.3.2
OS: W10 64 bit

Re: Landing lights showing up as near-solid white cones

Postby Neilson » Sat Mar 30, 2013 6:12 am

found it in this one 747-400 from the 2.10 plane list http://www.flightgear.org/download/airc ... ilterable/

Image

all settings.
User avatar
Neilson
 
Posts: 442
Joined: Fri Sep 02, 2011 8:17 pm
Location: Rochester UK EGTO
Callsign: Neilson
Version: 2017.3.1
OS: Mac

Re: Landing lights showing up as near-solid white cones

Postby Gijs » Sat Mar 30, 2013 9:16 am

Can you check the value of /sim/rendering/rembrandt/enabled?
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9363
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: Landing lights showing up as near-solid white cones

Postby Neilson » Sat Mar 30, 2013 4:00 pm

This is what i got.

/sim/rendering/rembrandt/
Image
User avatar
Neilson
 
Posts: 442
Joined: Fri Sep 02, 2011 8:17 pm
Location: Rochester UK EGTO
Callsign: Neilson
Version: 2017.3.1
OS: Mac

Re: Landing lights showing up as near-solid white cones

Postby Gijs » Sat Mar 30, 2013 5:45 pm

That is really, really weird. The lights are only selected when /sim/rendering/rembrandt/enabled=true, but for some reason that doesn't seem to work on Mac...\

Could you try changing blocks like this in all Aircraft/747-400/Models/Lights files:
Code: Select all
<animation>
   <type>select</type>
   <condition>
      <property>/sim/rendering/rembrandt/enabled</property>
   </condition>
</animation>

into this:
Code: Select all
<animation>
   <type>select</type>
   <condition>
      <equals>
         <property>/sim/rendering/rembrandt/enabled</property>
         <value>true</value>
      </equals>
   </condition>
</animation>

It shouldn't make a difference, but maybe it does on Mac...
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9363
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: Landing lights showing up as near-solid white cones

Postby Neilson » Sat Mar 30, 2013 6:11 pm

tried it, still got the exact same as the screen shots.

Added the bit to
beacon.xml light-cone.xml strobe.xml
User avatar
Neilson
 
Posts: 442
Joined: Fri Sep 02, 2011 8:17 pm
Location: Rochester UK EGTO
Callsign: Neilson
Version: 2017.3.1
OS: Mac

Re: Landing lights showing up as near-solid white cones

Postby Gijs » Sat Mar 30, 2013 6:12 pm

And if you delete the complete light animation from those files?
Code: Select all
 <animation>
    <type>light</type>
    ....
</animation>
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9363
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: Landing lights showing up as near-solid white cones

Postby Neilson » Sat Mar 30, 2013 6:46 pm

Did that and found out its not those files doing it.

Seems to be light-green.xml light-logo.xml light-red.xml

I added this below too them files and it work turning off rembrant lights,
Code: Select all
<animation>
   <type>select</type>
   <condition>
      <property>/sim/rendering/rembrandt/enabled</property>
   </condition>
</animation>


all though i have no lights on the 747 with Rembrant off, its a lot beter now
User avatar
Neilson
 
Posts: 442
Joined: Fri Sep 02, 2011 8:17 pm
Location: Rochester UK EGTO
Callsign: Neilson
Version: 2017.3.1
OS: Mac

Re: Landing lights showing up as near-solid white cones

Postby Gijs » Sat Mar 30, 2013 6:50 pm

Argh, that's a big mistake on my side. I'll fix it in Git. Thanks for noticing!
But it doesn't explain why other aircraft have the same issue, like the SU-37?
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9363
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: Landing lights showing up as near-solid white cones

Postby Neilson » Sat Mar 30, 2013 6:58 pm

just applied it to the SU-37 remb light files and it works :)

Nee to get someone to test it on a windows FG with rembrant

Big thank you very much :)
User avatar
Neilson
 
Posts: 442
Joined: Fri Sep 02, 2011 8:17 pm
Location: Rochester UK EGTO
Callsign: Neilson
Version: 2017.3.1
OS: Mac

Previous

Return to Aircraft

Who is online

Users browsing this forum: YandexBot [Bot] and 2 guests