Board index FlightGear Development Aircraft

eurofighter typhoon

Questions and discussion about creating aircraft. Flight dynamics, 3d models, cockpits, systems, animation, textures.

Re: eurofighter typhoon

Postby almursi » Wed Sep 22, 2010 8:50 pm

DFaber wrote:Hi almursi
It's the CG being to far aft. I have shifted it a bit to the front and now it stays on ground with elevators neutral up to 150 kts and above rises gently. It seems as if there were too many fuselages in the rear, I had to remove the vstab mount fuselage definition to get it reasonable.


Hi, great! Now it seems to go much better. At least that's my first impression, I have yet to try a little more (Edited: on empty fuel tends to nose up :mrgreen: It may also be inherited from my changes, I've been a season with the fuel-freeze enabled and maybe missing test this issue. APU seems just behind the pilot, I do not remember exactly where I placed but may be able to place better).


Usually I don't mind a positive Cruise AOA.


This was to facilitate the management wing leveler before becoming available on autopilot, so it's no problem to change.

add this to the <hstab> definition to have the gload limited to approx 9g


Thanks, I had not found this option yet. The response of the aircraft is stopped when it exceeds the ceiling, which gives rise to jumps when we try to exceed the limit. I think it's pretty good:) Anyway I was now used to manage it without limitations, I am going to miss it :D.

Best regards.
almursi
 
Posts: 108
Joined: Tue Apr 06, 2010 5:21 am
Location: LELC Murcia (Spain)
Callsign: EC-ALM
Version: Git
OS: Ubuntu 10.04

Re: eurofighter typhoon

Postby almursi » Thu Sep 23, 2010 2:37 am

Hi DFaber, this is my result:

Code: Select all
<?xml version="1.0"?>

<!-- Eurofighter Typhoon
TODO: strong parking brakes
Another (no basic) ToDo: adjust coord. of ballast, tanks, weights, slats more effective, thrust vectoring
Fixed: wing degres, fuel consume more moderated, mach 1.2 without afterburne
   (for mach 1.5 -sea level-, 2 -hight altitude- within & "fuel freeze":
    missing some message warning over fuel consume on right-bottom cockpit panel).

   * testing:
     - fuselages and ballast

******* Old:

Solution results:       Iterations: 353
 Drag Coefficient: 13.489564
       Lift Ratio: 217.109512
       Cruise AoA: 0.749491
   Tail Incidence: 0.995676
Approach Elevator: -0.086590
               CG: x:-9.516, y:-0.000, z:0.073

  Inertia tensor : 40285.816, -0.000, 6943.108
        [kg*m^2]   -0.000, 173467.250, 0.000
     Origo at CG   6943.108, 0.000, 203359.766

******* New:

Solution results:       Iterations: 216
 Drag Coefficient: 14.508112
       Lift Ratio: 206.225723
       Cruise AoA: 0.751738
   Tail Incidence: 0.690659
Approach Elevator: -0.021679
               CG: x:-9.613, y:-0.000, z:0.084

  Inertia tensor : 41505.789, -0.000, 5951.682
        [kg*m^2]   -0.000, 196072.641, 0.000
     Origo at CG   5951.682, 0.000, 227231.922

--> <!--drag = resistencia, lift = sustentación -->

<airplane mass="24581">

  <!-- Approach configuration    -->
  <approach speed="130" aoa="9">
    <control-setting axis="/controls/engines/engine[0]/throttle" value="0.4"/>
    <control-setting axis="/controls/engines/engine[1]/throttle" value="0.4"/>
    <control-setting axis="/controls/flight/flaps" value="0"/>
    <control-setting axis="/controls/gear/gear-down" value="1"/>
    <control-setting axis="/controls/flight/speedbrake" value="0"/>
    <control-setting axis="/controls/flight/slats" value="0"/>
  </approach>

  <!-- For Maximun perfomance test. Mach 2.0+
  <cruise speed="1480" alt="45000">
    <control-setting axis="/controls/engines/engine[0]/throttle" value="1"/>
    <control-setting axis="/controls/engines/engine[1]/throttle" value="1"/>
    <control-setting axis="/controls/engines/engine[0]/afterburner" value="1"/>
    <control-setting axis="/controls/engines/engine[1]/afterburner" value="1"/>
    <control-setting axis="/controls/flight/flaps" value="0"/>
    <control-setting axis="/controls/gear/gear-down" value="0"/>
    <control-setting axis="/controls/flight/speedbrake" value="0"/>
    <control-setting axis="/controls/flight/slats" value="1"/>
  </cruise>
    -->

  <!-- Cruise configuration. Reaches 1.1/1.3 Mach without afterburne and basic air-to-air load
       with 860 seem fine and reaches within 1.5 sea level; stall 80-90 kt !!!    -->
  <cruise speed="860" alt="45000">
    <control-setting axis="/controls/engines/engine[0]/throttle" value="0.94"/>
    <control-setting axis="/controls/engines/engine[1]/throttle" value="0.94"/>
    <control-setting axis="/controls/flight/flaps" value="0"/>
    <control-setting axis="/controls/gear/gear-down" value="0"/>
    <control-setting axis="/controls/flight/speedbrake" value="0"/>
    <control-setting axis="/controls/flight/slats" value="0"/>
  </cruise>

  <!-- pilot eyepoint -->
  <cockpit x="-4" y="0.0" z="1.18"/>

<!--fuselages old
  <fuselage ax="0" ay="0" az="0.067"
            bx="-14.96" by="0" bz="-0.064"
       width="1.8" taper= "0.6" midpoint= "0.7"/>

  <fuselage ax="-2.61" ay="0.0" az="1"
            bx="-13" by="0.0" bz="0.8"
       width="0.9" taper= "0.45" midpoint= "0.17"/>

  <fuselage ax="-11.20" ay="0" az="1.1"
            bx="-14.88" by="0" bz="0.6"
       width="0.4" taper= "0.9" midpoint= "0.65"/>
 -->

    <!--fuselage -->
      <fuselage ax="0" ay="0" az="0.067"
                bx="-3.0" by="0" bz="0.35"
           width="1.2" taper= "0.0" midpoint= "1.0"/>
      <fuselage ax="-3" ay="0" az="0.35"
                bx="-5.0" by="0" bz="0.35"
           width="1.3" taper= "0.9" midpoint= "1.0"/>
      <fuselage ax="-5.0" ay="0" az="0.067"
                bx="-14.96" by="0" bz="0.05"
           width="2.1" taper= "0.6" midpoint= "0.7"/>

    <!-- cockpit -->
      <fuselage ax="-2.61" ay="0.0" az="1"
                bx="-6" by="0.0" bz="0.8"
           width="0.9" taper= "0.45" midpoint= "0.17"/>

    <!-- vstab mount  cx="1.6" cy="1.2"
      <fuselage ax="-11.20" ay="0" az="1.1"
                bx="-14.88" by="0" bz="0.6"
           width="0.4" taper= "0.9" midpoint= "0.65"/>
    -->
    <!-- pods -->
      <fuselage ax="-10.6964" ay="5.471" az="-0.263"
                bx="-13.231" by="5.461" bz="-0.263"
           width="0.37" taper= "0.8" midpoint= "0.65"/>

      <fuselage ax="-10.6964" ay="-5.471" az="-0.263"
                bx="-13.231" by="-5.461" bz="-0.263"
           width="0.37" taper= "0.8" midpoint= "0.65"/>

    <!-- wing mounts -->
      <fuselage ax="-5.9526" ay="0.79" az="-0.14"
                bx="-13.65" by="0.983" bz="-0.35"
           width="0.4" taper= "0.9" midpoint= "0.9"/>

      <fuselage ax="-5.9526" ay="-0.79" az="-0.14"
                bx="-13.65" by="-0.983" bz="-0.35"
           width="0.4" taper= "0.9" midpoint= "0.9"/>

    <!-- engine mounts -->
      <fuselage ax="-11.08" ay="0.532" az="-0.06"
                bx="-14.914" by="0.532" bz="-0.06"
           width="1" taper= "1" midpoint= "0.8"/>

      <fuselage ax="-11.08" ay="-0.532" az="-0.06"
                bx="-14.914" by="-0.532" bz="-0.06"
           width="1" taper= "1" midpoint= "0.8"/>



<!-- on testing
 flap0 = foreplane, flap1 = variable capture air intake
-->
  <hstab x="-2.785" y="0.556" z="0.222"
         taper="0.34"
         length="1.6"
         chord="1.642"
         sweep="35"
        dihedral="-10">
    <stall aoa="35" width="13" peak="1.5"/>
    <flap0 start="0.001" end="1" lift="1.9" drag="1.4"/>
    <flap1 start="0.001" end="0.15" lift="1.4" drag="1.2"/>
    <control-input axis="/controls/flight/elevator" control="FLAP0" invert="true"/>
    <control-input axis="/controls/flight/elevator-trim" control="FLAP0" invert="true"/>
    <control-input axis="/controls/flight/flaps" control="FLAP1" invert="false"/>
    <control-input axis="/accelerations/pilot-g" control="FLAP0" invert="true"
          src0="8" src1="9" dst0="0" dst1="1" />
   <control-input axis="/accelerations/pilot-g" control="FLAP0" invert="true"
          src0="8" src1="9" dst0="0" dst1="1" />
    <control-output control="FLAP0" prop="/surface-positions/elevator-pos-norm"/>
    <control-output control="FLAP1" prop="/surface-positions/flap-pos-norm"/>
    <!--control-speed control="FLAP0" transition-time="4"/-->
    <control-speed control="FLAP1" transition-time="1.5"/>
  </hstab>

<!-- Other test, for fine AFCS work: flap0 = flapleron0, flap1 = flapleron1, slats, speedbrake
     Problem: spoiler do nothing...
  <wing x="-9.525" y="1.180" z="-0.199"
        taper="0.185"
        incidence="-0.4"
      twist="5.0"
        length="5.1"
        chord="6.815"
        sweep="30"
        dihedral="0">
    <stall aoa="21" width="8" peak="1.3"/>
    <flap0 start="0.02" end="0.55" lift="1.2" drag="1.1"/>
    <flap1 start="0.55" end="0.95" lift="1.2" drag="1.1"/>
    <spoiler start="0.001" end="0.10" lift="0.001" drag="8" aoa="3"/>
    <slat start="0.2" end="0.95" aoa="30" lift="3" drag="1.2"/>
    <control-input axis="/controls/flight/aileron" control="FLAP0" split="true"/>
    <control-input axis="/controls/flight/aileron-trim" control="FLAP0" split="true"/>
    <control-input axis="/controls/flight/aileron" control="FLAP1" split="true"/>
    <control-input axis="/controls/flight/aileron-trim" control="FLAP1" split="true"/>
    <control-input axis="/controls/flight/speedbrake" control="SPOILER"/>
    <control-input axis="/controls/flight/slats" control="SLAT" invert="true"/>

    <control-output control="SLAT" prop="/surface-positions/slat-pos-norm"/>

    <control-output control="FLAP0" side="left"
                    prop="/surface-positions/left-aileron-pos-norm"/>
    <control-output control="FLAP0" side="right"
                    prop="/surface-positions/right-aileron-pos-norm"/>
    <control-output control="FLAP0" prop="/surface-positions/aileron-pos-norm"/>
    <control-output control="FLAP1" side="left"
                    prop="/surface-positions/left-aileron-pos-norm"/>
    <control-output control="FLAP1" side="right"
                    prop="/surface-positions/right-aileron-pos-norm"/>
    <control-output control="FLAP1" prop="/surface-positions/aileron-pos-norm"/>

    <control-output control="SPOILER" prop="/surface-positions/speedbrake-pos-norm"/>

    <control-speed control="SLAT" transition-time="5"/>
    <control-speed control="FLAP0" transition-time="1.05"/>
    <control-speed control="FLAP1" transition-time="1.05"/>

    <control-speed control="SPOILER" transition-time="3.0"/>

  </wing>
-->

<!-- On test fine:  flap0 = flaplerons, slat = slats, flap1 = speedbrake (from wing)
      speedbrake drag 2.1 down to 1.9
-->
  <wing x="-9.525" y="1.016" z="-0.199"
        taper="0.18"
        incidence="1.5"
      twist="-2"
        length="4.95"
        chord="7"
        sweep="30"
        dihedral="0">
    <stall aoa="21" width="8" peak="1.3"/>
    <slat start="0.2" end="0.95" aoa="6" lift="1.2" drag="1.2"/>
    <flap0 start="0.02" end="0.95" lift="1.2" drag="1.0"/>
    <flap1 start="0.001" end="0.091" lift="0.001" drag="1.9"/>
    <control-input axis="/controls/flight/aileron" control="FLAP0" split="true"/>
    <control-input axis="/controls/flight/aileron-trim" control="FLAP0" split="true"/>
    <control-input axis="/controls/flight/speedbrake" control="FLAP1" invert="true"/>
    <control-input axis="/controls/flight/slats" control="SLAT"/>

    <control-output control="SLAT" prop="/surface-positions/slats-pos-norm"/>

    <control-output control="FLAP0" side="left" prop="/surface-positions/left-aileron-pos-norm"/>
    <control-output control="FLAP0" side="right" prop="/surface-positions/right-aileron-pos-norm"/>

    <control-output control="FLAP1" prop="/surface-positions/speedbrake-pos-norm"/>

    <control-speed control="SLAT" transition-time="2"/>
    <control-speed control="FLAP0" transition-time="1.05"/>
    <control-speed control="FLAP1" transition-time="3.0"/>
  </wing>



  <vstab x="-13.198" y="0.0" z="0.817"
         taper="0.38"
         length="3.9"
         chord="2.952"
         sweep="40" >
    <stall aoa="27" width="10" peak="1.5"/>
    <flap0 start="0.001" end="0.8" lift="1.3" drag="1.3"/>
    <control-input axis="/controls/flight/rudder" control="FLAP0" invert="true"/>
    <control-input axis="/controls/flight/rudder-trim" control="FLAP0" invert="true"/>
    <control-output control="FLAP0" prop="/surface-positions/rudder-pos-norm"/>
    <control-speed control="FLAP0" transition-time="1"/>
  </vstab>


 <!-- tsfc 0.7 seens excessive -->
  <jet x="-12.8" y="0.532" z="-0.06"
       mass="2204"
       thrust="13490"
      afterburner="20230"
                tsfc="0.4"
       n1-idle="25" n1-max="100" n2-idle="30" n2-max="100"
       exhaust-speed="1850"
       rotation="0">
    <actionpt x="-14.914" y="0.532" z="-0.06"/>
     <!--todo thrust axis testing  -->
    <control-input axis="/controls/engines/engine[0]/throttle" control="THROTTLE"/>
    <control-input axis="/controls/engines/engine[0]/reheat" control="REHEAT"/>
    <control-input axis="/controls/engines/engine[0]/reverser" control="REVERSE_THRUST"/>
    <control-output control="REHEAT" prop="engines/engine[0]/afterburner" />
  </jet>
  <jet x="-12.8" y="-0.532" z="-0.06"
       mass="2204"
       thrust="13490"
      afterburner="20230"
                tsfc="0.4"
       n1-idle="25" n1-max="100" n2-idle="30" n2-max="100"
       exhaust-speed="1850"
       rotation="0">
    <actionpt x="-14.914" y="-0.532" z="-0.06"/>
    <control-input axis="/controls/engines/engine[1]/throttle" control="THROTTLE"/>
    <control-input axis="/controls/engines/engine[1]/reheat" control="REHEAT"/>
    <control-input axis="/controls/engines/engine[1]/reverser" control="REVERSE_THRUST"/>
    <control-output control="REHEAT" prop="engines/engine[1]/afterburner" />
  </jet>

  <!-- gear -->
  <!-- Parking brakes on until 80% of throttle, real model parking brakes with 100% throttle and reheat...  -->  <!-- with brake-parking on noseger, use only on taxi-ground -->

  <gear x="-5.375" y="0" z="-2.05"
        retract-time="1" initial-load="10"
        compression="0.4" upx="0" upy="0" upz="0.3" spring="5" damp="4">   <!-- testing -->
    <control-input axis="/controls/flight/rudder" control="STEER" square="true"
                 src0="-1" src1="1" dst0="-0.9" dst1="0.9"/>
    <control-input axis="/controls/gear/brake-parking" control="BRAKE"/>
    <control-input axis="/controls/gear/gear-down" control="EXTEND"/>
    <control-output control="EXTEND" prop="/gear/gear[0]/position-norm"/>
    <control-speed control="EXTEND" transition-time="7"/>
  </gear>


  <!-- left main -->

  <gear x="-9.8" y="2.093" z="-1.81"
        retract-time="1"
        compression="0.4" upx="-0.02" upy="0.01" upz="0.19"
        spring="0.8" damp="2">
    <control-input axis="/controls/gear/brake-left" control="BRAKE"/>
    <control-input axis="/controls/gear/brake-parking" control="BRAKE" />
    <control-input axis="/controls/gear/gear-down" control="EXTEND"/>
    <control-output control="EXTEND" prop="/gear/gear[1]/position-norm"/>
    <control-speed control="EXTEND" transition-time="8"/>
    <control-speed control="BRAKE" transition-time="1"/>
  </gear>


  <!-- right main -->
  <gear x="-9.8" y="-2.093" z="-1.81"
        retract-time="1"
   compression="0.4" upx="-0.02" upy="-0.01" upz="0.19"
        spring="0.8" damp="2">
    <control-input axis="/controls/gear/brake-right" control="BRAKE"/>
    <control-input axis="/controls/gear/brake-parking" control="BRAKE" />
    <control-input axis="/controls/gear/gear-down" control="EXTEND"/>
    <control-output control="EXTEND" prop="/gear/gear[2]/position-norm"/>
    <control-speed control="EXTEND" transition-time="8"/>
    <control-speed control="BRAKE" transition-time="1"/>
  </gear>



<!-- Carrier ops ++++++++++++++++++++++++++++++++++++++++++++++++ -->

   <!-- Hook f14b ; true length seem +/- max "2.2246" min "2.06" -->
   <hook x="-12.20" y="-0.0192" z="-0.5483" length="2.25" down-angle="60" up-angle="-3">
      <control-input axis="/controls/gear/tailhook" control="HEXTEND"/>
      <control-speed control="HEXTEND" transition-time="4"/>
   </hook>


   <!-- Launch-bar f14b ; over nosegear tail: x="-5.406" y="0.0" z="-0.7945" length="1.463"
                               over nosewheel : x="-5.44" y="0.0" z="-1.175" -->
   <launchbar x="-5.44" y="0.0" z="-1.175" length="1.463">
      <control-input axis="/controls/gear/launchbar" control="LEXTEND"/>
      <control-speed control="LEXTEND" transition-time="1"/>
   </launchbar>




  <!-- tanks ahead gear 9.2, best that 9.8 (otherwise crash on parking !!!) -->
   <!-- front, 7.3 ? -->
  <tank x="-7.3" y="0.0" z="-0.25" jet="true" capacity="3990"/>
  <!-- rear, 9.2 ! -->
  <tank x="-9.2" y="-0.0" z="-0.25" jet="true" capacity="1873"/>
  <!-- left wing tanks -->
  <tank x="-9.3" y="2.2" z="-0.18" jet="true" capacity="420"/>
  <tank x="-10.1" y="2.7" z="-0.18" jet="true" capacity="882"/>
  <!-- right wing tanks -->
  <tank x="-9.3" y="-2.2" z="-0.18" jet="true" capacity="420"/>
  <tank x="-10.1" y="-2.7" z="-0.18" jet="true" capacity="882"/>
  <!-- drop tanks -->
  <tank x="-9.2" y="2.824" z="-0.6" jet="true" capacity="2645"/>
  <tank x="-9.2" y="-2.824" z="-0.6" jet="true" capacity="2645"/>
  <tank x="-9.2" y="0.0" z="-0.8" jet="true" capacity="2204"/>

  <tank x="-9.2" y="0.0" z="-0.8" jet="true" capacity="0"/>

  <!-- ballast
  <ballast x="-3.05" y="0" z="-0.1" mass="1000"/>
 
  <ballast x="-2.74" y="0" z="-0.35" mass="1200"/>
 -->

  <!-- ballast compensación a lo bruto...
  <ballast x="-2.7" y="0" z="-1.2" mass="3270"/>
 -->

  <!-- trim -->
  <ballast x="-0.7" y="0" z="0.2" mass="2000"/>
  <!-- radar -->
  <ballast x="-2" y="0" z="0.22" mass="300"/>
  <!-- cockpit -->
  <ballast x="-2.79" y="0" z="0.22" mass="300"/>
  <!-- piloto -->
  <ballast x="-4.09" y="0" z="-0.57" mass="300"/>
  <!-- mauser y  -->
  <ballast x="-6.12" y="0" z="-0.10" mass="200"/>


<!--
<ballast x="-0.9" y="0" z="-0.75" mass ="500"/>
-->


  <weight x="-4.5" y="0" z="0.6" mass-prop="/yasim/weights/pilot-lb"/>
  <!--<weight x="-0.39" y="0" z="-1.33" size="1.5"
        mass-prop="/yasim/hunter/weights/right-inboard-lbs"/>
<weight x="-0.79" y="2" z="-1.33" size="1"
        mass-prop="/yasim/hunter/weights/left-inboard-lbs"/>-->

<!-- external loads -->
  <weight x="-10.36"
               y="4.7"   
               z="-0.65"
            size="0.25"
              mass-prop="sim/weight[0]/weight-lb"
   />
  <weight x="-9.536"
               y="3.802"   
               z="-0.775"
            size="0.45"
              mass-prop="sim/weight[1]/weight-lb"
   />
<!-- left droptank -->
  <weight x="-9.4"
               y="2.824"   
               z="-0.6"
            size="0.7"
              mass-prop="sim/weight[2]/weight-lb"
   />
  <weight x="-7.376"
               y="1.739"   
               z="-0.817"
            size="0.45"
              mass-prop="sim/weight[3]/weight-lb"
   />
<!-- center -->
  <weight x="-9.4"
               y="0.0"   
               z="-0.32"
            size="0.6"
              mass-prop="sim/weight[4]/weight-lb"
   />
  <weight x="-7.376"
               y="-1.739"   
               z="-0.817"
            size="0.45"
              mass-prop="sim/weight[5]/weight-lb"
   />
<!-- right droptank -->
  <weight x="-9.4"
               y="-2.824"   
               z="-0.6"
            size="0.7"
              mass-prop="sim/weight[6]/weight-lb"
   />
  <weight x="-9.536"
               y="-3.802"   
               z="-0.775"
            size="0.45"
              mass-prop="sim/weight[7]/weight-lb"
   />
  <weight x="-10.36"
               y="-4.7"   
               z="-0.65"
            size="0.25"
              mass-prop="sim/weight[8]/weight-lb"
   />
<!-- fuselage AMRAAMs -->
  <weight x="-6.793"
               y="0.882"   
               z="-0.616"
            size="0.3"
              mass-prop="sim/weight[9]/weight-lb"
   />
  <weight x="-11.627"
               y="0.979"   
               z="-0.616"
            size="0.3"
              mass-prop="sim/weight[10]/weight-lb"
   />
  <weight x="-6.793"
               y="-0.882"   
               z="-0.616"
            size="0.3"
              mass-prop="sim/weight[11]/weight-lb"
   />
  <weight x="-11.627"
               y="-0.979"   
               z="-0.616"
            size="0.3"
              mass-prop="sim/weight[12]/weight-lb"
   />

</airplane>


I changed the ballast trim to get good result. It looks like a conflict issue, will not be getting up with empty fuel, and make the takeoff is not unrealistic :). With this solution I have only seen serious problems in case of full carry only the rear tank (a very rare case). As for the "g" limitation, we now need a smoother response of the controls, that's why I said it was the task of FCS (since the real model has a virtual cockpit, and never act directly on the controls: these days Algernon wanted to start with this subject, so wonderful). Regards.
almursi
 
Posts: 108
Joined: Tue Apr 06, 2010 5:21 am
Location: LELC Murcia (Spain)
Callsign: EC-ALM
Version: Git
OS: Ubuntu 10.04

Re: eurofighter typhoon

Postby DFaber » Thu Sep 23, 2010 6:15 am

almursi wrote:
Thanks, I had not found this option yet. The response of the aircraft is stopped when it exceeds the ceiling, which gives rise to jumps when we try to exceed the limit. I think it's pretty good:)


There is room for fine tuning. Currently it gives rather jumpy results, but one can change the onset (currently 8g) to start earlier and the maximum some higher, or lower the correction value (currently levels elevators out to zero, may be a bit too much). Basically an FCS can utilize this additional control input to compute properties calculated by the FCS.

Greetings
Detlef Faber
FlightGear Development:
http://flightgear-de.net

German FlightGear Forum
http://forum.flightgear-de.net
DFaber
 
Posts: 687
Joined: Fri Dec 01, 2006 7:51 pm
Location: Aachen, Germany
Version: GIT
OS: Linux

Re: eurofighter typhoon

Postby almursi » Thu Sep 23, 2010 6:22 am

Hi DFaber, (edited) I know not why, now, I get different results. :shock: I still have problems with the ballast, so not yet been resolved with my attempt :mrgreen:. Instead, after a reset, the result looks better takeoff.

And about g limitation it seems that sounds good what you say. One question was whether it is very difficult to control the negative g, because there it continues to exaggerated results :). Best regards.
almursi
 
Posts: 108
Joined: Tue Apr 06, 2010 5:21 am
Location: LELC Murcia (Spain)
Callsign: EC-ALM
Version: Git
OS: Ubuntu 10.04

Re: eurofighter typhoon

Postby Algernon » Thu Sep 23, 2010 1:57 pm

Good stuff guys. I have started to think about the FCS, my first sketches involve PI controllers which 'damp' the aileron input depending on the amount of G-loading - 0g means no damping, 10g means total damping (ailerons will move no further). Very basic, and only an experiment, but I have to start somewhere. I am very inexperienced at this sort of thing, you guys probably know a lot more, so I would value discussion on the matter. I have mostly kept clear of FDMs thus far so I don't know much about that aspect of aircraft modelling, and I don't really understand Detlef's code above, could somebody explain how it works please? :oops:

One thing I just noticed is Almursi mentioned the APU. I am very interested in it because when, eventually, the engines can be stopped and started, the APU will become important and I think I've worked out quite a nice way to do it. While weight and ballast and CG is being discussed, I thought it might be a good time to ask. On my experimental version of the Typhoon, there is a third <jet> in the FDM file which is disconnected from the throttle controls, having it's own throttle which would be controlled by a Nasal script upon power-up. At the moment, it is weightless and produces negligible thrust, it's purely there to generate electricity at the moment (though eventually of course it will also start the engines). Do you think it's more realistic to give it a reasonably accurate weight, and is positioning important?
Algernon
FGUK - A FlightGear community in the United Kingdom and Republic of Ireland
User avatar
Algernon
 
Posts: 498
Joined: Sun Jun 27, 2010 3:55 pm
Callsign: G-ALGY
Version: 3.0
OS: W7U

Re: eurofighter typhoon

Postby Algernon » Thu Sep 23, 2010 5:31 pm

Finally, I think we have a working autopilot for all versions, one file for GIT and one for V1.9 and 2.0. I cannot test on 1.9.1 as I do not have it, almursi would you mind checking it out for me if you get time? It's still a bit rough, the climb rates are a bit too steep but it works well enough to get some feedback.

Download it here.
Algernon
FGUK - A FlightGear community in the United Kingdom and Republic of Ireland
User avatar
Algernon
 
Posts: 498
Joined: Sun Jun 27, 2010 3:55 pm
Callsign: G-ALGY
Version: 3.0
OS: W7U

Re: eurofighter typhoon

Postby DFaber » Thu Sep 23, 2010 6:17 pm

Algernon wrote: I have mostly kept clear of FDMs thus far so I don't know much about that aspect of aircraft modelling, and I don't really understand Detlef's code above, could somebody explain how it works please? :oops:


The src/dst tags in Yasim takes an input of a given range (from src0 to src1) and maps it to an output range (dst0 to dst1) In this example it takes the g-load as input (starting from 8g) and adjusts the flap0 value accordingly. Any g value from 0-8g will not cause any correction, but as soon as 8g is exceeded it will "push" your elevator against your command. At 8.1 g only one tenth of the elevator range, at 8.5g half of the elevator range and at 9g it will competely erase your elevator input.

Greetings
Detlef Faber
FlightGear Development:
http://flightgear-de.net

German FlightGear Forum
http://forum.flightgear-de.net
DFaber
 
Posts: 687
Joined: Fri Dec 01, 2006 7:51 pm
Location: Aachen, Germany
Version: GIT
OS: Linux

Re: eurofighter typhoon

Postby DFaber » Thu Sep 23, 2010 7:07 pm

Hi almursi,

almursi wrote:Hi DFaber, (edited) I know not why, now, I get different results. :shock: I still have problems with the ballast, so not yet been resolved with my attempt :mrgreen:. Instead, after a reset, the result looks better takeoff.


Strange, I didn't notice anything like that.

almursi wrote:And about g limitation it seems that sounds good what you say. One question was whether it is very difficult to control the negative g, because there it continues to exaggerated results :). Best regards.


Here is my latest <hstab> section:

Code: Select all
  <hstab x="-2.785" y="0.556" z="0.222"
         taper="0.34"
         length="1.6"
         chord="1.642"
         sweep="35"
        dihedral="-10">
    <stall aoa="35" width="17" peak="1.5"/>
    <flap0 start="0.001" end="1" lift="1.8" drag="1.2"/>
    <flap1 start="0.001" end="0.15" lift="1.4" drag="1.2"/>
    <control-input axis="/controls/flight/elevator" control="FLAP0" invert="true" square="true"/>
    <control-input axis="/controls/flight/elevator-trim" control="FLAP0" invert="true"/>
    <control-input axis="/controls/flight/flaps" control="FLAP1" invert="false"/>
    <control-input axis="/accelerations/pilot-g" control="FLAP0" invert="true"
          src0="8" src1="9.5" dst0="0" dst1="1" />
    <control-input axis="/accelerations/pilot-g" control="FLAP0" invert="true"
          src0="-5" src1="-4" dst0="-1" dst1="0" />
    <control-output control="FLAP0" prop="/surface-positions/elevator-pos-norm"/>
    <control-output control="FLAP1" prop="/surface-positions/flap-pos-norm"/>
    <!--control-speed control="FLAP0" transition-time="4"/-->
    <control-speed control="FLAP1" transition-time="1.5"/>
  </hstab>


It has a working negative g-limit (at -5g) and should behave better (although not perfect) in negative-g area. I saw you removed the square tag in hstab. I'd prefer to leave it in as it cures (for me) some nasty oscillating of the elevator near zero deflection. but that's just a suggestion.

Greetings
Detlef Faber
FlightGear Development:
http://flightgear-de.net

German FlightGear Forum
http://forum.flightgear-de.net
DFaber
 
Posts: 687
Joined: Fri Dec 01, 2006 7:51 pm
Location: Aachen, Germany
Version: GIT
OS: Linux

Re: eurofighter typhoon

Postby Algernon » Thu Sep 23, 2010 7:26 pm

Ah, I understand. :) Presumably, we could work in some extra configurability by writing the FCS and having an FCS property work the elevator limiting instead of directly reading the pilot-g information? Might be easier to tune too...

Something I forgot to mention about the autopilots I uploaded - I strongly recommend using the Typhoon Autopilot dialog (I think I forgot to remove the sliders for V1.9) as one field - altitude hold - is NOT USED directly in the Typhoon. This is because a GPS route without altitude information will automatically set the alt hold to zero upon activation, and I was fed up with the aircraft suddenly diving when that happens. Altitude Hold is therefore set in the property /autopilot/settings/ind-target-altitude-ft, while FG's standard altitude-hold property is only used in the VNAV function (follow GPS altitude).
Algernon
FGUK - A FlightGear community in the United Kingdom and Republic of Ireland
User avatar
Algernon
 
Posts: 498
Joined: Sun Jun 27, 2010 3:55 pm
Callsign: G-ALGY
Version: 3.0
OS: W7U

Re: eurofighter typhoon

Postby DFaber » Thu Sep 23, 2010 8:01 pm

Hi Algernon,

Algernon wrote:Ah, I understand. :) Presumably, we could work in some extra configurability by writing the FCS and having an FCS property work the elevator limiting instead of directly reading the pilot-g information? Might be easier to tune too...


exactly, I chose the pilot-g property because it is already present and needed no calculation, but you can of course set the property by a Nasal- script.

Greetings
Detlef Faber
FlightGear Development:
http://flightgear-de.net

German FlightGear Forum
http://forum.flightgear-de.net
DFaber
 
Posts: 687
Joined: Fri Dec 01, 2006 7:51 pm
Location: Aachen, Germany
Version: GIT
OS: Linux

Re: eurofighter typhoon

Postby almursi » Thu Sep 23, 2010 8:02 pm

DFaber wrote:Strange, I didn't notice anything like that.


Hi Detlef, yes, you may get different answers, but I think maybe the problem is because the third fuselage is exceedingly wide. Keep in mind that the weight is above the air intake, and the whole area of air inlet is hollow to the height of the engine (where you have the compressor). And the weight is above that line. I think that when sharing the dough with the hollow surface is the cause of failure (or have mixed results). (Edited!) After a lot of attempts, I still can not tune it, so I leave my last attempt (today).

Over fuselages:
Code: Select all
    <!--fuselage -->
      <fuselage ax="0" ay="0" az="0.067"
                bx="-3.0" by="0" bz="0.35"
           width="1.2" taper= "0.0" midpoint= "1.0"/>
      <fuselage ax="-3" ay="0" az="0.35"
                bx="-11.08" by="0" bz="0.35"
           width="1.3" taper= "0.9" midpoint= "1.0"/>
      <fuselage ax="-11.08" ay="0" az="0.261"
                bx="-14.96" by="0" bz="0.261"
           width="1.8" taper= "0.9" midpoint= "0.1"/>


Over ballast:
Code: Select all
  <!-- trim -->
  <!-- trim -->
  <ballast x="0.2" y="0" z="0.13" mass="2500"/>
  <!-- radar
  <ballast x="-2" y="0" z="0.22" mass="300"/>
-->
  <!-- cockpit
  <ballast x="-2.79" y="0" z="0.22" mass="300"/>
-->
  <!-- piloto
-->
  <ballast x="-4.09" y="0" z="0.5" mass="550"/>
  <!-- mauser
-->
  <ballast x="-6.12" y="0" z="0.10" mass="100"/>


Solution results: Iterations: 162
Drag Coefficient: 14.629586
Lift Ratio: 204.920837
Cruise AoA: 0.748716
Tail Incidence: 0.629031
Approach Elevator: 0.001911
CG: x:-9.595, y:-0.000, z:0.135

Inertia tensor : 44569.641, -0.000, 6184.068
[kg*m^2] -0.000, 226032.312, 0.000
Origo at CG 6184.068, 0.000, 259368.766

Sometimes it just boot normal takeoffs, but usually only possible after a reset.

Regards.
almursi
 
Posts: 108
Joined: Tue Apr 06, 2010 5:21 am
Location: LELC Murcia (Spain)
Callsign: EC-ALM
Version: Git
OS: Ubuntu 10.04

Re: eurofighter typhoon

Postby almursi » Sat Sep 25, 2010 11:59 am

Hi, after many laps to fuselages, I think we should start from the beginning. The initial fuselages tried to adjust slightly the model we have, including some details of the actual model. But after studying each other I found too many differences (especially in incidence, or angle: 0 on nose, but -1.7º- 0.36m down on jet center out). For now I think it's best to take advantage of the limitation of "g" including by Deflet, but "parking" the rest of changes, at least until we can resolve some of this mess :D.

A stable FDM (meanwhile resolved), with "g" limitation can be this:

DivShare File - typhoon2-yasim_xml.zip

On the other hand, the latest version of Algernon autopilot will only work on 2.0 and 2.git, so I recommend that 1.9.1 users do not update file typhoon-autopilot191.xml (possibly there will be three versions of the autopilot. We can easily edit the file-set to load that interests us).

(Edited: I did some cleaning on Divshare, leaving only the last two packages, and so far not shown the links in my old posts :mrgreen: I hope to complete the package 1.4.3-final this weekend. )

Regards.
almursi
 
Posts: 108
Joined: Tue Apr 06, 2010 5:21 am
Location: LELC Murcia (Spain)
Callsign: EC-ALM
Version: Git
OS: Ubuntu 10.04

Re: eurofighter typhoon

Postby almursi » Sun Sep 26, 2010 6:16 am

Hi D.Faber,

I think I found a simple way that we do not have problems with nose up, and your FDM works perfectly. Only put: z="-2.0336" on the left and right gear. After comparing our model with EFT-Plan, I can see that the most notable difference was the rear landing gear, that we have higher than the original. So if we put it a little lower, it works properly and we don't have strange answers (I think :mrgreen:). Now need to try a little, but I think with this small correction is sufficient (we may have to extend the gear on model later, but not urgent). Best regards.
almursi
 
Posts: 108
Joined: Tue Apr 06, 2010 5:21 am
Location: LELC Murcia (Spain)
Callsign: EC-ALM
Version: Git
OS: Ubuntu 10.04

Re: eurofighter typhoon

Postby DFaber » Mon Sep 27, 2010 8:14 am

almursi wrote:I think I found a simple way that we do not have problems with nose up, and your FDM works perfectly. Only put: z="-2.0336" on the left and right gear.


Great, I hope to try this soon. Additionally I like to collect yours and algernons (both really excellent) work and put it in Git sometime this week. This will replace the previous one and I will do some renaming. Please use this one for future development. Many thanks to you all.

Greetings
Detlef Faber
FlightGear Development:
http://flightgear-de.net

German FlightGear Forum
http://forum.flightgear-de.net
DFaber
 
Posts: 687
Joined: Fri Dec 01, 2006 7:51 pm
Location: Aachen, Germany
Version: GIT
OS: Linux

Re: eurofighter typhoon

Postby almursi » Mon Sep 27, 2010 9:17 am

DFaber wrote:... Additionally I like to collect yours and algernons (both really excellent) work and put it in Git sometime this week. This will replace the previous one and I will do some renaming.


Hi, Maybe tonight I can finish other details of the cockpit who remained half. If I can leave here the link to my proposal to combine the contributions of the three (with the current names, in principle, I do not know if I could advance a bit of that work). The landing gear as I have long, and appears not to have to modify the animation :). As for renaming there is no problem, everyone agreed, but in any case I withdraw my proposed merger in git, which was redone to not overwrite the original files. Regards.
almursi
 
Posts: 108
Joined: Tue Apr 06, 2010 5:21 am
Location: LELC Murcia (Spain)
Callsign: EC-ALM
Version: Git
OS: Ubuntu 10.04

PreviousNext

Return to Aircraft

Who is online

Users browsing this forum: No registered users and 4 guests