Board index FlightGear Support Graphics

faulty ALS?

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

faulty ALS?

Postby medick007 » Sat Feb 27, 2021 3:35 pm

Hi, since 2020.3.6 switching the ALS on makes vegetation appear like boxes. I can change all possible driver settings (NVIDIA gt1030) or settings in flightgear. No effect. See screenshots. Have you seen this yet?
top - ALS on, bottom - ALS off.
Image
Image
medick007
 
Posts: 6
Joined: Tue Jan 12, 2021 11:37 am
Location: Bratislava
Version: 2020.3.5
OS: Windows7

Re: faulty ALS?

Postby Maerchenprinz » Sat Feb 27, 2021 4:10 pm

Hi!

Yes, I have seen this before! Right there:
https://forum.flightgear.org/viewtopic.php?f=37&t=37860
Hope this helps.

Ciao,

Adrian
User avatar
Maerchenprinz
 
Posts: 247
Joined: Thu Mar 15, 2007 5:24 pm
Location: Bochum, it's better, much better than you think!
Callsign: Adrian

Re: faulty ALS?

Postby medick007 » Sun Feb 28, 2021 1:25 pm

Hi, thanks for your advice. What bother me, is the fact, that it was not happening in previous versions of FG and I did not make any change in driver (and also in FG graphic settings). Uninstall-install of FG did not help, nor the uninstall-install of drivers.
medick007
 
Posts: 6
Joined: Tue Jan 12, 2021 11:37 am
Location: Bratislava
Version: 2020.3.5
OS: Windows7

Re: faulty ALS?

Postby wkitty42 » Sun Feb 28, 2021 2:25 pm

is this custom scenery or terrasync?
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 7069
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 20.04

Re: faulty ALS?

Postby V12 » Mon Mar 01, 2021 7:53 am

medick007 :
Turn off antialias in Flightgear, turn on ALS, test again and report.
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 2210
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: faulty ALS?

Postby medick007 » Wed Mar 03, 2021 10:12 am

Thanks. Turning off AA helped. But graphics was awful (flickering edges and lines). I changed settings of NVIDIA drivers (let application to setup presets, then full manual setting and also automatic setting for quality or power) and of course I can tweak the AA in driver - but the standard setting (turning on AA and ALS) in FG is definitely a new problem, that was not present in previous versions (problem started with 2020.3.6).
medick007
 
Posts: 6
Joined: Tue Jan 12, 2021 11:37 am
Location: Bratislava
Version: 2020.3.5
OS: Windows7

Re: faulty ALS?

Postby zakalawe » Wed Mar 03, 2021 11:23 am

Can you provide you fgfs.log when use ALS? This is probably a shader compile/link error which should be included in the log file.
zakalawe
 
Posts: 1257
Joined: Sat Jul 19, 2008 4:48 pm
Location: Edinburgh, Scotland
Callsign: G-ZKLW
Version: next
OS: Mac


Return to Graphics

Who is online

Users browsing this forum: No registered users and 1 guest