Board index FlightGear Support Graphics

Major Lag in airliners and when I open the map.

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Major Lag in airliners and when I open the map.

Postby Tufter » Mon Feb 08, 2021 1:39 am

Hi. On high graphics at a highly developed airport (ksfo, phnl, etc) And in a Cessna 172p, my Flightgear runs anywhere from 40-60 FPS. When I open the map and zoom out a bit, Flightgear runs at 15-20 FPS. When I am in an airliner, the FPS is normal until I start the systems and the game goes down to around 10 FPS. Turning down the graphics doesn’t have any major impact on my FPS only (3-6 FPS difference). My cpu also seems to be only using one core. I have an Intel i3 10th gen, 8 gigabytes or ram and no external gpu (Intel uhd graphics)
Tufter
 
Posts: 8
Joined: Fri Jan 29, 2021 12:00 pm
Callsign: Owl-06
OS: Info in “system”

Re: Major Lag in airliners and when I open the map.

Postby tdammers » Mon Feb 08, 2021 9:48 am

Two possible culprits here: single-core CPU performance, and that GPU.

Single-core CPU performance is such a big deal because parallelizing a flightsim is not an easy task, and flightgear, like most sims, will do a large portion of its work on just one thread, so that's why it only uses one core. This is pretty normal. And the reason why airlines are so much harder on the CPU is simply because they have much more complex systems: the 172 can, to a large extent, use the built-in instruments and systems, which, being written in C++, are very efficient; but an airliner requires a lot of custom work, and much of that will be written in Nasal, the scripting language built into FlightGear, and because that is an interpreted language, it will be about an order of magnitude slower.

The onboard GPU may also matter, because airliners usually have glass cockpits, while the C172 uses only analog "steam gauges". And this means that where the C172 can essentially push all textures and 3D models to the GPU once and then call it a day, an airliner needs to redraw each EFIS screen every frame, and push it to the GPU as an updated texture. A typical airliner will have about 6 main EFIS screens plus two CDU's, that's 8 dynamic textures; if each of these is 1024x1024 pixels at 32bpp, then this means we need to push 32 megabytes of texture data onto the GPU for each frame; at 30 fps, this amounts to a gigabyte per second of GPU bus bandwidth just for the EFIS screens. Most dedicated GPUs can handle this fine, but the onboard ones often can't.
tdammers
 
Posts: 364
Joined: Wed Dec 13, 2017 10:35 am
Callsign: NL256
IRC name: nl256


Return to Graphics

Who is online

Users browsing this forum: No registered users and 1 guest