Board index FlightGear Support Graphics

poor performance, Haswell-ULT Integrated Graphics

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

poor performance, Haswell-ULT Integrated Graphics

Postby rawlins02 » Sat May 02, 2020 9:35 pm

I'm a long time FG user, just not in the past 6-7 years. Just installed FlightGear 2017.3 on linux Ubuntu 16.04. Trying to change view and use mouse makes clear that performance is not up to par. FG is bringing my system to its knees. A few hardware specs. I suspect the integrated Intel card just won't get the job done, but maybe it's a driver or settings issue. Getting about 40 FPS. I have 20+ years experience on linux OS. Running GNOME desktop. Here are system specs:
> free -m
total used free shared buff/cache available
Mem: 7668 2214 2499 1158 2953 3959
Swap: 7877 0 7877

> lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 4
On-line CPU(s) list: 0-3
Thread(s) per core: 2
Core(s) per socket: 2
Socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 69
Model name: Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz
Stepping: 1
CPU MHz: 798.170
CPU max MHz: 3300.0000
CPU min MHz: 800.0000
BogoMIPS: 5387.66
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 256K
L3 cache: 4096K
NUMA node0 CPU(s): 0-3

> glxinfo shows
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.5

> glxgears
333 frames in 5.0 seconds = 66.528 FPS
300 frames in 5.0 seconds = 59.953 FPS
300 frames in 5.0 seconds = 59.946 FPS
300 frames in 5.0 seconds = 59.952 FPS
300 frames in 5.0 seconds = 59.946 FPS
rawlins02
 
Posts: 37
Joined: Thu Jul 29, 2010 12:17 pm
Location: Massachusetts, USA
Version: 2019.2.0
OS: linux lubuntu 16.04

Re: poor performance, Haswell-ULT Integrated Graphics

Postby V12 » Sun May 03, 2020 6:10 am

Try glmark2.
Intel graphics are only for basic office use, not for serious OpenGL apps or games that uses advanced shaders etc.
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1827
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: poor performance, Haswell-ULT Integrated Graphics

Postby rawlins02 » Sun May 03, 2020 12:29 pm

Thanks for the suggestion. I'd run glmark2 right after glxgears. Looks like score (1143) is a bit lower than others I've seen. Output below. I also found a suggestion that seems to have helped a bit. It suggested to disable power saving for both the CPU and GPU by adding this to the grub kernel params:

i915.enable_rc6=0

by editing the line in /etc/default/grub containing

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

so that it looks like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_rc6=0"

Saved the file and ran the command sudo update-grub. Rebooted.

> glmark2

=======================================================
glmark2 2014.03+git20150611.fa71af2d
=======================================================
OpenGL Information
GL_VENDOR: Intel Open Source Technology Center
GL_RENDERER: Mesa DRI Intel(R) Haswell Mobile
GL_VERSION: 3.0 Mesa 18.0.5
=======================================================
[build] use-vbo=false: FPS: 2062 FrameTime: 0.485 ms
[build] use-vbo=true: FPS: 1788 FrameTime: 0.559 ms
[texture] texture-filter=nearest: FPS: 1475 FrameTime: 0.678 ms
[texture] texture-filter=linear: FPS: 1568 FrameTime: 0.638 ms
[texture] texture-filter=mipmap: FPS: 1377 FrameTime: 0.726 ms
[shading] shading=gouraud: FPS: 1433 FrameTime: 0.698 ms
[shading] shading=blinn-phong-inf: FPS: 1400 FrameTime: 0.714 ms
[shading] shading=phong: FPS: 1216 FrameTime: 0.822 ms
[shading] shading=cel: FPS: 1418 FrameTime: 0.705 ms
[bump] bump-render=high-poly: FPS: 1149 FrameTime: 0.870 ms
[bump] bump-render=normals: FPS: 1760 FrameTime: 0.568 ms
[bump] bump-render=height: FPS: 1714 FrameTime: 0.583 ms
[effect2d] kernel=0,1,0;1,-4,1;0,1,0;: FPS: 1235 FrameTime: 0.810 ms
[effect2d] kernel=1,1,1,1,1;1,1,1,1,1;1,1,1,1,1;: FPS: 603 FrameTime: 1.658 ms
[pulsar] light=false:quads=5:texture=false: FPS: 1425 FrameTime: 0.702 ms
[desktop] blur-radius=5:effect=blur:passes=1:separable=true:windows=4: FPS: 557 FrameTime: 1.795 ms
[desktop] effect=shadow:windows=4: FPS: 924 FrameTime: 1.082 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 396 FrameTime: 2.525 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=subdata: FPS: 516 FrameTime: 1.938 ms
[buffer] columns=200:interleave=true:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 464 FrameTime: 2.155 ms
[ideas] speed=duration: FPS: 923 FrameTime: 1.083 ms
[jellyfish] <default>: FPS: 888 FrameTime: 1.126 ms
[terrain] <default>: FPS: 121 FrameTime: 8.264 ms
[shadow] <default>: FPS: 616 FrameTime: 1.623 ms
[refract] <default>: FPS: 213 FrameTime: 4.695 ms
[conditionals] fragment-steps=0:vertex-steps=0: FPS: 1321 FrameTime: 0.757 ms
[conditionals] fragment-steps=5:vertex-steps=0: FPS: 1237 FrameTime: 0.808 ms
[conditionals] fragment-steps=0:vertex-steps=5: FPS: 1471 FrameTime: 0.680 ms
[function] fragment-complexity=low:fragment-steps=5: FPS: 1319 FrameTime: 0.758 ms
[function] fragment-complexity=medium:fragment-steps=5: FPS: 1347 FrameTime: 0.742 ms
[loop] fragment-loop=false:fragment-steps=5:vertex-steps=5: FPS: 1254 FrameTime: 0.797 ms
[loop] fragment-steps=5:fragment-uniform=false:vertex-steps=5: FPS: 1325 FrameTime: 0.755 ms
[loop] fragment-steps=5:fragment-uniform=true:vertex-steps=5: FPS: 1211 FrameTime: 0.826 ms
=======================================================
glmark2 Score: 1143
=======================================================

rawlins02
 
Posts: 37
Joined: Thu Jul 29, 2010 12:17 pm
Location: Massachusetts, USA
Version: 2019.2.0
OS: linux lubuntu 16.04

Re: poor performance, Haswell-ULT Integrated Graphics

Postby V12 » Sun May 03, 2020 4:01 pm

That score is standard for integrated GPU and is not enough for serious flying with decent visibility and image quality. You should look for better machine :(
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1827
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: poor performance, Haswell-ULT Integrated Graphics

Postby rawlins02 » Mon May 04, 2020 4:06 am

V12 wrote in Sun May 03, 2020 4:01 pm:That score is standard for integrated GPU and is not enough for serious flying with decent visibility and image quality. You should look for better machine :(


I just installed Lubuntu on an old Dell Studio XPS that I'd not been using. It has an AMD Radeon HD 5730 card. glmark2 score is nearly 2000. I've disabled particles and 3D clouds and made the change to grub that I'd mentioned. I'm optimistic that with these modifications on this less resource intensive Lubuntu OS I can have a reasonable experience flying for fun. Always grateful for any helpful suggestions that anyone offers that might help to improve performance.
rawlins02
 
Posts: 37
Joined: Thu Jul 29, 2010 12:17 pm
Location: Massachusetts, USA
Version: 2019.2.0
OS: linux lubuntu 16.04

Re: poor performance, Haswell-ULT Integrated Graphics

Postby V12 » Mon May 04, 2020 5:51 am

I used LUbuntu too, 300 MB memory dedicated to OS is very cute. Radeon HD 5730 is ofcourse better than integrated Intel, but still too slow. Try turn off all shaders, bare LOD on 60 km, turn off cloud shadow, in Advanced weather turn off terrain presampling, thermals and terrain effects, next turn off AI. If all fails, You can try turn off terrasync and manualy download old SD scenery.
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1827
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12


Return to Graphics

Who is online

Users browsing this forum: No registered users and 2 guests