Board index FlightGear Support Graphics

ALS light effects

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

ALS light effects

Postby MIG29pilot » Fri Apr 10, 2020 11:58 pm

Hello everyone!
I have noticed some trouble with the ALS light effect. Testing in the Cessna 172, the taxi lights and landing lights are visible externally, but not from the cockpit. Also, if I recall correctly, the Twin Otter also has this feature, but it is not visible in any view. I am running Windows 10, Processor AMD A9-9425 Radeon R5, 8GB RAM, 64-bit.
User avatar
MIG29pilot
 
Posts: 1473
Joined: Tue May 19, 2015 4:03 pm
Location: 6 feet under Snow
Callsign: MIG29pilot
Version: 2020.1.3
OS: Windows 10

Re: ALS light effects

Postby wlbragg » Sat Apr 11, 2020 12:18 am

Hum, I just tested it and the interior ALS taxi and landing lights are working on my "next" version but they are tracking with your view. I don't remember them doing that before. Do we have some kind of regression in the code base? I recall some changes to the overall "view" code?
Kansas(2-27-15)/Ohio/Midwest scenery development.
KEQA (2-27-15), 3AU, KRCP Airport Layout
Intel i5 3570K AMDRX480
User avatar
wlbragg
 
Posts: 5607
Joined: Sat Aug 25, 2012 11:31 pm
Location: Kansas (Tornado Alley), USA
Callsign: WC2020
Version: next
OS: Win10/Linux/AMDRX480

Re: ALS light effects

Postby MIG29pilot » Sat Apr 11, 2020 2:54 am

Also, just so you know, the flashlight is working perfectly well.
User avatar
MIG29pilot
 
Posts: 1473
Joined: Tue May 19, 2015 4:03 pm
Location: 6 feet under Snow
Callsign: MIG29pilot
Version: 2020.1.3
OS: Windows 10

Re: ALS light effects

Postby wlbragg » Sat Apr 11, 2020 3:39 am

I think the "model" shader settings in the GUI need to be set to a high enough level for the ALS lighting to work, make sure that a set correctly. Not sure what to expect from compsitor build either.
Kansas(2-27-15)/Ohio/Midwest scenery development.
KEQA (2-27-15), 3AU, KRCP Airport Layout
Intel i5 3570K AMDRX480
User avatar
wlbragg
 
Posts: 5607
Joined: Sat Aug 25, 2012 11:31 pm
Location: Kansas (Tornado Alley), USA
Callsign: WC2020
Version: next
OS: Win10/Linux/AMDRX480


Return to Graphics

Who is online

Users browsing this forum: No registered users and 1 guest