Board index FlightGear Support Graphics

Visual problem instrument vor c172p linux raspbian

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Visual problem instrument vor c172p linux raspbian

Postby Roberto1977 » Tue Dec 03, 2019 6:48 pm

VOR instrument appears dark as shown in photo (raspbian raspberry pi 4)
Image
Roberto1977
 
Posts: 2
Joined: Tue Dec 03, 2019 6:40 pm

Re: Visual problem instrument vor c172p linux raspbian

Postby wlbragg » Tue Dec 03, 2019 7:30 pm

That's a new one for me. I know nothing about raspberry pi. But I can't think of any reason that instrument alone would have issues. First try to identify any difference between the missing mesh and a like instrument that is not missing.
Kansas(2-27-15)/Ohio/Midwest scenery development.
KEQA (2-27-15), 3AU, KRCP Airport Layout
Intel i5 3570K AMDRX480
User avatar
wlbragg
 
Posts: 5194
Joined: Sat Aug 25, 2012 11:31 pm
Location: Kansas (Tornado Alley), USA
Callsign: WC2020
Version: next
OS: Win10/Linux/AMDRX480

Re: Visual problem instrument vor c172p linux raspbian

Postby wlbragg » Tue Dec 03, 2019 7:33 pm

There may be a slight material animation applied to the needles (lines) where as other instruments may not have it? If so, try commenting out the material animation and see if that corrects it.
Kansas(2-27-15)/Ohio/Midwest scenery development.
KEQA (2-27-15), 3AU, KRCP Airport Layout
Intel i5 3570K AMDRX480
User avatar
wlbragg
 
Posts: 5194
Joined: Sat Aug 25, 2012 11:31 pm
Location: Kansas (Tornado Alley), USA
Callsign: WC2020
Version: next
OS: Win10/Linux/AMDRX480

Re: Visual problem instrument vor c172p linux raspbian

Postby Roberto1977 » Thu Dec 12, 2019 6:58 pm

Apparently solved. In the vor1.ac element playing with alpha channel transparencies, the outermost texture making it transparent. the same in heading indicator.
Roberto1977
 
Posts: 2
Joined: Tue Dec 03, 2019 6:40 pm


Return to Graphics

Who is online

Users browsing this forum: No registered users and 1 guest