Board index FlightGear Support Graphics

Low Framerate

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Re: Low Framerate

Postby V12 » Sat Aug 24, 2019 6:38 am

OK, try this :
- select UFO
- in settings select default renderer and run sim
- turn off all shaders
- end FG
- run FG again with Cessna and report FPS
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1446
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: Low Framerate

Postby legoboyvdlp » Sat Aug 24, 2019 7:59 am

He already is running on the lowest settings so that won't do anything unfortunately.

Looks like you are starting on water. Try starting at an airport such as PHTO - PHTO's scenery comes with FlightGear now - or else enable automatic scenery download.
User avatar
legoboyvdlp
 
Posts: 6937
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Low Framerate

Postby wkitty42 » Sat Aug 24, 2019 3:14 pm

MrSefaa wrote in Sat Aug 24, 2019 4:47 am:https://imgur.com/a/VVLC1mQ

thanks... can you confirm that you have the latest video drivers installed?
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5572
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Low Framerate

Postby MrSefaa » Sun Aug 25, 2019 2:38 am

wkitty42 wrote in Sat Aug 24, 2019 3:14 pm:
MrSefaa wrote in Sat Aug 24, 2019 4:47 am:https://imgur.com/a/VVLC1mQ

thanks... can you confirm that you have the latest video drivers installed?


As far as I can tell, yea.
MrSefaa
 
Posts: 20
Joined: Wed Aug 21, 2019 2:59 am

Re: Low Framerate

Postby MrSefaa » Sun Aug 25, 2019 2:42 am

V12 wrote in Sat Aug 24, 2019 6:38 am:OK, try this :
- select UFO
- in settings select default renderer and run sim
- turn off all shaders
- end FG
- run FG again with Cessna and report FPS


Everything is on all low settings, max performance settings. However, I just noticed that I believe the CPU isn't rendering the scenery fast enough or something. For example, when I look to the right, it'll lag spike. But after like 5 secs, it'll have 60+ fps. If I look to the left, the same thing happens.
MrSefaa
 
Posts: 20
Joined: Wed Aug 21, 2019 2:59 am

Re: Low Framerate

Postby GamingSkull » Tue Aug 27, 2019 1:17 pm

Hello i want to ask why does my game lag like crazy (literaly unplayable)

I use Windows 10 with the latest version of FlightGear
i have an RX 580 with 8 gb of DDR5 vram
16 GB of DDR4 ram
and an ryzen 5 2600

Thanks
GamingSkull
 
Posts: 1
Joined: Tue Aug 27, 2019 1:13 pm

Re: Low Framerate

Postby Thorsten » Tue Aug 27, 2019 1:51 pm

@GamingSkull

Read this thread from the beginning, follow the advice and answer all the questions. Oh - and it's not a game, it's a simulator.
Thorsten
 
Posts: 10840
Joined: Mon Nov 02, 2009 8:33 am

Re: Low Framerate

Postby V12 » Tue Aug 27, 2019 5:03 pm

GamingSkull :
Try this :
- start FG with parameter in blue box :

Image

- choose aircraft and start sim on Innsbruck (LOWI) airport
- after scenery download is completed, 2 times go to Menu - Debug - Cycle On screen Statistic to obtain similar minicharts on the screen :

Image

With F3 make screenshot and post it here.
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1446
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: Low Framerate

Postby MrSefaa » Wed Aug 28, 2019 10:24 pm

GamingSkull wrote in Tue Aug 27, 2019 1:17 pm:Hello i want to ask why does my game lag like crazy (literaly unplayable)

I use Windows 10 with the latest version of FlightGear
i have an RX 580 with 8 gb of DDR5 vram
16 GB of DDR4 ram
and an ryzen 5 2600

Thanks


I literally have the same specs as you aside from the cpu... So... idk man (I lag like hell too)
MrSefaa
 
Posts: 20
Joined: Wed Aug 21, 2019 2:59 am

Re: Low Framerate

Postby MrSefaa » Wed Aug 28, 2019 10:30 pm

V12 wrote in Tue Aug 27, 2019 5:03 pm:GamingSkull :
Try this :
- start FG with parameter in blue box :

Image

- choose aircraft and start sim on Innsbruck (LOWI) airport
- after scenery download is completed, 2 times go to Menu - Debug - Cycle On screen Statistic to obtain similar minicharts on the screen :

Image

With F3 make screenshot and post it here.


https://imgur.com/a/3MAnZfl
MrSefaa
 
Posts: 20
Joined: Wed Aug 21, 2019 2:59 am

Re: Low Framerate

Postby V12 » Thu Aug 29, 2019 6:36 am

Nothing non standard. What fps You had in that test ?
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1446
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: Low Framerate

Postby wkitty42 » Fri Aug 30, 2019 12:19 am

the bottom right hand corner of his pic on imgur shows "0" FPS...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5572
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Low Framerate

Postby V12 » Fri Aug 30, 2019 5:58 am

Sorry, I was blind :oops: It is really very strange. By graph all processes looks OK with standard execution time. It should be driver related problem. Try reinstall current driver with older one and test again.
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1446
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: Low Framerate

Postby Icecode GL » Fri Aug 30, 2019 8:59 am

Really really weird, those OSG bars show a fps of at least 60. There is definitely nothing wrong with the drivers/anything graphics related. Looks like the simulation is paused...
Icecode GL
 
Posts: 525
Joined: Thu Aug 12, 2010 12:17 pm
Location: Spain
Callsign: icecode
Version: GIT
OS: Arch Linux

Re: Low Framerate

Postby Robertfm » Sat Sep 07, 2019 7:50 pm

Weird event. For no apparent reason my frame rate dropped to half it's normal 60 when landing at EGSH (Norwich). The runway looked as though it was breaking up. I took off again and it stayed the same low rate (for my system). I then referred to a thread relating to AI and frame rate. Now I have never altered any AI setting so AI traffic was on. According to the other thread If I turn it off that helps.

I did and sure enough the FR went back to 60. So I clicked AI traffic back on and the FR dropped again. Whilst this solved the problem how on earth did it happen in the first place. I am on FG V19.1, which does seem to crash rather a lot compared to 2018.3.2.

Any ideas
Robertfm
 
Posts: 330
Joined: Thu Apr 25, 2019 4:56 pm

PreviousNext

Return to Graphics

Who is online

Users browsing this forum: Google [Bot] and 3 guests