Board index FlightGear Support Graphics

Unreadable white text on white background on Twin Otter GPS

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Re: Unreadable white text on white background on Twin Otter

Postby legoboyvdlp » Thu Aug 15, 2019 4:41 pm

Just make sure you run this command:
Code: Select all
git checkout fgfs-342-1
User avatar
legoboyvdlp
 
Posts: 6938
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Unreadable white text on white background on Twin Otter

Postby SurferTim » Thu Aug 15, 2019 4:46 pm

legoboyvdlp wrote in Thu Aug 15, 2019 4:41 pm:Just make sure you run this command:
Code: Select all
git checkout fgfs-342-1

Not sure what that does, but ok. Is that before the cmake/make/install or after?

Once I do this cmake/make/install, I need to run
./download_and_install.sh SIMGEAR FGFS
Nothing else? No OSG?

Edit: It showed it was building 3.4.2 files. Install went ok. The simulator runs now, but the text colors are still wrong.
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 282
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: Unreadable white text on white background on Twin Otter

Postby legoboyvdlp » Thu Aug 15, 2019 5:59 pm

You need to do it in this order:

- Clone OSG from zakalawe's fork
- Checkout the fgfs-342-1 branch
- Build OSG
- Build SG
- Build FG

The second step is the most important - if you just clone the repository and build you still will get the wrong text colours. Checking out the branch will load up the branch that has various fixes / modifications done for FlightGear.
User avatar
legoboyvdlp
 
Posts: 6938
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Unreadable white text on white background on Twin Otter

Postby SurferTim » Thu Aug 15, 2019 6:32 pm

When I entered the git checkout, it told me it was the current branch.

I am rebuilding OSG SIMGEAR FGFS

Edit: It did not fix the colors. Most text still white.
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 282
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: Unreadable white text on white background on Twin Otter

Postby legoboyvdlp » Thu Aug 15, 2019 7:34 pm

Hmm - I wonder is SG and FG actually using the OSG you compiled? It's a known bug and a known soloution... Is the old version of OSG still there from GitHub.com/openscenegraph/? If so that's probably why - if not not so sure.
User avatar
legoboyvdlp
 
Posts: 6938
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Unreadable white text on white background on Twin Otter

Postby SurferTim » Thu Aug 15, 2019 7:57 pm

According to the d_n_c script, if OSG is selected, it will download the OSG from the openscenegraph Github site and build it.

That is why I asked.

I would have guessed SIMGEAR and FGFS only.
Code: Select all
./download_and_compile -j4 SIMGEAR FGFS


I started over. This time I am not going to build OSG, just SIMGEAR, FGFS, and DATA
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 282
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: Unreadable white text on white background on Twin Otter

Postby legoboyvdlp » Thu Aug 15, 2019 8:55 pm

That sounds righ, yep. Hope it works!
User avatar
legoboyvdlp
 
Posts: 6938
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Unreadable white text on white background on Twin Otter

Postby Alant » Thu Aug 15, 2019 9:57 pm

After all of these downloads and rebuilds, I don´t know how mixed up your system may be. It may help if you check that your environment variables are all still pointing to the ones that are relevant to the current build. Can you can safely delete directories and files that relate to old builds?
"apt remove" may be needed if you still have stuff from Ubuntou or saikrishna.
Alant
 
Posts: 904
Joined: Wed Jun 23, 2010 5:58 am
Location: Portugal
Callsign: Tarnish99
Version: from Git
OS: Windows 10

Re: Unreadable white text on white background on Twin Otter

Postby SurferTim » Thu Aug 15, 2019 10:02 pm

Well, it runs, and most of the colors are good. Some of the text has color, but most is white.

There is no alternative AFAIK. The OSG installed with the d_n_c script doesn't even start the simulator. Immediate crash.

I can deal with it like this. :D

@Alant:
Yes, I can empty directories without problem.
I have no OSG installed from the Ubuntu repository.
The last couple installs went pretty good.
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 282
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: Unreadable white text on white background on Twin Otter

Postby legoboyvdlp » Fri Aug 16, 2019 8:28 am

If you want to see if it is fixed maybe you could open up the IDG A32X and show a screenshot of the autopilot panel and the pedestal?

Glad it's fixed ;)
User avatar
legoboyvdlp
 
Posts: 6938
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Unreadable white text on white background on Twin Otter

Postby SurferTim » Fri Aug 16, 2019 12:37 pm

The "route" feature display in the Citation-X has text for fixes, waypoints, etc, in color where appropriate. Cyan and magenta.

Is that the one from the Octal450 3rd party livery? If so, I'll try to download and take a quick flight in it after getting your screenshot.

Gonna take a flight first in the Twin Otter.
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 282
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: Unreadable white text on white background on Twin Otter

Postby legoboyvdlp » Fri Aug 16, 2019 1:54 pm

Certainly not sure how you could fly it before downloading it but yes :P
User avatar
legoboyvdlp
 
Posts: 6938
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Unreadable white text on white background on Twin Otter

Postby Alant » Fri Aug 16, 2019 2:17 pm

SurferTim wrote in Tue Aug 13, 2019 1:23 pm:
Alant wrote in Tue Aug 13, 2019 1:05 pm:AFAIK, this bug affects other aircraft with glass cockpits.

OK, a glass cockpit? I'm not familiar with that term.


This is how glass cockpits started. Back in 1977 the two main British aircraft companies (BAC and HSA) collaborated in a joint project which we called the Advanced FlightDeck https://www.flightglobal.com/FlightPDFArchive/1977/1977%20-%201182.PDF. The attached is from BAC´s 1978 Calendar . They could not afford a pretty girl, so the handsome young pilot is yours truly.
Image

Alan
Alant
 
Posts: 904
Joined: Wed Jun 23, 2010 5:58 am
Location: Portugal
Callsign: Tarnish99
Version: from Git
OS: Windows 10

Re: Unreadable white text on white background on Twin Otter

Postby SurferTim » Fri Aug 16, 2019 2:53 pm

My flight in the Twin Otter went well.

I wish I could say the same about the A320. No matter which version I try to run, it throws an error "FGPropertyValue::GetValue() The property /systems/electrical/bus/ac1 does not exist", and aborts the app.

@Alant: Nice pic. Lucky guy!

Edit: The C172 has a Garmin 196 option. It has the same problem. The rest of the cockpit looks fine.
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 282
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: Unreadable white text on white background on Twin Otter

Postby legoboyvdlp » Fri Aug 16, 2019 3:27 pm

Have a look in INSTALL.MD - make sure you removed -master from the folder name (as is standard for every aircraft downloaded from GitHub).
User avatar
legoboyvdlp
 
Posts: 6938
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

PreviousNext

Return to Graphics

Who is online

Users browsing this forum: No registered users and 3 guests