Board index FlightGear Support Graphics

Clouds LOD

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Re: Clouds LOD

Postby V12 » Fri Oct 25, 2019 8:01 pm

OK, will try.
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1665
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: Clouds LOD

Postby V12 » Fri Oct 25, 2019 9:54 pm

Test with clouds converted into RGB subformat unsuccessful :( Short video :
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1665
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: Clouds LOD

Postby Richard » Sat Oct 26, 2019 9:14 am

V12 wrote in Fri Oct 25, 2019 7:31 pm:
legoboyvdlp wrote in Fri Oct 25, 2019 6:03 pm:the DDS doesn't like the cloud images (as I recall something to do with transparency).

This is not only cloud problem. On Concorde I had some .PNG textures in grayscale subformat.


The three main problems are;

1. The particular DXT encoding that are used in the DDS texture cache do not support grayscale images - this can result in strange things happening. As yet I've not found a way to reliably detect a grayscale png (due to the way that OSG works I don't know that a particular file is png as the loader obviously loads the png as an OSG image)

2. Certain textures are functional textures and cannot be DDS/DXT(1,3,5) encoded. There is a built in set of exclusion rules based on the origin - I need specific steps to reproduce the problem *or* a texture filename that shows the problem so I can investigate a fix.

3. Possibly some of the textures in FGData will need to be re-encoded as RGB; I'm trying to avoid doing this as I'd like the texture cache to be smart enough to not require this; but it might be necessary.
Richard
 
Posts: 737
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: Clouds LOD

Postby V12 » Sat Oct 26, 2019 12:34 pm

I converted all grayscale .png to RGB .png but it did not help. Testplan :
0. turn on texture caching and restart sim
1. spawn with ufo somewhere
2. select Advanced weather, choose Thunderstorm scenario
3. seek lightnings, zoom in and You will see cumulonimbus, zoom out and CB will dissapear
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1665
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Previous

Return to Graphics

Who is online

Users browsing this forum: No registered users and 2 guests