Board index FlightGear Support Graphics

Low CPU and GPU usage, low framerates

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Low CPU and GPU usage, low framerates

Postby Hassan272 » Wed Mar 20, 2019 3:03 pm

Hi all,
I've been having performance issues with FlightGear 2018.3.2. I run the sim on a gaming laptop with fairly solid specs - i5-6300HQ, 8GB DDR4 RAM and a GTX 960M with 4GB DDR5 VRAM - yet my framerates are low and get worse over time, dropping from 45fps to 10-15fps over the course of two hours.
Surprisingly though, my CPU and GPU usage never exceed 65% and my temps are in the normal range, which tells me that the program is not utilising the full power of the system at all. I run maxed-out ALS at 1920x1080 with no MSAA as I'm sure my system should handle that at a minimum of 35fps at any given location as I've tested, but I only get smooth frames at the start of the simulation and then performance takes a nosedive.
What might be the cause? Is it just my system, or is the sim not fully performance-optimised yet? Or perhaps it's the aircraft I fly (IDG-A32X)?
Hassan272
 
Posts: 6
Joined: Thu Jul 06, 2017 5:23 pm

Re: Low CPU and GPU usage, low framerates

Postby Thorsten » Wed Mar 20, 2019 3:54 pm

I suspect if neither CPU nor GPU are maxed out, it's your OS throttling the process for some reason. If FG gobbles up resources, in my experience it goes to 100% with something and stays there.

(Actually, I had a Windows case of the nvidia driver taking another rendering application into power saving after 5 minutes - then the framerates took a dive of course - the solution was to tell the driver to always give that process full power - maybe it's as trivial as that...)
Thorsten
 
Posts: 10693
Joined: Mon Nov 02, 2009 8:33 am

Re: Low CPU and GPU usage, low framerates

Postby Hassan272 » Wed Mar 20, 2019 4:23 pm

I might as well check my Nvidia driver's power settings then if that's the case. Thanks for the support :D
Hassan272
 
Posts: 6
Joined: Thu Jul 06, 2017 5:23 pm

Re: Low CPU and GPU usage, low framerates

Postby Richard » Wed Mar 20, 2019 5:46 pm

Use the OSG Stats to see how long the frame pause is; I've seen certain aircraft that will gradually get slower because of growth in the events manager usage over time that affects the framerate because the CPU becomes more and more busy.

You can also use the performance monitor to view usage which does also affect framerate in itself; but even so it can be useful to identify if any individual subsystem is taking a lot of CPU. On versions after 2019.1 when the performance monitor is active there will also be overrun reports for individual subsystems on the console.
Richard
 
Posts: 699
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: Low CPU and GPU usage, low framerates

Postby xDraconian » Thu Mar 21, 2019 2:12 am

The last few days I've been suspect of animated jetways causing framerate drop over time. Since I've turned jetways off I'm getting much better stability.
I don't have any hard evidence that there is an issue directly tied to jetways, but you may to disable them and see if your situation improves.

Scott
xDraconian
 
Posts: 236
Joined: Sun Jan 21, 2018 5:53 am
Version: Git
OS: Linux Mint

Re: Low CPU and GPU usage, low framerates

Postby V12 » Fri Mar 22, 2019 8:25 am

Hassan272 wrote in Wed Mar 20, 2019 3:03 pm:...my framerates are low and get worse over time, dropping from 45fps to 10-15fps over the course of two hours.
Your machine probably swapping memory to harddrive. Try lower settings for Bare LOD range and ALS max visibility set to 90 km.
Sometime I have this problem too. For me, reason is in not optimal, ehm, better word is bad, ehm ehm memory management, when FG doesn't release memory. It is very strange if I take off from Paris, heading direct to KJFK, when I leave Europe, I have 8 GB used memory and this value slowly rise to 9 GB in flight over the sea without any scenery to point 200 nm from Newfoundland. Only deep blue sea will eat 1 GB of memory. IMHO, FG is optimized only for low level low speed flying in small regions, because only in this case is high probability of the repetitive usage of the loaded scenery chunks. But not for transcontinental flights.

For example - properly configured old 32bit 3GB RAM limited FSX can do flight from LZIB to LPPT with resource heavy PMDG737 without any trouble with visibility 160 km. And scenery is still much more eye-candy than in FG...
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1332
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12


Return to Graphics

Who is online

Users browsing this forum: No registered users and 1 guest