Board index FlightGear Support Graphics

FGPanel says: GLEW version 2.1 not supported : 1.13.0

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

FGPanel says: GLEW version 2.1 not supported : 1.13.0

Postby PatrikB » Sun Jul 01, 2018 3:19 pm

Hello,

I'm building a simulator:
Image
The main computer is a an AMD Athlon 2x2.5Ghz / NVidia GeForce GTX 1050Ti / 4G RAM / SSD+HDD running Linux Mint 18.3 and connected to a beamer.

That works quite fine but I would like to get the instruments and radio stack on the small old laptop connected to a 15" display, in that way the beamer would render only the outside view without instrument.
I'm absolutely fine with 2D panels, therefore I thought FGPanel is what I need.

i followed https://sourceforge.net/p/flightgear/flightgear/ci/next/tree/utils/fgpanel/README but the only thing I get is:
Code: Select all
fgpanel --fg-root=/usr/share/games/flightgear --panel=Aircraft/c172p/Panels/MyPanel.xml
GLEW version 2.1 not supported : 1.13.0


Did I miss something?
System is Lubuntu 16.04 32b, fresh installed, fgfs is 2018.2.1, installed from ppa:saiarcot895 and, yes, libglew is 1.13.

(and I did not find a place to post a first presentation topic to introduce myself. :? )
PatrikB
 
Posts: 4
Joined: Sun Jul 01, 2018 7:05 am
Location: LFGC
Version: 2018.2.1
OS: Linux Mint / Lubuntu

Re: FGPanel says: GLEW version 2.1 not supported : 1.13.0

Postby Icecode GL » Wed Jul 18, 2018 12:39 pm

FGPanel requires GLEW version 2.1 to work, while you have 1.13. You might want to try building GLEW 2.1 from source and compile FGPanel with it. Another option, since you are using a Debian based distro, is looking for a .deb package of GLEW 2.1. Debian experimental has it here. I'm not familiar with Ubuntu and its derivatives, but maybe there are PPAs you could use as well. All of this might be kind of troublesome because GLEW has dependencies that could or could not be updated in your system, so you might end up installing a few dependencies from source as well.

As a last resort you could just remove lines 136 to 139 in $FG_SOURCE/utils/fgpanel/FGGLApplication.cxx to avoid the version check. If there is a version check, fgpanel probably uses features of GLEW 2.1, so I don't think it will work, but you can try if you want.

Kind of a late response, but in case you are still stuck. :)
Icecode GL
 
Posts: 498
Joined: Thu Aug 12, 2010 12:17 pm
Location: Spain
Callsign: icecode
Version: GIT
OS: Arch Linux

Re: FGPanel says: GLEW version 2.1 not supported : 1.13.0

Postby PatrikB » Fri Jul 20, 2018 8:11 am

Thx for the answer,

You are not too late, I'm still stuck, but one step further.
I also came to conclusion that I have to compile, therefore I used download_and_compile.sh.

I get 2018.3.0 compiled and working.
BUT
fgpanel is not compiled.

I also try to make all in fgpanel directory, nothing.

I will have to investigate the makefile content now. :)
(any help is welcome, thx again)
PatrikB
 
Posts: 4
Joined: Sun Jul 01, 2018 7:05 am
Location: LFGC
Version: 2018.2.1
OS: Linux Mint / Lubuntu

Re: FGPanel says: GLEW version 2.1 not supported : 1.13.0

Postby FlugHund » Fri Jul 20, 2018 8:25 am

Make sure you have packages fluid, libbz2-dev, libfltk1.3-dev, libxi-dev and libxmu-dev installed.
If it still doesn't work provide the log file "compilation_log.txt". Either upload it or paste its content to some paste-site (like https://dpaste.de/ or such).
Also, make sure you've got the latest version of the script (http://wiki.flightgear.org/Scripted_Compilation_on_Linux_Debian/Ubuntu#Update_Available).
User avatar
FlugHund
 
Posts: 512
Joined: Thu Mar 01, 2007 3:27 pm
Callsign: D-HUND
IRC name: D-HUND / debdog
Version: next
OS: Devuan


Return to Graphics

Who is online

Users browsing this forum: No registered users and 1 guest