Board index FlightGear Support Graphics

No background and tutorials?  Topic is solved

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

No background and tutorials?

Postby Zman12804 » Sun Mar 18, 2018 10:17 pm

So I recently downloaded this game to learn a little more about aviation. As I loaded into the game, I thought it looked incredible. But then I went into the tutorial to learn how to control my aircraft. I was met with a fairly large crash and the background was completely blue, which prevented me from taking out the wheel chocks, so I couldn't finish the tutorial. I tried the next tutorial, and I was met with the same exact thing. Also, while I did the engine startup tutorial, the engine would not start even though I did the tutorial step by step. I am using an iMac, version 10.13.3, and FlightGear 2017.3.1. for Mac OSX. My graphics card is and Intel Iris Pro 1536 MB.I have attached an image of my problem here. Image

Thank you for any help.
Zman12804
 
Posts: 2
Joined: Sun Mar 18, 2018 9:48 pm

Re: No background and tutorials?  

Postby wkitty42 » Sun Mar 18, 2018 10:36 pm

this looks like the c172p default craft that comes with the sim (not game!)... do you have "download terrain automatically" turned ON in the launcher? it sounds like you are stuck in the water because you don't have the terrain for Sabadell Airport (LELL)... you need to download it so you have some real land to work on :)

what do you see if you use the 'v' key to switch to an outside view? please post another screen shot of that...

use 'V' to go back through the views... there is a difference between uppercase and lower ;)
"Cockpit view" is the normal view used... you should see the view name in a tooltip that pops up in the top middle of the screen when you change views...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4897
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: No background and tutorials?

Postby Zman12804 » Mon Mar 19, 2018 1:02 am

Hi! Thank you for the advice and I now have FlightGear up and running smoothly!
Last edited by Gijs on Mon Mar 19, 2018 7:34 am, edited 1 time in total.
Reason: Please don't quote the entire post directly above yours.
Zman12804
 
Posts: 2
Joined: Sun Mar 18, 2018 9:48 pm


Return to Graphics

Who is online

Users browsing this forum: No registered users and 4 guests