Board index FlightGear Support Graphics

Ihave a problem with the options disappearing in the menu b  Topic is solved

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Ihave a problem with the options disappearing in the menu b

Postby sultan » Sun Feb 18, 2018 4:12 pm

Hello all,

I have a problem and I don't know why? :cry: :cry:

The problem is in the options disappearing from the menu bar!!! :(

(1)
Image

(2)
Image

(3)
Image

(4)
Image


Video
https://drive.google.com/file/d/1EL08Ec ... sp=sharing



Please, I really want help :cry: :cry:
sultan
 
Posts: 12
Joined: Sun Feb 18, 2018 1:27 am
Location: Kingdom Of Saudi Arabia, Mecca
Callsign: sultan
Version: 2018.1.1
OS: Windows 10 64bit

Re: Ihave a problem with the options disappearing in the men  

Postby it0uchpods » Sun Feb 18, 2018 4:36 pm

Hi,
I had this issue while running FG on an AMD graphics card, you can do a Debug --> Cycle GUI, and make sure ALS is off (View --> Rendering options).

Kind Regards,
Josh
it0uchpods/WTF411

FGFS Aircraft Developer
Lead Programmer at it0uchpods Design Group
Download High Quality Aircraft from it0uchpods Hangar
User avatar
it0uchpods
 
Posts: 3479
Joined: Tue Oct 06, 2015 12:51 pm
Version: 2018.2.1
OS: Windows 10 x64

Re: Ihave a problem with the options disappearing in the men

Postby FlugHund » Sun Feb 18, 2018 6:49 pm

The issue here is caused by the font somehow. Since I prefer the default GUI style I went for another solution, replacing the font. To do so alter file $FG_ROOT/gui/style/anthrax.xml [1], line 14.

Before:
Code: Select all
<name type="string">HELVETICA_12</name>


After:
Code: Select all
<name type="string">AvantGarde-Demi.txf</name>


[1] https://sourceforge.net/p/flightgear/fg ... nthrax.xml
User avatar
FlugHund
 
Posts: 491
Joined: Thu Mar 01, 2007 3:27 pm
Callsign: D-HUND
IRC name: D-HUND / debdog
Version: next
OS: Devuan

Re: Ihave a problem with the options disappearing in the men

Postby Clive2670 » Sun Feb 18, 2018 6:54 pm

Josh is exactly right, I have a AMD R7-M260, and this is one of the issues I get, Sadly there is no way around or fix for the issue, except for cycle GUI, This will "cure" the problem, I find that I can use ALS because I don't get the problem back, Well maybe the odd slow flicker but I can still read all text. Hope my input helps
Thanks Clive aka: G-BLS01, BIGJET1
Can be seen flying the Boeing 777-200LR
Toshiba laptop,
Intel i5 4210U,
16Gb RAM,
AMD R7-M260 graphics 2Gb RAM
User avatar
Clive2670
 
Posts: 580
Joined: Mon Feb 08, 2016 7:11 pm
Location: Anywhere in the World at some point on Flightgear!
Callsign: G-BLS01, BIGJET1
Version: 2018.1.1
OS: Windows 10 64bit

Re: Ihave a problem with the options disappearing in the men

Postby sultan » Sun Feb 18, 2018 7:27 pm

it0uchpods wrote in Sun Feb 18, 2018 4:36 pm:Hi,
I had this issue while running FG on an AMD graphics card, you can do a Debug --> Cycle GUI, and make sure ALS is off (View --> Rendering options).

Kind Regards,
Josh



I love you <3 <3

thank you thank you.

The problem has been resolved
sultan
 
Posts: 12
Joined: Sun Feb 18, 2018 1:27 am
Location: Kingdom Of Saudi Arabia, Mecca
Callsign: sultan
Version: 2018.1.1
OS: Windows 10 64bit

Re: Ihave a problem with the options disappearing in the men

Postby sultan » Sun Feb 18, 2018 7:28 pm

FlugHund wrote in Sun Feb 18, 2018 6:49 pm:The issue here is caused by the font somehow. Since I prefer the default GUI style I went for another solution, replacing the font. To do so alter file $FG_ROOT/gui/style/anthrax.xml [1], line 14.

Before:
Code: Select all
<name type="string">HELVETICA_12</name>


After:
Code: Select all
<name type="string">AvantGarde-Demi.txf</name>


[1] https://sourceforge.net/p/flightgear/fg ... nthrax.xml



thank you for help
sultan
 
Posts: 12
Joined: Sun Feb 18, 2018 1:27 am
Location: Kingdom Of Saudi Arabia, Mecca
Callsign: sultan
Version: 2018.1.1
OS: Windows 10 64bit

Re: Ihave a problem with the options disappearing in the men

Postby sultan » Sun Feb 18, 2018 7:29 pm

Clive2670 wrote in Sun Feb 18, 2018 6:54 pm:Josh is exactly right, I have a AMD R7-M260, and this is one of the issues I get, Sadly there is no way around or fix for the issue, except for cycle GUI, This will "cure" the problem, I find that I can use ALS because I don't get the problem back, Well maybe the odd slow flicker but I can still read all text. Hope my input helps



thank you
sultan
 
Posts: 12
Joined: Sun Feb 18, 2018 1:27 am
Location: Kingdom Of Saudi Arabia, Mecca
Callsign: sultan
Version: 2018.1.1
OS: Windows 10 64bit

Re: Ihave a problem with the options disappearing in the men

Postby RJ5576 » Mon Feb 19, 2018 7:04 am

Is antialiasing on in the launcher? I find that the problem goes away when I turn it off.
RJ5576
 
Posts: 88
Joined: Wed Feb 20, 2013 3:24 am
Location: Between KSEA and KPDX
Callsign: RJ5576
Version: 2018.1.1
OS: Linux Mint Sylvia

Re: Ihave a problem with the options disappearing in the men

Postby Thorsten » Mon Feb 19, 2018 12:04 pm

The problem seems to be a weird resource management issue by the driver, and it usually gets better whenever you reduce the load the graphics card has to process, it gets worse when you increase it. There doesn't seem to be 'the' particular thing that causes it.
Thorsten
 
Posts: 9825
Joined: Mon Nov 02, 2009 8:33 am

Re: Ihave a problem with the options disappearing in the men

Postby sultan » Tue Feb 20, 2018 12:48 pm

Will the problem be resolved in the new version of the software?
sultan
 
Posts: 12
Joined: Sun Feb 18, 2018 1:27 am
Location: Kingdom Of Saudi Arabia, Mecca
Callsign: sultan
Version: 2018.1.1
OS: Windows 10 64bit

Re: Ihave a problem with the options disappearing in the men

Postby Thorsten » Tue Feb 20, 2018 4:08 pm

The problem seems to be a weird resource management issue by the driver,


If the analysis is correct, we can't resolve it, we can only ease it - some work on the ATI/AMD experience has been done by Richard, but don't expect miracles.
Thorsten
 
Posts: 9825
Joined: Mon Nov 02, 2009 8:33 am

Re: Ihave a problem with the options disappearing in the men

Postby Clive2670 » Tue Feb 20, 2018 5:52 pm

It can be frustrating but I have learnt "to live with it"
Thanks Clive aka: G-BLS01, BIGJET1
Can be seen flying the Boeing 777-200LR
Toshiba laptop,
Intel i5 4210U,
16Gb RAM,
AMD R7-M260 graphics 2Gb RAM
User avatar
Clive2670
 
Posts: 580
Joined: Mon Feb 08, 2016 7:11 pm
Location: Anywhere in the World at some point on Flightgear!
Callsign: G-BLS01, BIGJET1
Version: 2018.1.1
OS: Windows 10 64bit

Re: Ihave a problem with the options disappearing in the men

Postby it0uchpods » Tue Feb 20, 2018 8:10 pm

Yep.

Glad it's fixed. Enjoy FlightGear! :)

Kind Regards,
Josh
it0uchpods/WTF411

FGFS Aircraft Developer
Lead Programmer at it0uchpods Design Group
Download High Quality Aircraft from it0uchpods Hangar
User avatar
it0uchpods
 
Posts: 3479
Joined: Tue Oct 06, 2015 12:51 pm
Version: 2018.2.1
OS: Windows 10 x64


Return to Graphics

Who is online

Users browsing this forum: No registered users and 1 guest