Board index FlightGear Support Graphics

graphic card

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

graphic card

Postby ponipei » Tue Dec 26, 2017 4:21 pm

Hi I need your kind help for a problem I am trying to solve since three months: Simply after a short time after take-off the screen freezes and then blackens. In rare cases the screen starts working again and the flight can continue, till the next stop which is in general unrecoverable. I have to act on the power button to stop and start again. Bad practice, I know. Here is a list of things I have tried to solve the problem ( I am too affectionate to FlightGear to give up):

Operating System The problem occurs almost identically in Windows 10 and Ubuntu 17.10 Artful Aardvark.
Changing the battery charger. I had the impression that the CPU temperature was a possible cause, but the system crashes even at low CPU temperatures.
Changing from Weyland to X and viceversa. No way.
All possible combination of parameters. The only aircraft working is the UFO.
The log files don't seem to indicate what is happening, at least to me.
I ran all possible tests on the graphic cards. The most complete one seems to be glmark2 which gives a score of 2389. Not so bad.

Here is a brief description of my notebook.

Code: Select all
HP Envy 1010 el notebook
OS Ubuntu 17.10 64 bit
          product: Intel(R) Core(TM) i7 CPU       Q 720  @ 1.60GHz
          vendor: Intel Corp.
          physical id: 1
          bus info: cpu@0
          size: 2592MHz
          width: 64 bits
                description: VGA compatible controller
                product: Broadway PRO [Mobility Radeon HD 5850]
                vendor: Advanced Micro Devices, Inc. [AMD/ATI]
                physical id: 0
                bus info: pci@0000:01:00.0
                version: 00
                width: 64 bits
                clock: 33MHz
  description: Audio device
             product: 5 Series/3400 Series Chipset High Definition Audio
             vendor: Intel Corporation
             physical id: 1b
             bus info: pci@0000:00:1b.0
             version: 05
             width: 64 bits
             clock: 33MHz
 OpenGL Information
    GL_VENDOR:     X.Org
    GL_RENDERER:   AMD JUNIPER (DRM 2.50.0 / 4.13.0-21-generic, LLVM 5.0.0)
    GL_VERSION:    3.0 Mesa 17.2.2
[build] use-vbo=false: FPS: 2691 FrameTime: 0.372 ms
[build] use-vbo=true: FPS: 3895 FrameTime: 0.257 ms
[texture] texture-filter=nearest: FPS: 3806 FrameTime: 0.263 ms
[texture] texture-filter=linear: FPS: 3759 FrameTime: 0.266 ms
[texture] texture-filter=mipmap: FPS: 3842 FrameTime: 0.260 ms
[shading] shading=gouraud: FPS: 3449 FrameTime: 0.290 ms
[shading] shading=blinn-phong-inf: FPS: 39 FrameTime: 25.641 ms
[shading] shading=phong: FPS: 1260 FrameTime: 0.794 ms
[shading] shading=cel: FPS: 1238 FrameTime: 0.808 ms
[bump] bump-render=high-poly: FPS: 2090 FrameTime: 0.478 ms
[bump] bump-render=normals: FPS: 3867 FrameTime: 0.259 ms
[bump] bump-render=height: FPS: 3833 FrameTime: 0.261 ms
[effect2d] kernel=0,1,0;1,-4,1;0,1,0;: FPS: 3651 FrameTime: 0.274 ms
[effect2d] kernel=1,1,1,1,1;1,1,1,1,1;1,1,1,1,1;: FPS: 1960 FrameTime: 0.510 ms
[pulsar] light=false:quads=5:texture=false: FPS: 3243 FrameTime: 0.308 ms
[desktop] blur-radius=5:effect=blur:passes=1:separable=true:windows=4: FPS: 1506 FrameTime: 0.664 ms
[desktop] effect=shadow:windows=4: FPS: 1683 FrameTime: 0.594 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 408 FrameTime: 2.451 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=subdata: FPS: 489 FrameTime: 2.045 ms
[buffer] columns=200:interleave=true:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 437 FrameTime: 2.288 ms
[ideas] speed=duration: FPS: 217 FrameTime: 4.608 ms
[jellyfish] <default>: FPS: 2792 FrameTime: 0.358 ms
[terrain] <default>: FPS: 0 FrameTime: inf ms
[shadow] <default>: FPS: 1282 FrameTime: 0.780 ms
[refract] <default>: FPS: 430 FrameTime: 2.326 ms
[conditionals] fragment-steps=0:vertex-steps=0: FPS: 3536 FrameTime: 0.283 ms
[conditionals] fragment-steps=5:vertex-steps=0: FPS: 3543 FrameTime: 0.282 ms
[conditionals] fragment-steps=0:vertex-steps=5: FPS: 3530 FrameTime: 0.283 ms
[function] fragment-complexity=low:fragment-steps=5: FPS: 3541 FrameTime: 0.282 ms
[function] fragment-complexity=medium:fragment-steps=5: FPS: 3535 FrameTime: 0.283 ms
[loop] fragment-loop=false:fragment-steps=5:vertex-steps=5: FPS: 3545 FrameTime: 0.282 ms
[loop] fragment-steps=5:fragment-uniform=false:vertex-steps=5: FPS: 3555 FrameTime: 0.281 ms
[loop] fragment-steps=5:fragment-uniform=true:vertex-steps=5: FPS: 2213 FrameTime: 0.452 ms
                                  glmark2 Score: 2389

Could the 0 FPS for terrain shading possibly be an issue ?

I would be very grateful for any possible suggestion aimed at solving the problem

Thank you
Last edited by bugman on Tue Dec 26, 2017 9:05 pm, edited 1 time in total.
Reason: Added code tags.
Posts: 8
Joined: Fri Oct 21, 2016 2:16 pm

Re: graphic card

Postby wkitty42 » Tue Dec 26, 2017 4:46 pm

ponipei wrote in Tue Dec 26, 2017 4:21 pm:
Code: Select all
OpenGL Information
    GL_VENDOR:     X.Org
    GL_RENDERER:   AMD JUNIPER (DRM 2.50.0 / 4.13.0-21-generic, LLVM 5.0.0)
    GL_VERSION:    3.0 Mesa 17.2.2

at a guess, i'd say this... have you tried updating your openGL?

it is possible that it just won't run n that system with that video card and driver...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
Posts: 5560
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: graphic card

Postby ponipei » Wed Dec 27, 2017 3:46 pm

Well I don't know how to do it. If I go to the system update it say that all the software is up to date. I could I do it manually ?
thank you
Posts: 8
Joined: Fri Oct 21, 2016 2:16 pm

Re: graphic card SOLVED

Postby ponipei » Wed Jan 10, 2018 10:57 pm

Well the problem was solved just casually. I was operating with a compatible battery charger and no battery, because the original battery died. I decided to buy a "compatible" battery, but I had to return it to the manufacturer because id didn't work. So I spent about 100 Euro for a new ' original battery. Well to be short,
after charging the battery FG ran smootly as never did. I made a series of tests, artifacts and crashes literally disappeared. I could also fly with the charger and battery acting together. I had to fight 2 months with drivers, hardware, operating systems, sensors, graphic cards etc, to discover that the cause of all troubles was the compatible adapter. Now I have an average of 50 fps with a relatively heavy configuration. The only problem left is the high GPU and CPU temperatures. They could reach 80 °C for the GPU, after using FG for more than an hour. It has been noted that this is a particular feature of my PC. For the moment this is not causing troubles. Perhaps my experience could be useful for someone else.

Thank you for your kind help

Posts: 8
Joined: Fri Oct 21, 2016 2:16 pm

Re: graphic card

Postby Alant » Thu Jan 11, 2018 12:02 am

Are you running your laptop in such a position that the air vents are blocked?

I can not run my laptop for long without overheating if it is on a cushion. It is fine on a hard table, or on my knees.

Also check that the fans(s) are running and that the ventilation passages are not full of e.g. (in my case) dog hair.

Overheating can also be caused by overclocking. If you can set the performance to be lower that may help.

Posts: 904
Joined: Wed Jun 23, 2010 5:58 am
Location: Portugal
Callsign: Tarnish99
Version: from Git
OS: Windows 10

Re: graphic card

Postby Clive2670 » Thu Jan 11, 2018 6:22 pm

I have a Toshiba Satelite L50B-21F, with integrated AMD R7-M260 (2Gb) graphics, I have very few problems with mine, As other say check your fan cuts in and all the vents are kept clear, ( I "jack mine up" on a pen at the front as this helps with getting the air through faster, As normally the intake for the fan is on the bottom of the case), Also until very recently I only had 6Gb of RAM, I see you have 8Gb, It might be worth buying extra RAM and upgrading if you can, I maxed mine out with 16Gb and this has taken a great deal of strain off the CPU / GPU, I used to get around 8 to 10 FPS with 6Gb, I can now get around 20FPS stable. My RAM usage by flightgear with 6Gb used to average 70-75% this has now dropped to 25% maximum. I would consider the upgrade if you can afford it and your laptop allows you to upgrade, As you can see by my results. But also bare in mind you have AMD graphics as well, When you update your graphics driver do you CORRECTLY UNINSTALL your old driver before correctly installing the new version? As I found out failure to do this correctly WILL virtually render your AMD card inoperative. Last thing make sure that you set your card to recognise Flightgear when you lauch it and run at "High performance" as it will just run at "Balanced" if you don't. Hope this helps?
Thanks Clive aka: G-BLS01
Can be seen flying the Boeing 777-200LR
Toshiba laptop,
Intel i5 4210U,
16Gb RAM,
AMD R7-M260 graphics 2Gb RAM
User avatar
Posts: 593
Joined: Mon Feb 08, 2016 7:11 pm
Location: Anywhere in the World at some point on Flightgear!
Callsign: G-BLS01
Version: 2018.3.1
OS: Windows 10 64bit

Re: graphic card

Postby ponipei » Sun Jan 14, 2018 10:42 pm

Thank you Clive and Alan for you kind advice. As a matter of fact I am extremely keen on keeping the ventilation gates clear, and now and then I try to get all the dust and other extraneous material out using a vacuum cleaner. As far as the RAM upgrade is concerned, wishful thinking !, my laptop has a max 8 GB of RAM and nothing can be added. Anyway the CPU and GPU temperatures vary according to the flight conditions. In stormy and cloudy weather with 3D clouds the performance drops to a miserable 6 - 10 fps, but temperatures are lower. Looking at the large material present on this subject on the Internet, I have seen that temperatures around 65 - 75 °C are considered "normal".
Thanks again

Posts: 8
Joined: Fri Oct 21, 2016 2:16 pm

Re: graphic card

Postby Alant » Sun Jan 14, 2018 11:55 pm

Are other programs running in the background?. Check with the resource monitor.

Especially check the memory usage. If the memory is full FG will grind to a halt.

Your system appears suitable to me. My laptop is well over 5 years old and has IntelI5, 8GB ram , but has a nvidia graphics card.

Posts: 904
Joined: Wed Jun 23, 2010 5:58 am
Location: Portugal
Callsign: Tarnish99
Version: from Git
OS: Windows 10

Return to Graphics

Who is online

Users browsing this forum: D-ECHO, ludomotico, V12 and 2 guests