Board index FlightGear Support Graphics

Menu text disappearing randomly on Windows 10-64Bit home

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Re: Menu text disappearing randomly on Windows 10-64Bit home

Postby lzu164 » Mon Oct 12, 2020 3:47 pm

I ran into this problem trying out Amd proprietary drivers on Ubuntu and thought to leave this here for future reference. Easiest fix (or rather a detour), as suggested at the first page, is to change the gui style, . Gui style can be changed from debug menu "cycle gui style" (last item on the list). If the flickering is so bad that no items can be seen, this can also be changed via xml (wikipage: http://wiki.flightgear.org/index.php?title=FlightGear_configuration_via_XML&redirect=no). Just change gui style from 1 to 2 on the xml here:
Code: Select all
<gui>
    <current-style type="int">2<current-style>
    <devel-widgets type="bool">false</devel-widgets>
</gui>

There might be an easier way for this (via commandline) but i couldn't find the relevant command, and this was anyway fast to do.
lzu164
 
Posts: 11
Joined: Sat Nov 04, 2017 1:19 pm
Version: 2020.01.01

Re: Menu text disappearing randomly on Windows 10-64Bit home

Postby Hooray » Mon Oct 12, 2020 4:51 pm

You can use the --prop:key=value command line argument to set properties during startup.

PS: This should probably be added to the wiki: http://wiki.flightgear.org/Howto:Create ... _GUI_style
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 12173
Joined: Tue Mar 25, 2008 8:40 am

Re: Menu text disappearing randomly on Windows 10-64Bit home

Postby WoodSTokk » Mon Oct 12, 2020 4:54 pm

The command line option is:
Code: Select all
fgfs.exe --prop:/sim/gui/current-style=0
WoodSTokk
 
Posts: 796
Joined: Tue Oct 17, 2017 2:30 pm
Location: Milky Way/Sol/Earth/Europe
Callsign: OE-WST
IRC name: WoodSTokk
Version: 2020.4.0
OS: Debian Buster

Re: Menu text disappearing randomly on Windows 10-64Bit home

Postby lzu164 » Mon Oct 12, 2020 5:04 pm

Thanks! I knew there was an easier way.
lzu164
 
Posts: 11
Joined: Sat Nov 04, 2017 1:19 pm
Version: 2020.01.01

Previous

Return to Graphics

Who is online

Users browsing this forum: No registered users and 1 guest