Board index FlightGear Support Graphics

2017.1.1 - Bad performances.  Topic is solved

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

2017.1.1 - Bad performances.

Postby Dogers » Sun Feb 26, 2017 10:00 am

Greetings everyone !

I just installed the last stable version of FGFS (compiled 2017.1.1 from scratch), and I got a problem. Indeed, my FPS were not so good as it was in the 2016.4.4. Even with lower settings the improvement in my frame rate was poor. For instance, with the F-15 C, I was at 30-40 FPS at ground in the previous version, and I am about 15 FPS right now ! Since I do not get any FPS drop on any other 3D application or other game, I think there might be an issue with FGFS, at least with my configuration. On some other aircraft (more optimized ones, like DR400, F-14 or C172P), the FPS was better but, lower compared to the 2016.4.4.

Here's some hardware informations :

OS : Ubuntu Studio 16.10.
CPU : AMD FX 6300 Hexa-Core.
GPU : Nvidia GeForce 750 Ti - using the proprietary driver version 367.57.
RAM : 16Go Dual-Chan.
Sound Card : Focusrite Scarlett 2i2 USB.

Here's the launch command-line using the QT5 launcher :

Code: Select all
--callsign=F-DGRS
--multiplay=out,10,mpserver01.flightgear.org,5000
--multiplay=in,10,,5005
--enable-horizon-effect
--enable-enhanced-lighting
--enable-distance-attenuation
--enable-specular-highlight
--fog-fastest
--shading-flat
--enable-ai-models
--httpd=8080
--disable-clouds3d
--ai-scenario=foch_demo
--ai-scenario=nimitz_demo
--ai-scenario=clemenceau_demo


If anyone has any clue about what could be causing these FPS drop, please, fell free to reply.

Do not hesitate to ask me more information.

Thanks !
Scenery contributions :

LFVM - LFVP - FMEE - FMCZ
User avatar
Dogers
 
Posts: 45
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: FreeBSD 12.0

Re: 2017.1.1 - Bad performances.

Postby sanhozay » Sun Feb 26, 2017 10:07 am

You could try copying ~/.fgfs/autosave_2017_1.xml out of the way (e.g. to your Desktop), copying ~/.fgfs/autosave_2016_4.xml to ~/.fgfs/autosave_2017_1.xml and running with that. Doing so would rule out any difference in settings as the cause.

It can also be useful to compare autosave_2016_4.xml to autosave_2017_1.xml. Meld is a good tool for this and available in the Ubuntu repos.

If there's no improvement, the next step would be to try checking out the 2016.4.4 release and compile that in the same way you compiled 2017.1.1.
sanhozay
 
Posts: 1207
Joined: Thu Dec 26, 2013 11:57 am
Location: EGNM
Callsign: G-SHOZ
Version: Git
OS: Ubuntu 16.04

Re: 2017.1.1 - Bad performances.

Postby Dogers » Sun Feb 26, 2017 10:36 am

Well there is a problem with the .xml. Indeed, each time I compile a new version, I remove every file of the previous in order to have a "default" experience and in order to minimize possible compatibility issue with old files. The only thing I keep between versions is the command-line arguments. So I do not have any of the old .xml, my installation is completely fresh.

But for the compilation, I did exactly the same as I do for the 2016.4.4 without adding any library.

An other information I forgot to give is that I do all of my FPS test at the same airport : LFMA RW33, in order to get the same conditions in different configuration (aircraft, graphics settings ...). For instance, here I got 15 FPS with the F-15C (35 - 40 on the 2016.4.4) and ~40 with the DR-400 JSBsim (more than 60 on the 2016.4.4).

Thanks for your reply by the way.
Scenery contributions :

LFVM - LFVP - FMEE - FMCZ
User avatar
Dogers
 
Posts: 45
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: FreeBSD 12.0

Re: 2017.1.1 - Bad performances.

Postby Thorsten » Mon Feb 27, 2017 7:34 am

I've also had the gut feeling that we've lost performance somewhere, although I can't precisely pinpoint it. Once the dust of various changes all at once settles, I ought to be able to investigate a bit more whether it's true and what system drains.
Thorsten
 
Posts: 11580
Joined: Mon Nov 02, 2009 8:33 am

Re: 2017.1.1 - Bad performances.

Postby Dogers » Mon Feb 27, 2017 8:40 am

With further testing, I think that canvas may be a part of the problem. The huge FPS only happen in aircraft using canvas (i think). If I remember correctly the F-15C using it. I also tried the Space Shuttle with the lower graphics settings possible, and I only got 1 FPS !
Scenery contributions :

LFVM - LFVP - FMEE - FMCZ
User avatar
Dogers
 
Posts: 45
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: FreeBSD 12.0

Re: 2017.1.1 - Bad performances.

Postby Richard » Mon Feb 27, 2017 9:13 am

I just did a quick test (with 2017.2) - on the F-15 I deleted the HUD, MPCD, VSD and TEWS folders in the Nasal directory; which removes canvas completely and I get the exact same FPS sitting on the runway at Nellis.
Richard
 
Posts: 765
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: 2017.1.1 - Bad performances.

Postby Dogers » Mon Feb 27, 2017 10:28 am

I did the same test at LFMA RW33. With the default F-15 C I got 19-20 FPS, when I remove the folders concerning canvas, I reach 40-45 FPS. So I think it is really related to canvas but the issue is certainly OS-Dependent.
Scenery contributions :

LFVM - LFVP - FMEE - FMCZ
User avatar
Dogers
 
Posts: 45
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: FreeBSD 12.0

Re: 2017.1.1 - Bad performances.

Postby Thorsten » Mon Feb 27, 2017 10:48 am

At least it'd fit the bill in that there've been changes to canvas during the last development cycle (the Shuttle is somewhat tricky as test case as it requires performance on so many fronts, it's hard to know where the bottleneck is...)
Thorsten
 
Posts: 11580
Joined: Mon Nov 02, 2009 8:33 am

Re: 2017.1.1 - Bad performances.

Postby Thorsten » Tue Feb 28, 2017 11:17 am

@Dogers

For the discussion on the devel list about this, could you please identify your OS and if possible also the compiler version you've been using?
Thorsten
 
Posts: 11580
Joined: Mon Nov 02, 2009 8:33 am

Re: 2017.1.1 - Bad performances.

Postby Dogers » Tue Feb 28, 2017 11:23 am

For sure , here are the OS informations :

Code: Select all
Ubuntu Studio 16.10

4.8.0-39-lowlatency #42-Ubuntu SMP PREEMPT Mon Feb 20 13:42:49 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux


And the gcc -v gives that :

Code: Select all
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/6/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 6.2.0-5ubuntu12' --with-bugurl=file:///usr/share/doc/gcc-6/README.Bugs --enable-languages=c,ada,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-6 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-libmpx --enable-plugin --enable-default-pie --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-6-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-6-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-6-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 6.2.0 20161005 (Ubuntu 6.2.0-5ubuntu12)


I hope it will help.
Scenery contributions :

LFVM - LFVP - FMEE - FMCZ
User avatar
Dogers
 
Posts: 45
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: FreeBSD 12.0

Re: 2017.1.1 - Bad performances.

Postby Thorsten » Tue Feb 28, 2017 3:44 pm

@Dogers: Since you compile yourself, you should not have trouble looking at this:

Erik has kindly added a patch to temporarily disable recent changes to canvas rendering

https://sourceforge.net/p/flightgear/si ... next/tree/

Quoting him from the mailing list:

I've pushed a patch which temporarily disables SIMD for Canvas in next.
Let me know if you see any difference.


Please pull simgear/flightgear next and see whether your framerate for the F-15 comes back up!
Thorsten
 
Posts: 11580
Joined: Mon Nov 02, 2009 8:33 am

Re: 2017.1.1 - Bad performances.

Postby Dogers » Tue Feb 28, 2017 4:45 pm

I just downloaded and compiled the git version of flightgear and simgear and also the last dev version of the F-15C. And apart from the new loading screen, nothing has changed. My FPS are as bad as the 2017.1.1 version ... So I do not think it is related to the SIMD changes, but it was worth a try.
Scenery contributions :

LFVM - LFVP - FMEE - FMCZ
User avatar
Dogers
 
Posts: 45
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: FreeBSD 12.0

Re: 2017.1.1 - Bad performances.  

Postby Dogers » Fri Jun 02, 2017 3:17 pm

Okay everyone !

After many (many) tests & installation of other GNU/Linux, I finally manage to found the problem ! I even buy a new Graphic Card to try if it was not the old one that was creating all those issues. Well all my FPS drop were caused by the openscenegraph library ! But more precisely, the problem was not directly caused by Flightgear ! Indeed, I found that another game use the openscenegraph library. In fact, I installed OpenMorrowind from a PPA, and this game was using an other version of openscenegraph. This version was apparently not optimized for Flightgear. I discover the library conflict and the compilation process of the Debian building script, which mentioned that the openscenegraph library was not the good one. I did not get any error of that kind when I compiled FGFS manually from sources ! So I just removed OpenMW and all its library and that's all !

Finally I am able to fly comfortably again with high frame-rate !

Thank for everyone who tried to help me !
Scenery contributions :

LFVM - LFVP - FMEE - FMCZ
User avatar
Dogers
 
Posts: 45
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: FreeBSD 12.0

Re: 2017.1.1 - Bad performances.

Postby Thorsten » Fri Jun 02, 2017 5:12 pm

Wow... that's... tricky to find.
Thorsten
 
Posts: 11580
Joined: Mon Nov 02, 2009 8:33 am


Return to Graphics

Who is online

Users browsing this forum: No registered users and 1 guest