Board index FlightGear Support Graphics

AMD Radeon R9 – Massive text flickering again

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Re: AMD Radeon R9 – Massive text flickering again

Postby bugman » Thu Dec 17, 2015 3:05 pm

dutchman wrote in Thu Dec 17, 2015 1:33 pm:It will eventually be solved with a future update.


True, but this needs to be taken with a grain of salt ;) AMD are notorious for terrible software drivers (all OSes, and open source vs. proprietary). Their driver releases swing wildly in quality. As the current Crimson release is a new design, by this very nature it will be less stable and more buggy than the older Catalyst drivers. Future updates (15.11.1 included) should improve things. But at some point, they may release a driver which is a step backwards (history has a tendency to repeat itself, and AMD are determined to push this philosophy to the absolute limits).

Regards,
Edward
bugman
Moderator
 
Posts: 1683
Joined: Thu Mar 19, 2015 9:01 am
Version: next

Re: AMD Radeon R9 – Massive text flickering again

Postby Babbo » Thu Dec 17, 2015 5:33 pm

So you made me really curious ... but, as it turns out right now, Beta-Crimson 15.11.1 does not solve the issue.
Babbo
 
Posts: 12
Joined: Sun Dec 13, 2015 9:30 am

Re: AMD Radeon R9 – Massive text flickering again

Postby Hooray » Thu Dec 17, 2015 5:36 pm

what about the minimal startup profile ?

http://wiki.flightgear.org/Template:Startup_Profile

(if you can build from source, there is a patch that disables PUI entirely)
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11326
Joined: Tue Mar 25, 2008 8:40 am

Re: AMD Radeon R9 – Massive text flickering again

Postby bugman » Thu Dec 17, 2015 5:46 pm

Babbo wrote in Thu Dec 17, 2015 5:33 pm:So you made me really curious ... but, as it turns out right now, Beta-Crimson 15.11.1 does not solve the issue.


Pity! They mentioned so many 'flickering' bug fixes that there was a chance they'd fix it. Anyway, there is one benefit and that is the new afterburner effect used by some aircraft, which was broken in some earlier AMD drivers, should now be fixed. Hopefully the next AMD driver release will iron out the remaining bugs and the flickering will go away. It's a bit difficult for 3D applications to work around graphics driver bugs, especially AMD's ones that are constantly changing.

Regards,
Edward
bugman
Moderator
 
Posts: 1683
Joined: Thu Mar 19, 2015 9:01 am
Version: next

Re: AMD Radeon R9 – Massive text flickering again

Postby Babbo » Thu Dec 17, 2015 9:15 pm

Hooray wrote in Thu Dec 17, 2015 5:36 pm:what about the minimal startup profile ?

http://wiki.flightgear.org/Template:Startup_Profile


Hello again, Hooray: I tried that profile. I produced a system.fgfsrc (with the content from your wiki-link), positioned it in ...\data and directly (not via fgrun) called fgfs.exe from ...\bin - and that one worked ..., technically.

However, the flickering produced cannot be overlooked. Actually, it is more than the usual one (my current fgrun-setting), it is really the heaviest observed so far.
Babbo
 
Posts: 12
Joined: Sun Dec 13, 2015 9:30 am

Re: AMD Radeon R9 – Massive text flickering again

Postby Hooray » Thu Dec 17, 2015 9:37 pm

Actually, on most systems, the fgfsrc file would not go into ../$FG_ROOT normally: http://wiki.flightgear.org/Fgfsrc
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11326
Joined: Tue Mar 25, 2008 8:40 am

Re: AMD Radeon R9 – Massive text flickering again

Postby Richard » Thu Dec 17, 2015 10:02 pm

I've been doing some more research and I now suspect the inbuilt texture mapped fonts are the ones that are affected.

If I run with the standard renderer there is not much flicker; there might even be no flicker. It is most flickery with ALS; and more often invisible with Rembrandt. It looks like the text isn't being drawn properly every frame, so it could be timing related. I'm currently trying to figure out how the texture mapped fonts work, although AMD drivers are not the best - this has the feeling of something that isn't doing the right thing but it just happens to work with non-AMD cards.
Richard
 
Posts: 700
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: AMD Radeon R9 – Massive text flickering again

Postby Hooray » Thu Dec 17, 2015 10:12 pm

Are you referring to the PUI/TXF stuff or something else ?
To see if disabling PUI entirely helps, you can use the draw mask patches I posted previously - and then control FlightGear using either Phi and/or a simple Canvas-based fallback (or even just telnet).
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11326
Joined: Tue Mar 25, 2008 8:40 am

Re: AMD Radeon R9 – Massive text flickering again

Postby Babbo » Thu Dec 17, 2015 10:40 pm

Hooray wrote in Thu Dec 17, 2015 9:37 pm:Actually, on most systems, the fgfsrc file would not go into ../$FG_ROOT normally: http://wiki.flightgear.org/Fgfsrc

... I know, what you mean ... and I can present a more or less misterious story now. I moved my newly produced fgfsrc from ...\data (which to my knowledge is FG_ROOT) to ...\AppData\Roaming\flightgear.org\, exactly like the wiki suggests. Again, starting via fgfs.exe, I got confronted with the following facts:

    • The program came up in windowed-mode (probably 800x600)
    • The aircraft was not the ufo, but the Cessna
    • Flying the Straight-in Landing, there were some light texture areas, i.e. problems, at the coast in front of the KHAF-runway and ...
    • ... guess what, the FLICKERING was GONE!
Additionally: The ufo was not initialized even if a "--aircraft=ufo"-line declared it explicitly. Also, "--enable-fullscreen" and "--geometry=1920x1200" had no effect.

Isn't that strange!?

@Richard; You're right, fonts are triggering the problem, but I think, they are not the original cause.

Getting tired ... sleep well ...
Babbo
 
Posts: 12
Joined: Sun Dec 13, 2015 9:30 am

Re: AMD Radeon R9 – Massive text flickering again

Postby Richard » Thu Dec 17, 2015 11:23 pm

Hooray wrote in Thu Dec 17, 2015 10:12 pm:Are you referring to the PUI/TXF stuff or something else ?
To see if disabling PUI entirely helps, you can use the draw mask patches I posted previously - and then control FlightGear using either Phi and/or a simple Canvas-based fallback (or even just telnet).


The flickering only affects PUI items (menus, dialog, popup text (chat)). I can turn everything off in draw-masks and the PUI text still flickers. The flicker is manifested as the entire text not being visible; it looks like single calls with a string work or don't, it's not the case that parts of words or letters are drawn or not.

Canvas, model text, OSG Debug are fine,

The flickering isn't constant; it does depend on the view angle (or what's in the view, hard to tell). The amount of flickering and how it flickers seems to differ between Rembrandt and ALS, but both flicker; however the standard render is pretty much flicker free.

The txf fonts that are loaded (i.e. not pre-loaded from a static array) are fine; I use the alternative (0) the fonts in this are fine, but the helvetica used in the mp pilot list still flicker.

If I run with the minimal profile (from the command line) I still get flickering, it's slightly less noticeable but still there.
Richard
 
Posts: 700
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: AMD Radeon R9 – Massive text flickering again

Postby Hooray » Fri Dec 18, 2015 5:46 am

Richard wrote in Thu Dec 17, 2015 11:23 pm:The flickering isn't constant; it does depend on the view angle (or what's in the view, hard to tell). The amount of flickering and how it flickers seems to differ between Rembrandt and ALS, but both flicker; however the standard render is pretty much flicker free.

The txf fonts that are loaded (i.e. not pre-loaded from a static array) are fine; I use the alternative (0) the fonts in this are fine, but the helvetica used in the mp pilot list still flicker.

If I run with the minimal profile (from the command line) I still get flickering, it's slightly less noticeable but still there.


So, "minimal startup profile" + standard renderer (no ALS/Rembrandt, all shaders/effects disabled) = no flickering at all when using the legacy PUI style ?
If so, we can check the git logs (or do a bisect) to see if the commits related to supporting PUI styling, look suspicious.

So far, our assumptions has been that it is not specific to PUI, but related to OSG not being aware of how PUI is integrated - together with certain effects/shaders.

If I had access to AMD/ATI hardware, I'd try older releases next, and specifically look for PUI styling related commits, to see if those touched anything else.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11326
Joined: Tue Mar 25, 2008 8:40 am

Re: AMD Radeon R9 – Massive text flickering again

Postby Babbo » Fri Dec 18, 2015 8:00 am

Hooray wrote in Thu Dec 17, 2015 10:12 pm:Are you referring to the PUI/TXF stuff or something else ?

Excuses for not having been that specific. So allow do redefine my "massive text flickering": I mean the text of the main menu-bar at the left top of the screen, including its menus and sub-windows accessable from it (e.g. the map-window). And, again, what flickers is text exlusively (in the main-bar, in menus, near tickboxes of such sub-windows, ...). Probably, to my humble understanding, that's what you experts call "PUI". Regarding fonts, I'd like to remember that obviously only default-fonts are targeted, any - not so beautiful - txf (installed by changing a style-file, see above) runs perfectly fine.

Hooray wrote in Fri Dec 18, 2015 5:46 am:
Richard wrote in Thu Dec 17, 2015 11:23 pm:So, "minimal startup profile" + standard renderer (no ALS/Rembrandt, all shaders/effects disabled) = no flickering at all when using the legacy PUI style ?

Absolutely, this is what I found from my last night's experiments.
Babbo
 
Posts: 12
Joined: Sun Dec 13, 2015 9:30 am

Re: AMD Radeon R9 – Massive text flickering again

Postby Solid » Fri Dec 18, 2015 11:00 am

Hi Everybody,

in March I posted a report about the same problen under viewtopic.php?f=37&t=25595#p234492 .

I observed the problem continously with no real effective solution except switching off ALS. The strenghth of flickering/disappearing of text changes depending on weather/lighting and aircraft model. But the problem still remains as long as ALS is switched on.
The change of the font as published by Saga and copied into my post stopped the text flickering and disappearing but resulted in other problems like cutted text in the METAR info of the airport selection window.
The change from basic weather to detailed weather initially looked promising but was not allways working.

Even the change of the operating system from Windows 8.1 to Windows 10 didn´t show any impact on the problem. I don´t know if the problem occurs on Linux operating systems using ATI cards.

I wrote a problem report to AMD Customer care on the october. 25 but did not get any response exempt receipt compliance.

Maybe someone is able to identify the main difference between the classic font and the anthrax font. Or maybe the integration of some more font-styles may lead to a usable font for players with ATI cards.

I´m not a programmer, my possibilities are too restricted to do programming work. But if someone is willing to work on the problem I would volunteer for testing possible solutions if i get a deailed instruction what to do.

Greetings,


Achim
Solid
 
Posts: 39
Joined: Tue Nov 25, 2014 8:25 pm
Location: Niedersachsen, Germany
Callsign: Solid
Version: 2018.2.2
OS: Win 10

Re: AMD Radeon R9 – Massive text flickering again

Postby Babbo » Fri Dec 18, 2015 12:00 pm

Hello, Achim! Please allow some comments. Yes, I know your thread and it was one of the sources, which led me to the idea to play with anthrax and/or classic (which, btw., are no fonts, but xml-style files, which call fonts). So my short-term workaround currently is to use an anthrax-version that calls txf-fonts (some of them come with FG, here and there, they can be found in the net; alternatively, one could produce txf's from ttf's, but that's not so easy). The only - visible - problem is, txf's cannot keep up with ttf's,

I made the same observations like you, except that also a disabled ALS doesn't really contribute: text is flickering frequently and continuously, while with activated ALS text usually completely disappears.

Some minimal configuration efforts were successful (you may check them above) ..., but for the moment, from my point of view, there is nothing else but to wish you a nice day ...!
Babbo
 
Posts: 12
Joined: Sun Dec 13, 2015 9:30 am

Re: AMD Radeon R9 – Massive text flickering again

Postby TheTom » Fri Dec 18, 2015 12:13 pm

Solid wrote in Fri Dec 18, 2015 11:00 am:I don´t know if the problem occurs on Linux operating systems using ATI cards.

I'm using Ubuntu with a Radeon HD 7870 and have the same problems. Sometimes everything renders just fine, but sometimes it is flickering (not only the text but sometimes also the whole window) so much that it is just unusable. The problems are probably not specific to FlightGear because it also happens with other OpenGL based applications like Spotify, Chrome or Blender.
TheTom
 
Posts: 321
Joined: Sun Oct 09, 2011 10:20 am

PreviousNext

Return to Graphics

Who is online

Users browsing this forum: No registered users and 1 guest