Board index FlightGear Support Graphics

Strange conical "circus tent" artifacts..

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Re: Strange conical "circus tent" artifacts..

Postby clrCoda » Sun Jul 12, 2015 4:20 pm

Someone mentioned earlier that there was no Models folder in the data/Scenery folder and that's because the Models folder is at data/Models at the same level as data/Scenery.

Much time was spent over the last couple hours with a monitor that I made the mistake of shutting off last night and today it would not turn back on. Oh well. Guess I'll hit a pawn shop or 3.

I tried to reproduce the issue. I was not successfull. I had realized that in my previous post above I had not remembered that I was using a different default scenery, the one for Scenery-v2.12 and not the 2.0 scenery that comes with the current FGdata download.

I re-pointed my scenery path to include the default KSFO. I turned on Rembrandt. I had done like Edward had said and renamed my FG_HOME directory and let FlightGear build a new one.

I verified that I had the latest FGdata available and with the exception of a couple things about copy-write and the latest update to the C172P, I had hacked in the change to the preferences.xml shown at the repo by hand. This means that I have the most up to date data/Scenery folder currently going. I allowed the nav-cache to build with this Scenery folder.

Making adjustments to rendering and Rembrandt I was not able to reproduce the "tents" as shown above.

It may be that the difference is the C172P which I have from the previous update to the default aircraft. Other than that I wish I could be more helpful with this. I suppose I could get all of the newest FGdata and another nightly build and try again. Maybe that will help one way or the other.

--Ray
Ray St. Marie
clrCoda
 
Posts: 1228
Joined: Wed Apr 07, 2010 11:04 am

Re: Strange conical "circus tent" artifacts..

Postby Johan G » Sun Jul 12, 2015 4:34 pm

bugman wrote in Sun Jul 12, 2015 3:35 pm:I can confirm that the following single command fixes this bug: ...

If so, make sure to submit a good bug report and/or drop a message on the mailing list. This should not slip into 3.6. :wink:
Low-level flying — It's all fun and games till someone looses an engine. (Paraphrased from a YouTube video)
Improving the Dassault Mirage F1 (Wiki, Forum, GitLab. Work in slow progress)
Johan G
Moderator
 
Posts: 5492
Joined: Fri Aug 06, 2010 5:33 pm
Location: Sweden
Callsign: SE-JG
IRC name: Johan_G
Version: 3.0.0
OS: Windows 7, 32 bit

Re: Strange conical "circus tent" artifacts..

Postby caliberza » Sun Jul 12, 2015 5:20 pm

bugman wrote in Sun Jul 12, 2015 4:05 pm:Hi caliberza,

Do you have a SourceForge login? If so, would you like to create a detailed bug report for the record and then make a merge request? A merge request would require you to fork FGData, create a new branch for the bug fix, copy the TerraSync file to Models/Airport/apt-light-ba.ac and make a commit (with a link in the commit message pointing to this forum thread as well as the bug report), and then click on the 'Request Merge' button in the SourceForge web interface to ask for it to be merged. It should then be fixed in time for FG v3.6. If this is too much of an adventure for you, there are plenty of others here who can do this for you (the bug report should be easy enough though).

Eh, I can give it a try, sounds easy enough. :p

clrCoda wrote in Sun Jul 12, 2015 4:20 pm:Someone mentioned earlier that there was no Models folder in the data/Scenery folder and that's because the Models folder is at data/Models at the same level as data/Scenery.

Yea, that was me. :oops: I realised a while afterwards where the Models directory was located. Nonetheless, copying the models dir from terrasync into the data/Scenery folder seems to take precedence over data/Models which I guess is why that worked for me anyway.
caliberza
 
Posts: 15
Joined: Sat Jul 11, 2015 2:20 pm
Location: South Africa
Callsign: caliber
Version: Git
OS: Linux, Ubuntu 14.04

Re: Strange conical "circus tent" artifacts..

Postby bugman » Sun Jul 12, 2015 6:31 pm

clrCoda wrote in Sun Jul 12, 2015 4:20 pm:Making adjustments to rendering and Rembrandt I was not able to reproduce the "tents" as shown above.


I'm not sure what the issue is. Maybe your FG binary is somehow finding a TerraSync directory or the v2.12 scenery files. Let's see what is in your NavDataCache. If you install sqlite3 (easy in Linux), you can then question your NavDataCache for the scenery paths directly with:

Code: Select all
$ sqlite3 ~/.fgfs/navdata_3_5.cache
SQLite version 3.8.10.2 2015-05-20 18:17:19
Enter ".help" for usage hints.
sqlite> select value from properties where key="scenery_paths";
/flightgear/flightgear-fgdata/Scenery;/flightgear/flightgear-fgdata/Scenery/Terrain;/flightgear/flightgear-fgdata/Scenery/Objects;;/home/edward/.fgfs/TerraSync;
sqlite> .quit
$


You should only see these 4.

Johan G wrote in Sun Jul 12, 2015 4:34 pm:
bugman wrote in Sun Jul 12, 2015 3:35 pm:I can confirm that the following single command fixes this bug: ...

If so, make sure to submit a good bug report and/or drop a message on the mailing list. This should not slip into 3.6. :wink:


I'll let caliberza give it a go first. It will be a great learning experience to be able to do some awesome stuff in the future. And then he'll have his name permanently recorded in the FlightGear repositories.

caliberza wrote in Sun Jul 12, 2015 5:20 pm:
bugman wrote in Sun Jul 12, 2015 4:05 pm:Hi caliberza,

Do you have a SourceForge login? If so, would you like to create a detailed bug report for the record and then make a merge request? A merge request would require you to fork FGData, create a new branch for the bug fix, copy the TerraSync file to Models/Airport/apt-light-ba.ac and make a commit (with a link in the commit message pointing to this forum thread as well as the bug report), and then click on the 'Request Merge' button in the SourceForge web interface to ask for it to be merged. It should then be fixed in time for FG v3.6. If this is too much of an adventure for you, there are plenty of others here who can do this for you (the bug report should be easy enough though).

Eh, I can give it a try, sounds easy enough. :p


It's more long winded than difficult. By the way, this exact same problem has been just reported on the FlightGear development mailing list in the thread:


Regards,

Edward
bugman
Moderator
 
Posts: 1686
Joined: Thu Mar 19, 2015 9:01 am
Version: next

Re: Strange conical "circus tent" artifacts..

Postby bugman » Sun Jul 12, 2015 6:42 pm

Hi,

To be sure that the light cones work correctly, I checked these at night time. FGData + fix shows the same lighting behaviour as the TerraSync data files. So updating the *.ac AC3D file should hopefully have no adverse effects.

Regards,

Edward
bugman
Moderator
 
Posts: 1686
Joined: Thu Mar 19, 2015 9:01 am
Version: next

Re: Strange conical "circus tent" artifacts..

Postby Philosopher » Sun Jul 12, 2015 8:59 pm

Torsten seems to have committed a fix to FGData. (Thanks for the commit log emails Edward! :D)
Thanks,
Philosopher
(inactive but lurking occasionally...)
Philosopher
 
Posts: 1590
Joined: Sun Aug 12, 2012 6:29 pm
Location: Stuck in my head...
Callsign: AFTI
Version: Git
OS: Mac OS X 10.7.5

Re: Strange conical "circus tent" artifacts..

Postby Hooray » Tue Jul 14, 2015 3:30 pm

Oh, Hooray will chide me again for attributing all problems to rendering... but I risk venturing this guess anyway

Actually, I sorta agree that this seems very much rendering related - and I even posted comments along those lines when I suggested to look at the camera configuration, too - because rendering multiple cameras to the main window looks very similar to the screen shots the OP posted. Then again, I am pretty sure that there are other potential factors involved here. So I stayed out of this for a reason...
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11326
Joined: Tue Mar 25, 2008 8:40 am

Re: Strange conical "circus tent" artifacts..

Postby MIG29pilot » Tue Jul 14, 2015 3:55 pm

That scenery must have been the one for the circus coming to KSFO!
User avatar
MIG29pilot
 
Posts: 1454
Joined: Tue May 19, 2015 4:03 pm
Location: 6 feet under Snow
Callsign: MIG29pilot
Version: 3.7nightly
OS: Windows 10

Re: Strange conical "circus tent" artifacts..

Postby EnricoC » Fri Aug 14, 2015 10:06 am

I have the same problem...FG 3.5.0 on windows 7 64bit

Image

Can I Solve this?????
thanks
BR
EnricoC
Callsign : Spectre
www.enricocastaldi.simplesite.com

"A superior pilot uses his superior judgment to avoid situations which require the use of his superior skill".
Frank Frederick Borman II
Commander of Apollo 8 .
EnricoC
 
Posts: 31
Joined: Mon Apr 13, 2015 7:30 am
Location: Pescara (LIBP)
Callsign: Spectre
Version: 2018.2.2
OS: Windows 10

Re: Strange conical "circus tent" artifacts..

Postby bugman » Fri Aug 14, 2015 10:24 am

Hi,

As I mentioned in the cross-post, this problem has been solved in FGData about a month ago. Updating from the development version 3.5 to the current 3.7 will fix this.

Regards,

Edward
bugman
Moderator
 
Posts: 1686
Joined: Thu Mar 19, 2015 9:01 am
Version: next

Previous

Return to Graphics

Who is online

Users browsing this forum: No registered users and 1 guest