Board index FlightGear Support Graphics

Strange conical "circus tent" artifacts..

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Strange conical "circus tent" artifacts..

Postby caliberza » Sat Jul 11, 2015 2:33 pm

Heya,

I've compiled FG from github and I'm noticing some strange conical artifacts like huge "circus tents", basically just around KSFO, haven't seen them anywhere else.
Attached screenshot demonstrates this:
Image

I'm using Ubuntu 14.04, I have an Nvidia Gtx550ti.
I realise of course that github is development version so some issues are to be expected, I'm just not sure if this is one of them or if it's something with my setup..

Any ideas appreciated. :)

FGFS command line:
Code: Select all
/usr/local/bin/fgfs
  --fg-root=/home/daniel/Shared/Linux/Games/FlightGear/flightgear-fgdata
  --fg-scenery=/home/daniel/Shared/Linux/Games/FlightGear/flightgear-fgdata/Scenery:/home/alt/Flightgear
  --fg-aircraft=/home/daniel/Shared/Linux/Games/FlightGear/flightgear-fgaddon/Aircraft
  --airport=KSFO
  --aircraft=a26
  --enable-random-objects
  --enable-auto-coordination
  --enable-horizon-effect
  --enable-enhanced-lighting
  --failure=pitot
  --failure=static
  --failure=electrical
  --failure=vacuum
  --enable-ai-models
  --enable-ai-traffic
  --enable-real-weather-fetch
  --enable-clouds3d
  --enable-fullscreen
  --prop:/sim/frame-rate-throttle-hz=60
  --geometry=1920x1200
  --bpp=32
  --texture-filtering=8
  --enable-rembrandt
  --disable-terrasync
  --callsign=caliber
  --multiplay=out,10,,0
  --multiplay=in,10,,0
  --disable-fgcom
  --ai-scenario=KSFO_AirTrain
  --ai-scenario=nimitz_demo
  --ai-scenario=railway_demo
  --ai-scenario=wingman_demo
  --generic=socket,out,5,192.168.0.3,5501,udp,andatlas
  --telnet=socket,in,20,,9000,tcp
caliberza
 
Posts: 15
Joined: Sat Jul 11, 2015 2:20 pm
Location: South Africa
Callsign: caliber
Version: Git
OS: Linux, Ubuntu 14.04

Re: Strange conical "circus tent" artifacts..

Postby Martien van der P. » Sat Jul 11, 2015 3:38 pm

Looks like a rembrandt problem around the lamppost's at KSFO. Probably it will disappear when you disable rembrandt. But further I don't know how to solve it :oops:
User avatar
Martien van der P.
 
Posts: 323
Joined: Fri Dec 14, 2012 4:09 pm
Location: The Netherlands
Callsign: MV-DP
Version: 2018.3.2
OS: Windows 7

Re: Strange conical "circus tent" artifacts..

Postby caliberza » Sat Jul 11, 2015 4:01 pm

I tried disabling rembrandt now, it made no difference. ;/
I also tried switching pretty much every other graphics option on/off and none of them seem to fix it.
caliberza
 
Posts: 15
Joined: Sat Jul 11, 2015 2:20 pm
Location: South Africa
Callsign: caliber
Version: Git
OS: Linux, Ubuntu 14.04

Re: Strange conical "circus tent" artifacts..

Postby someguy » Sat Jul 11, 2015 4:35 pm

Set the Model shader to zero, all the way left.
User avatar
someguy
 
Posts: 1653
Joined: Tue Nov 25, 2008 5:54 am
Location: USA
Version: 2016.2.1
OS: Mac OS X 10.11

Re: Strange conical "circus tent" artifacts..

Postby caliberza » Sat Jul 11, 2015 5:01 pm

someguy wrote in Sat Jul 11, 2015 4:35 pm:Set the Model shader to zero, all the way left.

Thanks, but this doesn't appear to fix it either.
caliberza
 
Posts: 15
Joined: Sat Jul 11, 2015 2:20 pm
Location: South Africa
Callsign: caliber
Version: Git
OS: Linux, Ubuntu 14.04

Re: Strange conical "circus tent" artifacts..

Postby legoboyvdlp » Sat Jul 11, 2015 5:03 pm

Recompile in case yours is corrupted?
User avatar
legoboyvdlp
 
Posts: 6938
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Strange conical "circus tent" artifacts..

Postby caliberza » Sat Jul 11, 2015 5:54 pm

legoboyvdlp wrote in Sat Jul 11, 2015 5:03 pm:Recompile in case yours is corrupted?

Tried, no luck. :/

I should perhaps mention that on closer inspection this problem is not purely visual, what I mean is that if I fly into the conical shapes they are solid (i.e., I crash :lol: ) I can also taxi over them like going over a hill..
caliberza
 
Posts: 15
Joined: Sat Jul 11, 2015 2:20 pm
Location: South Africa
Callsign: caliber
Version: Git
OS: Linux, Ubuntu 14.04

Re: Strange conical "circus tent" artifacts..

Postby caliberza » Sat Jul 11, 2015 6:52 pm

I'm pleased to say that I've gotten it working.. it would appear that there is something amiss with the default scenery files in the github. I suddenly had the notion to enable terrasync, and whatever it downloaded around KSFO has solved the problem. :D
caliberza
 
Posts: 15
Joined: Sat Jul 11, 2015 2:20 pm
Location: South Africa
Callsign: caliber
Version: Git
OS: Linux, Ubuntu 14.04

Re: Strange conical "circus tent" artifacts..

Postby Martien van der P. » Sat Jul 11, 2015 6:56 pm

Good to hear :)
User avatar
Martien van der P.
 
Posts: 323
Joined: Fri Dec 14, 2012 4:09 pm
Location: The Netherlands
Callsign: MV-DP
Version: 2018.3.2
OS: Windows 7

Re: Strange conical "circus tent" artifacts..

Postby caliberza » Sat Jul 11, 2015 7:07 pm

Thanks a lot for all the suggestions. :)
caliberza
 
Posts: 15
Joined: Sat Jul 11, 2015 2:20 pm
Location: South Africa
Callsign: caliber
Version: Git
OS: Linux, Ubuntu 14.04

Re: Strange conical "circus tent" artifacts..

Postby Gijs » Sat Jul 11, 2015 9:10 pm

FlightGear isn't hosted on Github. Our official repositories are on Sourceforge. Maybe you've used some corrupted repository clone? See http://sourceforge.net/projects/flightgear/ for the correct repositories.
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9363
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: Strange conical "circus tent" artifacts..

Postby caliberza » Sat Jul 11, 2015 9:31 pm

My bad.. I did indeed pull it from Sourceforge, I guess I'm just so used to git using projects being hosted on github that I kinda forgot where I pulled it from.. :oops:
caliberza
 
Posts: 15
Joined: Sat Jul 11, 2015 2:20 pm
Location: South Africa
Callsign: caliber
Version: Git
OS: Linux, Ubuntu 14.04

Re: Strange conical "circus tent" artifacts..

Postby bugman » Sat Jul 11, 2015 10:49 pm

Hi,

I've seen the same thing today after deleting the ~/.fgfs cofiguration directory and then running FG with TerraSync disabled on the command line. Some objects were reported missing from FGData in the logs - this information is key (if you can copy and paste it, that'd be extremely useful). I might look into it later.

Regards,

Edward
bugman
Moderator
 
Posts: 1685
Joined: Thu Mar 19, 2015 9:01 am
Version: next

Re: Strange conical "circus tent" artifacts..

Postby wkitty42 » Sun Jul 12, 2015 3:43 am

@bugman: this really should be looked into ASAP as not everyone is going to or be able to run terrasync... not as long as the data packages are as huge as some of them are when considering the time it takes to download them and the time it takes a craft to cross the boarder from real terrain to langolier territory...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5574
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Strange conical "circus tent" artifacts..

Postby bugman » Sun Jul 12, 2015 9:05 am

This is a piece of cake to reproduce!

Code: Select all
$ rm -rf ~/.fgfs
$ fgfs --disable-terrasync


It doesn't matter if the FG_SCENERY environmental variable is set. I see the circus tents as KSFO. The console messages are:

Code: Select all
ERROR: The path '/home/edward/.fgfs' does not exist in the file system.
Enabling ATI viewport hack
default catalog not found, installing 'org.flightgear.default' from 'http://fgfs.goneabitbursar.com/pkg/3.5.0/default-catalog.xml'.                                                                               
Failed to tie property fcs/ to object methods                                                                                                                                                                     
                                                                                                                                                                                                                   
In file /flightgear/flightgear-fgdata/Aircraft/c172p/Systems/c172p-hydrodynamics.xml: line 25                                                                                                                     
      Property floats-enabled-norm is already defined.                                                                                                                                                             
KMA20 audio panel initialized                                                                                                                                                                                     
Hobbs system stopped                                                                                                                                                                                               
Hobbs system stopped                                                                                                                                                                                               
Starter off                                                                                                                                                                                                       
KI266 dme indicator #0 initialized                                                                                                                                                                                 
catalog download failure:http://fgfs.goneabitbursar.com/pkg/3.5.0/default-catalog.xml                                                                                                                             
Primer reset to 0                                                                                                                                                                                                 
osgDB ac3d reader: could not find texture "EDXW_lamp_10m_01.png"                                                                                                                                                   


osgDB ac3d reader: could not find texture "large_tree_erected.png"

Electrical system initialized

Could not find at least one of the following objects for animation: 'terminal_2'
Could not find at least one of the following objects for animation: 'terminal_2'
osgDB ac3d reader: could not find texture "steam.png"


Regards,

Edward
bugman
Moderator
 
Posts: 1685
Joined: Thu Mar 19, 2015 9:01 am
Version: next

Next

Return to Graphics

Who is online

Users browsing this forum: No registered users and 2 guests