Board index FlightGear Support Graphics

livery disappears

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

livery disappears

Postby jpolache » Fri Oct 03, 2014 7:41 pm

Did a fresh install. FG opens in cockpit view. I press "v" to get a outside view. Aircraft show up, but after a second or two the livery disappears leaving a black aircraft. Using the livery select menu has no result.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
Windows 7 Prof

- what FlightGear version do you use?
3.0.0
gl-vendor:Intel
gl-version:2.0.0 - Build 8.15.10.1867
gl-renderer:Intel 965/963 Graphics Media Accelerator
gl-shading-language-version:1.10 - Intel Build 8.15.10.1867


- what graphics card do you have?
Mobile Intel(R) 965 Express Chipset Family in a Lenovo T61 laptop

- does the problem occur with any aircraft, at any airport?
yes

- is there any output printed to the console (black window)?
Enabling ATI viewport hack
ALC Error (sound manager): Invalid Enum at context creation.
environment init
KMA20 audio panel initialized
KI266 dme indicator #0 initialized
Electrical system initialized
KAP140 power up

- copy&paste your commandline
C:\Program Files\FlightGear\bin\Win32\fgfs.exe
--fg-root=C:\Program Files\FlightGear\data
--fg-scenery=C:\Program Files\FlightGear\data\Scenery;C:\Program Files\FlightGear\scenery;C:\Program Files\FlightGear\terrasync
--airport=KHAF
--aircraft=c172p
--control=joystick
--console
--disable-random-objects
--prop:/sim/rendering/random-vegetation=false
--enable-auto-coordination
--enable-horizon-effect
--disable-ai-models
--disable-ai-traffic
--disable-real-weather-fetch
--prop:/sim/menubar/autovisibility/enabled=1
--fog-fastest
--geometry=1024x768
--bpp=32
--timeofday=noon
--disable-terrasync
--disable-fgcom
--generic=socket,out,5,192.168.1.104,5501,udp,andatlas
--telnet=socket,in,5,,9000,tcp
jpolache
 
Posts: 2
Joined: Fri Oct 03, 2014 7:09 pm

Re: livery disappears

Postby Gijs » Sun Oct 05, 2014 9:54 am

Welcome!

Thanks for posting many of the details required for troubleshooting! Something that'd also be interesting to check is the shaders setting in the View > Rendering Options dialog. What if you slide the slider all the way to the left? Also, just to make sure we have the same definition of "black aircraft", could you please post a screenshot? See this topic for instructions.

Cheers,
Gijs
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9365
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: livery disappears

Postby jpolache » Sun Oct 05, 2014 9:29 pm

Thanks Gijs, the slider did indeed fix the problem. Now I can clearly see the rudder moving and can understand the rudder control. On to the perfect 3-point landing?

Regards,

Jpolache

BTW, any suggestions on the optimal (power vs price) computer to run FG on? Any experience with 64 bit Linux? I get the feeling video drivers can be an issue.
jpolache
 
Posts: 2
Joined: Fri Oct 03, 2014 7:09 pm


Return to Graphics

Who is online

Users browsing this forum: No registered users and 7 guests