Board index FlightGear Support Graphics

Liveries not looking right  Topic is solved

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Liveries not looking right

Postby szeged » Sat Nov 17, 2012 4:23 am

Hello, new here, sorry if this has been covered but obviously couldnt find an answer:
My liveries are not loading (black aircraft) or weirdly half loading (you can see the livery only when you really zoom in). Is this a solved problem?

I'm running FG 2.4.0 on Ubuntu 12.04. Planes downloaded from the 2.4.0 group of planes on FG.

Any tips greatly appreciated!
szeged
 
Posts: 2
Joined: Sat Nov 17, 2012 4:19 am

Re: Liveries not looking right

Postby Gijs » Sat Nov 17, 2012 10:15 am

Welcome!

Does it only happen with your custom liveries, or also with the liveries that are packaged with the aircraft as defaults? Try fiddling with the shaders in the View > Rendering Options dialog. Your graphics card may not support some of them...

Please post all the info as listed in the pink box at the top of this page if that doesn't help.

Cheers,
Gijs
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9364
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: Liveries not looking right

Postby szeged » Sat Nov 17, 2012 10:44 pm

Thanks for the reply. It happens with some but not all of the aircraft included in the release.

I am using a PC with integrated Intel graphics on the motherboard. So I now see that this is probably related to the "shattered plane" effect, and likely has no solution. Looks like I will have to upgrade or just avoid looking at the outside of the plane!
szeged
 
Posts: 2
Joined: Sat Nov 17, 2012 4:19 am

Re: Liveries not looking right

Postby sa7k » Sun Nov 18, 2012 12:28 am

I sometimes get a black airplane but it gets fixed if I change the livery to another and even if I change it back to the original. Have you tried changing liveries?
sa7k
 
Posts: 382
Joined: Fri Mar 16, 2012 2:24 pm
Location: SA7K
Callsign: LV-EPM
IRC name: sa7k
Version: git
OS: debian

Re: Liveries not looking right  

Postby Tomaskom » Sat Dec 08, 2012 8:00 pm

I had the same problem, until yesterday. When reading an article on the wiki (something about improving framerates), I tried one tip which should fix some texture related issues, and everything is all right now :)
Running on Linux, with Intel HD graphics.

Try adding this to your startup command:
Code: Select all
--prop:/sim/rendering/texture-compression=off


This is what it was like at my machine:
Image
"There are no problems in the air. The only problem is hitting the ground"

Get my L-159 ALCA from the FGUK hangar. If you crash it, things gonna go boom!
User avatar
Tomaskom
 
Posts: 132
Joined: Sun Dec 02, 2012 8:03 pm
Location: Czech Republic
Callsign: OK-TomK
Version: git
OS: openSUSE (Linux)

Re: Liveries not looking right

Postby jam007 » Wed Jan 23, 2013 8:23 pm

Tomaskom wrote in Sat Dec 08, 2012 8:00 pm:Try adding this to your startup command:
Code: Select all
--prop:/sim/rendering/texture-compression=off


:idea: :)
Solved my graphics issue too.
jam007
 
Posts: 477
Joined: Sun Dec 16, 2012 10:04 am
Location: Uppsala, Sweden
Version: 2017.3.1
OS: Ubuntu 16.04

Re: Liveries not looking right

Postby saiarcot895 » Tue Feb 19, 2013 12:10 pm

Solved mine as well. Thank you!
Last edited by Gijs on Tue Feb 19, 2013 12:13 pm, edited 1 time in total.
Reason: No useless quoting please.
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 305
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Re: Liveries not looking right

Postby matteom » Sun Jun 29, 2014 4:47 pm

Hallo All

I have the same problem with FG 2.4 I use Mint 13.
Everithing is working only problem is that aircraft are looking with black liveries.
Unable to fix with that command

Do you have any advice?
matteom
 
Posts: 1
Joined: Thu May 29, 2014 1:45 pm


Return to Graphics

Who is online

Users browsing this forum: No registered users and 3 guests