Board index FlightGear Support Tools FGRun

FGRun won't start fgfs with festival

FGRun is a graphical frontend to run FlightGear.

FGRun won't start fgfs with festival

Postby kg6rtr » Sun Aug 22, 2010 6:10 am

I tried to run fgfs with voices enabled for festival. By using advanced settings in FGRun, under "Properties" I added the following:

/sim/sound/voices/enabled=true

and the window listing the command line shows the property between double-quotes:

"--prop:/sim/sound/voices/enabled=true"

However, when I press the "Run" button, I get the following error message in the log window:

"Fatal error: Failed to open file
at "--prop:/sim/sound/voices/enabled=true"
(received from SimGear XML Parser)"

And, if I put the property in the "Executable:" field (all the way back to first window):

Executable: /usr/bin/fgfs --prop:/sim/sound/voices/enabled=true

the log window shows a different error:

execv :: No such file or directory.

I tried to run fgfs from a command line:

[kg6rtr@my_computer]$ fgfs --aircraft=c172p --prop:/sim/sound/voices/enabled=true

and it work as expected, with festival running and having an ATC voice (festival was started in server mode earlier, and was running in the background). Needless to say, FGRun runs fgfs just fine if I remove the aforementioned property.

Technical data:
FGRun 1.5.2
FlighGear 2.0.0
OS: Fedora 13, 64-bit

Is there anything I can do to make FGRun start fgfs with voices enabled ?

Thank you.
Ferdi B.
KG6RTR
kg6rtr
 
Posts: 17
Joined: Sat Jun 06, 2009 9:42 pm

Re: FGRun won't start fgfs with festival

Postby bishb25 » Sun Sep 05, 2010 2:33 am

I have the same problem you have. It seems the issue is simply that fgrun is putting the quotation marks around the option --prop:/sim/sound/voices/enabled=true.

We just have to figure out how to get fgrun to drop the quotes.
Callsign: cncman
"The only thing smart about me... I know where to find the answers." I think?
bishb25
 
Posts: 134
Joined: Wed Sep 09, 2009 4:11 pm
Location: 10mi southwest of KLBE
Callsign: cncman
Version: GIT
OS: Linux

Re: FGRun won't start fgfs with festival

Postby bishb25 » Sun Sep 05, 2010 3:18 am

Got IT!

Here's my temporary fix:

Open FlightGear/data/preferences.xml (I trust you know where the flightgear folder is saved on your system);
find the line
Code: Select all
 <voices>
    <host type="string" write="n">localhost</host>
    <port type="string" write="n">1314</port>
    <enabled type="bool">false</enabled>

and change it to
Code: Select all
 <voices>
    <host type="string" write="n">localhost</host>
    <port type="string" write="n">1314</port>
    <enabled type="bool">true</enabled>

Note: You may have to have root privileges to access this file.

This will cause festival to be enabled every time flightgear is started whether from fgrun or the command line without having to input the --prop:/sim/sound/voices/enabled=true. If you don't wish to use festival on a given day just don't start the festival server and you won't hear the voices. You'll get an error in the log but flightgear will still run fine.

Apparently, if you have other voices installed you can also use preferences.xml to customize which voice you hear for different types of messages. :D
Callsign: cncman
"The only thing smart about me... I know where to find the answers." I think?
bishb25
 
Posts: 134
Joined: Wed Sep 09, 2009 4:11 pm
Location: 10mi southwest of KLBE
Callsign: cncman
Version: GIT
OS: Linux

Re: FGRun won't start fgfs with festival

Postby MAKG » Fri Jan 14, 2011 7:22 pm

At one point, I modified fgrun to fix this. Someone else did the same thing in parallel and it works in the svn version now (so I never submitted it).

But frankly, I find FG unusable with festival, as there is FAR too much chatter. That is, unless you turn multiplayer off. Festival will happily talk over everything, like ATIS and fgcom, and there doesn't appear to be a way to turn its volume down or make it shut up. A good idea, but not too useful in practice.
MAKG
 
Posts: 1156
Joined: Sun Oct 19, 2008 6:11 pm
Location: California Central Coast

Re: FGRun won't start fgfs with festival

Postby sunjob » Mon Aug 13, 2012 5:13 pm

good day!

mini patch for fgrun-1.5.2 : send add property to argument of command string w/o "

-> cut
fgfsrc.patch [----] 0 L:[ 1+ 0 1/ 12] *(0 / 411b)= - 45 0x2D
--- src/fgfsrc.cxx 2010-01-24 16:33:01.000000000 +0700
+++ src/fgfsrc_new.cxx 2012-08-14 00:56:43.434983659 +0800
@@ -373,7 +373,7 @@ Wizard::write_fgfsrc( Fl_Preferences &pr
prefs.get( Fl_Preferences::Name("property-item-%d", i),
buf, "", buflen-1 );
if ( strlen( buf ) > 0 )
- os << pfx << "\"--prop:" << buf << "\"";
+ os << pfx << "--prop:" << buf << "";
}
.
// Debugging
--> cut

this bug because of the introduction of the parameters with spaces in the new version :o)))
now adding property "/sim/sound/voices/enabled=true" - work ik OK

I apologize for my english
with love from siberia
sunjob
 
Posts: 1
Joined: Mon Aug 13, 2012 5:07 pm


Return to FGRun

Who is online

Users browsing this forum: No registered users and 3 guests