Board index FlightGear Support Tools FGRun

fgrun and FG CVS properties issues

FGRun is a graphical frontend to run FlightGear.

fgrun and FG CVS properties issues

Postby hvengel » Sat Feb 13, 2010 9:27 am

I use the Advanced --> Properties settings in fgrun to setup things like changing the redout/blackout G force settings and setting up default frequencies for the com radio. This was working OK for FG 1.9.x but it appears that this is broken in CVS. In the the log window I get messages like:

Fatal error: Failed to open file
at "--prop:/sim/rendering/redout/papmeters/blackout-onset-g=4.5"
(received from SimGear XML Parser)


I also tried setting one of these properties from the command line like this:

Code: Select all
fgfs --prop:/sim/rendering/redout/papmeters/blackout-onset-g=4.5


And that does not set the property although there are no error messages and flightgear starts up. Anyone have any idea what is causing this or how to fix it?
hvengel
Retired
 
Posts: 1128
Joined: Sun Dec 24, 2006 4:35 am
Location: Minden Nevada

Re: fgrun and FG CVS properties issues

Postby fredb » Sat Feb 13, 2010 10:44 am

hvengel wrote:fgfs --prop:/sim/rendering/redout/papmeters/blackout-onset-g=4.5

"papmeters" ?
User avatar
fredb
 
Posts: 756
Joined: Fri Dec 01, 2006 10:41 am
Location: Paris, France

Re: fgrun and FG CVS properties issues

Postby hvengel » Sat Feb 13, 2010 6:49 pm

Sorry I typo'ed. It should have read

/sim/rendering/redout/parameters/blackout-onset-g=4.5

I used these same settings with 1.9.1 and they work fine but they fail with CVS when using fgrun to launch FG. For some reason it appears that fgrun is putting quotes around this but I am not sure if that is the issue. Fixing the typo also makes this work from the command line. So it looks like this is an fgrun issue.
hvengel
Retired
 
Posts: 1128
Joined: Sun Dec 24, 2006 4:35 am
Location: Minden Nevada


Return to FGRun

Who is online

Users browsing this forum: No registered users and 2 guests