Board index FlightGear Support Tools FGRun

--SOLVED-- FG not opening while broadcasting position on BT  Topic is solved

FGRun is a graphical frontend to run FlightGear.

--SOLVED-- FG not opening while broadcasting position on BT  

Postby tcx32fr » Tue Sep 26, 2017 9:02 am

Hello

I have been trying to use FG and meanwhile to broadcast GPS NMEA position on my PC WIN7 BT com port (COM8).
It appears that 1- I found the correct set of parameters to add to the Launch command line --nmea,serial,out,1,COM8,4800, but when I launch FG with such set of parameters, the init of FG stops and remains stuck at "Position Initialization".

Log is available here (post #18 @ http://fr.flightgear.org/forums/viewtop ... 634#p39634 , first log is the one with --nmea parameters, second one is the one without where everything is OK. One can see that the last sentence of the --nmea log is :"view:3:G:\Jenkins\workspace\Windows-release\flightgear\src\Viewer\splash.cxx:678:Splash screen progress finalize-position")

But I discovered that if I launch an PC WIN app which has been designed by a French pilot (see here: http://francois.fouchet.free.fr/, there is a link for english speakers in the menu) before launching FG, FG is not stuck anymore during its initialization. Indeed, in this application aimed at preparing VFR flight navigation, there is an option to send to a port Com MNEA GPS position for a simulation mode - see here: https://drive.google.com/file/d/0B-Weut ... sp=sharing) -

Doing so and launching for a while this simulation mode, then exiting the app and launching FG: FG is happy and passes all initialization steps with --nmea parameters

I am not a PC software expert but it seems that Navigation software sets parameters or variables for port com management or other stuffs in windows which are retained even if the application is exited, and it seems that FG is benefiting from these parameters/variables to init itself OK

Is it a know issue - I have seen somewhere else on the forum that "Position Initialization" stuck were already observed, and would it be possible to add to the launch of FG the adequate set of parameters (identical to Navigation App ?) to allow a good behavior along with --nmea parameters ?

Thanks in advance for any help

NB: My conf: FlightGear 2017.2.1
Win7 SP1, NVIDIA GeForce GTX 650 TI Boost 2GO, Directx11, proc AMDFX-8350 8 coeurs, 8 GO RAM, Stick Logitech Extreme 3D Pro
Last edited by tcx32fr on Fri Oct 06, 2017 10:58 pm, edited 1 time in total.
tcx32fr
 
Posts: 5
Joined: Sat Sep 16, 2017 4:35 pm

Re: FG not opening while broadcasting position on BT

Postby tcx32fr » Wed Sep 27, 2017 9:10 pm

Hi
In case there is any Flightgear developer around, here is a link containing the code used by Navigation developer to set port com - using Windows primitives, which could be analyzed to investigate if there are differences with was is done - and at least for me not working - in Flightgear.

I don't know what to do in addition to help resolution of my issue

Thanks

https://drive.google.com/open?id=0B-Weu ... AxTGNOazdj
tcx32fr
 
Posts: 5
Joined: Sat Sep 16, 2017 4:35 pm

Re: --SOLVED-- FG not opening while broadcasting position on

Postby tcx32fr » Fri Oct 06, 2017 11:13 pm

Hi, for those interested, I succeded to identify the root cause of the issue and a work-around. In fact, if the Bluetooth connexion is not established during the init phase of FG, the init phase never ends up and is frozen.
The trick is to FIRST launch from the Android tablet the appropriate app (Bluetooth GPS app for instance), with "automatic reconnect request if no connexion is established" parameter set to 1. The Android App will try to connect and reconnect up until a connexion is established. THEN launch FG, and during the init phase of FG, FG requests the BT connexion, gets a positive answer from the Android device app and that'is it, bingo, it works

Hope it will help those interested to get their favorite aircraft position on a moving map on a Android device.

NB: the "why" the FG init is frozen if no BT connexion is available while launching FG with the appropriate --NMEA etc.. parameters is another topic I am totally unable to further comment
tcx32fr
 
Posts: 5
Joined: Sat Sep 16, 2017 4:35 pm


Return to FGRun

Who is online

Users browsing this forum: No registered users and 1 guest