Board index FlightGear Support Tools FGRun

Sending data via UDP

FGRun is a graphical frontend to run FlightGear.

Sending data via UDP

Postby noobee » Sun Feb 16, 2014 7:34 pm

Hey there,

I am trying to configure flightgear to send data via UDP. At the beginning it is only the altitude and the heading values. There's a how to on doing that but it doesn´t seem to work for me. My configuration is a little bit complex but I try to explain it anyway. :D

My computer is running on a Win 7 system where Simulink is working. On that System I have a virtual machine running an Ubuntu 12.04 LTS system on which flighgear is running. It works very nice without crashing or something else. 8)

I am starting flighgear with the launcher. In the last step during the launcher configuration at the advanced menu I am adding the “Input/Output” option which looks like:

--generic=socket,out,10,localhost,5000,udp,my_protocol

First of all I wanted to catch the UDP packets in the virtual machine using wireshark what doesn´t work.
The my_protocol.xml looks like this:

<?xml version="1.0"?>
<PropertyList>
<generic>
<output>
<line_separator>newline</line_separator>
<var_separator>tab</var_separator>

<chunk>
<node>/position/altitude-agl-ft</node>
<name>altitude to go</name>
<type>float</type>
<format>%03.2f</format>
</chunk>

<chunk>
<node>/orientation/heading-deg</node>
<name>Heading</name>
<type>float</type>
<format>%03.3f</format>
</chunk>

</output>
</generic>
</PropertyList>

I was expecting seeing the UDP packets in wireshark during the flight. What am I doing wrong??? :(
noobee
 
Posts: 8
Joined: Wed Jan 22, 2014 4:18 pm

Return to FGRun

Who is online

Users browsing this forum: No registered users and 1 guest