Board index FlightGear Support Tools FGRun

Version Conflict?

FGRun is a graphical frontend to run FlightGear.

Version Conflict?

Postby KyleKatarn » Sat Oct 26, 2013 11:52 pm

Ok, So Ive Got The Following Versions Installed Like This

V2.12 With Rembrandt
C:\Program Files\FlightGear\
V1.0.0
C:\Program Files\FlightGear 1.0.0\
V1.9.0
C:\Program Files\FlightGear 1.9.0\

But When I Launch FlightGear V2.12 I Get An Error In The CMD Window

''Unknown Command --Disable AI Traffic--''

Im Going To Assume Thats Why FG Doesnt Start(Even Though It Says It Has)
Windows 7 64-Bit SP2
Intel Core 2 Quad Q8300 @ 2.5GHZ (4 Cores)
NVIDIA GeForce GTX 750TI 2GB MSI Gaming Factory OC @ PCI-E 1.1
Creative Labs SoundBlaster X-FI Go! Pro USB (E.A.X. 5, 64-Channel)
4GB PNY Optima DDR2 667MHZ
1TB Total Storage
User avatar
KyleKatarn
 
Posts: 16
Joined: Sat Oct 26, 2013 7:41 pm
Location: Lick Creek, Southern Illinios, USA
Callsign: AirWhoopass
Version: v3.4.0
OS: Windows 7 64-Bit

Re: Version Conflict?

Postby Gijs » Sun Oct 27, 2013 9:19 am

Could you please copy&paste your command-line (tick the "Show command-line" box on last page of the launcher)?
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9306
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: Version Conflict?

Postby KyleKatarn » Sun Oct 27, 2013 1:20 pm

I Have Figured Out That It Is Trying To Run The V2.12 Exe With 1.9.0 Data, I Can Switch The Data And Exe Path By Hand But Not The Scenary

C:\Program Files\FlightGear 1.9.0\bin\Win32\fgfs.exe
--fg-root=C:\Program Files\FlightGear 1.9.0\data
--fg-scenery=C:\Program Files\FlightGear 1.9.0\data\Scenery;C:\Program Files\FlightGear 1.9.0\scenery;C:\Program Files\FlightGear 1.9.0\terrasync
--aircraft=f-14b
--control=joystick
--enable-game-mode
--enable-random-objects
--enable-hud
--disable-anti-alias-hud
--enable-horizon-effect
--enable-enhanced-lighting
--enable-distance-attenuation
--enable-ai-models
--disable-ai-traffic <----------------------------------------------------------------------Error Message
--disable-real-weather-fetch
--enable-clouds3d
--enable-fullscreen
--geometry=1024x768
--bpp=32
--texture-filtering=8
--prop:/sim/rendering/rembrandt/enabled=true
--prop:/sim/rendering/multisamples=8

Yes, I Run Rembrandt On A GT 520 Cupled To A Single Core..................But It Was Running Before I Installed The Other 2 Versions
Windows 7 64-Bit SP2
Intel Core 2 Quad Q8300 @ 2.5GHZ (4 Cores)
NVIDIA GeForce GTX 750TI 2GB MSI Gaming Factory OC @ PCI-E 1.1
Creative Labs SoundBlaster X-FI Go! Pro USB (E.A.X. 5, 64-Channel)
4GB PNY Optima DDR2 667MHZ
1TB Total Storage
User avatar
KyleKatarn
 
Posts: 16
Joined: Sat Oct 26, 2013 7:41 pm
Location: Lick Creek, Southern Illinios, USA
Callsign: AirWhoopass
Version: v3.4.0
OS: Windows 7 64-Bit

Re: Version Conflict?

Postby Hooray » Sun Oct 27, 2013 1:33 pm

umm, why did you install those other versions if 2.12 worked, even in Rembrandt mode ??
Anyways, you simply need to fix up the paths for each installed version, to only refer to the corresponding FlightGear installation path - there's no reason why you can't have multiple versions installed, you just need to be careful to keep them in separate folders and configure fgrun (the launcher) accordingly.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11287
Joined: Tue Mar 25, 2008 8:40 am

Re: Version Conflict?

Postby KyleKatarn » Sun Oct 27, 2013 1:45 pm

1, How Do I Configure The FGRun To Use The Correct Folder?
2. V2.12 No Rembrandt = 20-30FPS || V2.12 With Rembrandt = 2-11 FPS
Windows 7 64-Bit SP2
Intel Core 2 Quad Q8300 @ 2.5GHZ (4 Cores)
NVIDIA GeForce GTX 750TI 2GB MSI Gaming Factory OC @ PCI-E 1.1
Creative Labs SoundBlaster X-FI Go! Pro USB (E.A.X. 5, 64-Channel)
4GB PNY Optima DDR2 667MHZ
1TB Total Storage
User avatar
KyleKatarn
 
Posts: 16
Joined: Sat Oct 26, 2013 7:41 pm
Location: Lick Creek, Southern Illinios, USA
Callsign: AirWhoopass
Version: v3.4.0
OS: Windows 7 64-Bit

Re: Version Conflict?

Postby Hooray » Sun Oct 27, 2013 2:12 pm

please see the docs, referring you to the wiki: http://wiki.flightgear.org/Fgrun
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11287
Joined: Tue Mar 25, 2008 8:40 am


Return to FGRun

Who is online

Users browsing this forum: No registered users and 1 guest