Board index FlightGear Support Tools FGRun

comand line options

FGRun is a graphical frontend to run FlightGear.

comand line options

Postby pommesschranke » Sun Oct 06, 2013 9:58 am

how/where can I enter the following options in fgrun?

--telnet=9000
--enable-fgcom
pommesschranke
 
Posts: 1104
Joined: Sat Apr 27, 2013 7:58 pm
Location: EDLM & LJCE
Callsign: d-laser
IRC name: laserman
Version: git
OS: Linux Lubuntu 18.04

Re: comand line options

Postby ludomotico » Sun Oct 06, 2013 11:00 pm

I don't knwo about fgcom, but you can configure telnet in the advanced menu:

In the last tab, just before pressing "run", click on the button "advanced". Section "Input/Output", press "new" and set these options:

- Protocol: telnet
- Medium: socket
- Direction: in
- Hz: 5
- Hostname: leave empty
- Port: 9000

(some of these values are nonsense, but apparently fgrun need them!)

OK to all and there you are.

If you need telnet for FlightGearMap, remember you must find the local IP address of your computer and enter this address in the settings menu of FlightGearMap, section communications. Do a quick search in google with the name of your operating system to learn how you can find the IP address of your computer. Beware the IP shown in some web pages is not usually your local IP!
User avatar
ludomotico
 
Posts: 1018
Joined: Tue Apr 24, 2012 1:01 pm
Version: git
OS: Debian GNU/Linux

Re: comand line options

Postby Gijs » Mon Oct 07, 2013 6:51 am

You can add --enable-fgcom behind the fgfs.exe path on the first page (don't forget to put a space inbetween). I'll add a checkbox later today.
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9364
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: comand line options

Postby ludomotico » Mon Oct 07, 2013 7:50 am

Gijs, this doesn't work on Linux. Linux believes you want to run a command called "fgfs --enable-fgcom", space included, and execvp() fails with a "command not found".
User avatar
ludomotico
 
Posts: 1018
Joined: Tue Apr 24, 2012 1:01 pm
Version: git
OS: Debian GNU/Linux

Re: comand line options

Postby Gijs » Mon Oct 07, 2013 8:11 am

Oh ok. You can use the plain property --prop:/sim/fgcom/enabled=true instead (can be added through Advanced > Properties) or wait a few hours till I've added the checkbox ;-)
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9364
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10


Return to FGRun

Who is online

Users browsing this forum: No registered users and 3 guests