Board index FlightGear Support Tools FGCom

FGCOM 3.4 Standalone problem

FGCom is a realtime voice communication system specially designed for FlightGear.

FGCOM 3.4 Standalone problem

Postby CaptB » Wed Feb 18, 2015 3:39 pm

Hello folks,

I am unable to use FGCOM 3.4 standalone on Windows 7 64 with ATC-Pie or OR. I am able to hear everyone but unable to transmit ( I am not heard ) No errors shown in the console , echo test works fine. FGCOM 2.9 is working correctly.

Any hints/ideas? Thanks!
CaptB
 
Posts: 487
Joined: Thu May 23, 2013 6:36 pm
Callsign: EKCH_AP
IRC name: CAPTB
Version: 2018.1
OS: Xubuntu, Win7 64

Re: FGCOM 3.4 Standalone problem

Postby mickybadia » Wed Feb 18, 2015 5:43 pm

Aye, how are you Captain?

I did not know you were having this problem while testing ATC-pie. I have spent some time with henrikp (another beta-tester) trying to debug the same problem, rather looking for a local setup issue as nobody had reported anything like it. Running back the ATC-pie commit history, we discovered it started to fail exactly the way you describe, and exactly when I upgraded to FGCom v3.4.

It appears that there are at least two of you having the same problem, plus he is running Gentoo Linux I think (to be confirmed, I may be confusing two people here), in which case the problem may not at all be local.

I will direct him to this post, and let him share the relevant exchanges we have had and the various tests we have performed trying to diagnose the problem. It is interesting to see that OpenRadar suffers from it as well on your side. I don't know/remember if he has tried that, but I think he has it working from FGFS... Perhaps you should both recap this all here so that Clément can have an informed look.

See Captain how useful it is to share your problems? :-p
mickybadia
 
Posts: 394
Joined: Tue Sep 24, 2013 9:12 am

Re: FGCOM 3.4 Standalone problem

Postby henrikp » Wed Feb 18, 2015 6:06 pm

CapB: could you check out the source with reference e51c0806722f3d782a3ad0c8c7ce98faf0c3fb6c (https://gitorious.org/atc-pie/atc-pie/s ... faf0c3fb6c:) to see, if that works for you too?
henrikp
 
Posts: 74
Joined: Thu Feb 26, 2009 8:59 am
Location: Estonia
Callsign: ES-KLA
IRC name: ahven
Version: git
OS: Gentoo

Re: FGCOM 3.4 Standalone problem

Postby CaptB » Wed Feb 18, 2015 7:27 pm

I pull a couple of times daily the dev branch, so I have the latest.

As mentioned in my post I had this problem in OR as well and was unable to use 3.x. The 2.9 is a win64 build while 3.4 is win32, maybe that is an issue?. The 2.9 is running as an external box on port 63333, I tried to run 3.4 the same way with no positive results.
CaptB
 
Posts: 487
Joined: Thu May 23, 2013 6:36 pm
Callsign: EKCH_AP
IRC name: CAPTB
Version: 2018.1
OS: Xubuntu, Win7 64

Re: FGCOM 3.4 Standalone problem

Postby henrikp » Wed Feb 18, 2015 7:32 pm

CaptB wrote in Wed Feb 18, 2015 7:27 pm:I pull a couple of times daily the dev branch, so I have the latest.

This is an old, January 25 snapshot location. For some strange reason, that build is the last one to work for me. (that is, other can hear my voice via fgcom)
henrikp
 
Posts: 74
Joined: Thu Feb 26, 2009 8:59 am
Location: Estonia
Callsign: ES-KLA
IRC name: ahven
Version: git
OS: Gentoo

Re: FGCOM 3.4 Standalone problem

Postby F-JJTH » Wed Feb 18, 2015 7:39 pm

Hi,

I just checked FGCom 3.4.0 and everything works fine here.

Here is my test case:
1) Delete every files located at "ATC-Pie/output" but keep the "Notice" file
2) Start 2 ATC-Pie instance at the same airport (in my case LFNH)
3) On the first ATC-Pie instance create 1 radio box (you should read "Radio box ready; connection port 16666" in the terminal)
4) Then switch on the radio box (you should read "FGCom-16666 instance is on." in the terminal)
5) On the second ATC-Pie instance create 2 radio box (you should read "Radio box ready; connection port 16666" and "Radio box ready; connection port 16667" in the terminal)
6) Then switch on the second radio box (you should read "FGCom-16667 instance is on." in the terminal)
(take care to be at the very same airport and the very same frequency in both ATC-Pie instance)
7) Press the PTT button of the first ATC-Pie instance and talk, you should hear your voice

If you can't hear your voice at this step:
1) Start an echo test and make sure you can hear your voice during echo test
2) Go back to the "ATC-Pie/output" directory then show me the content of all .log files

Regards,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: FGCOM 3.4 Standalone problem

Postby CaptB » Wed Feb 18, 2015 8:33 pm

Proceeded with the test :

1- When creating a new box, no "Radio box ready; connection port xxxxx" messages displayed at all.
2- Cannot hear own voice.
3- Echo test passed.
4- All log files empty.
CaptB
 
Posts: 487
Joined: Thu May 23, 2013 6:36 pm
Callsign: EKCH_AP
IRC name: CAPTB
Version: 2018.1
OS: Xubuntu, Win7 64

Re: FGCOM 3.4 Standalone problem

Postby mickybadia » Wed Feb 18, 2015 8:47 pm

<offline>
Damn! I have always known I should allow to choose the FGCom connection ports explicitly. Nice work around Clément!
EDIT: now possible since March release, see --fgcom-ports command line option.
</offline>

Sorry to kick in, but this might save some misunderstandings...

The two people involved here are on the testing branch so either must check back into the public branch for your test or acknowledge that the console messages you are referring to have been removed... What Clément is asking is NOT to use the same port in both instances. In the latest dev commit, you can know what port a radio box connects to from its on/off button tooltip.
Last edited by mickybadia on Mon Apr 20, 2015 11:48 am, edited 1 time in total.
mickybadia
 
Posts: 394
Joined: Tue Sep 24, 2013 9:12 am

Re: FGCOM 3.4 Standalone problem

Postby F-JJTH » Wed Feb 18, 2015 10:09 pm

Indeed I'm using "master" branch for my test. CaptB, please can you try the same test with the master branch of ATC-Pie instead of the "dev" branch ?

For summary, you are reporting that:
* echo test is working with FGCom 3.4 and older
* you can hear other people with FGCom 3.4 and older
* other can't hear you with FGCom 3.4 but they can with older FGCom

all correct ?


@Michael: you would change the "--voipserver" option to "--server" in your source code ;-)
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: FGCOM 3.4 Standalone problem

Postby CaptB » Thu Feb 19, 2015 11:12 am

Tested current main:

Exactly the same results as described in previous post.

Tested https://gitorious.org/atc-pie/atc-pie/source/e51c0806722f3d782a3ad0c8c7ce98faf0c3fb6c: :

both PTT boxes grayed out, unable to perform test, log files empty.

Tested ATC-Pie and FlighGear3.4 locally:

Able to transmit and receive voice from FG. ATC-Pie is able to receive, transmissions are lost.
CaptB
 
Posts: 487
Joined: Thu May 23, 2013 6:36 pm
Callsign: EKCH_AP
IRC name: CAPTB
Version: 2018.1
OS: Xubuntu, Win7 64

Re: FGCOM 3.4 Standalone problem

Postby F-JJTH » Thu Feb 19, 2015 7:04 pm

CaptB,

Good new ! I found what is going wrong and I have a fix for that.
The problem is not related to FGCom 3.4, it's a problem of bad packet sent by ATC-Pie.

I will inform both OpenRadar and ATC-Pie maintainer that they need to update their source code if they want to provide built-in FGCom to their users.
I think it will be fixed in ATC-Pie really soon ;)

Kind regards,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: FGCOM 3.4 Standalone problem

Postby mickybadia » Thu Feb 19, 2015 9:55 pm

Thank you Clément for your diagnosis. I had not known FGCom packets had changed so was probably not going to solve this very quickly.
The fix is already on the dev branch.
mickybadia
 
Posts: 394
Joined: Tue Sep 24, 2013 9:12 am


Return to FGCom

Who is online

Users browsing this forum: No registered users and 2 guests