Board index FlightGear Support Tools FGCom

[SOLVED] Looks like the space-bar doesn't work with my FGCom  Topic is solved

FGCom is a realtime voice communication system specially designed for FlightGear.

[SOLVED] Looks like the space-bar doesn't work with my FGCom

Postby Andreas » Wed Jul 30, 2014 5:34 pm

Hi, I'm on linux debian, so my fgcom doesn't work :)

As I have "display messages" enabled, shouldn't I get a message when the PPT-button is pressed or released?
This information could help me to rule out soundcard issues.

Thanks in advance!
Last edited by Andreas on Thu Jul 31, 2014 7:03 am, edited 1 time in total.
User avatar
Andreas
 
Posts: 128
Joined: Sat Mar 14, 2009 6:11 pm
Callsign: D-AZ
Version: 3.4.1
OS: Debian Buster

Re: Looks like the space-bar doesn't work with my FGCom(FG3.  

Postby F-JJTH » Wed Jul 30, 2014 9:28 pm

You can get the PPT information in the property tree (Debug > Property tree) by looking at /instrumentation/comm[n]/ptt
FGCom is listening this property, if this property = 1 the mic is open and your voice is transmitted.

Also take care to tweak the silence threshold setting available in Multiplayer > FGCom Settings in case your mic is not enough powered (low input volume/bad mic quality)

How good is the echo test available in Multiplayer > FGCom Settings ?

Regards,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: [SOLVED] Looks like the space-bar doesn't work with my F

Postby Andreas » Thu Jul 31, 2014 7:37 am

Thanks for the quick reply.
Looking at the property tree verified the spacebar is working, and when I did some more testing I found out my FGCom actually does work :oops:

Analysis:
- me stupid
- The old FGCom put out a message to the terminal each time the PTT-button was pressed, so the absence of this feature led me to the stupid premature assumption the whole system didn't work only because someone couldn't hear me. :roll:
- As I have a no-hardware-mixing-soundcard, I already expect alsa trouble after each major system upgrade.

Suggestions:
- The wiki recommends to keep the "enable messages" box checked to verify the function of the fgcom-related keys. This should be corrected and maybe the information about the property-tree could be mentioned there.
- FGCom could print a PTT-message if messages are enabled
- The echo test should respond only to signals that are picked up while PTT is pressed
- On the live-fgcom-page http://fgcom.flightgear.org/index.php (which is a great tool for trouble shooting) it's not clear what time-zone the "date" column refers to.
- Maybe there is a way to implement an audio testing tool in the FGCom menu, like doing two "aplay test.wav" simultaneously? (Altough, this problem is already well covered by the wiki).

Thanks for the good work! It's good to have the radio included in FG.
Best regards
Andreas
User avatar
Andreas
 
Posts: 128
Joined: Sat Mar 14, 2009 6:11 pm
Callsign: D-AZ
Version: 3.4.1
OS: Debian Buster

Re: [SOLVED] Looks like the space-bar doesn't work with my F

Postby Johan G » Sun Aug 03, 2014 9:18 am

Andreas wrote in Thu Jul 31, 2014 7:37 am:- The echo test should respond only to signals that are picked up while PTT is pressed

That is not a bad idea.
Low-level flying — It's all fun and games till someone looses an engine. (Paraphrased from a YouTube video)
Improving the Dassault Mirage F1 (Wiki, Forum, GitLab. Work in slow progress)
Johan G
Moderator
 
Posts: 5294
Joined: Fri Aug 06, 2010 5:33 pm
Location: Sweden
Callsign: SE-JG
IRC name: Johan_G
Version: 3.0.0
OS: Windows 7, 32 bit

Re: [SOLVED] Looks like the space-bar doesn't work with my F

Postby F-JJTH » Sun Aug 03, 2014 6:53 pm

Hi,

Thanks you for the feedback !

Andreas wrote in Thu Jul 31, 2014 7:37 am:- [...] the information about the property-tree could be mentioned there.
- FGCom could print a PTT-message if messages are enabled
- On the live-fgcom-page http://fgcom.flightgear.org/index.php (which is a great tool for trouble shooting) it's not clear what time-zone the "date" column refers to.

I will work on these points.


Andreas wrote in Thu Jul 31, 2014 7:37 am:- The echo test should respond only to signals that are picked up while PTT is pressed

I don't like this idea because the echo test is a "debug helper" for the audio & network scheme used by FGCom (OpenAL input/output + Asterisk client/server)
When "echo test" is working fine you are sure that your audio device is correctly configured and the network is correct.
If we include the "does your PTT (joystick? keyboard? customized?) we increase the complexity of debug.

If FGCom works only in "echo test" mode = your PTT button has a problem (wrong joystick configuration ? keyboard bug ?)
If FGCom doesn't work in "echo test" mode = your audio device is not correctly configured ? are you connected on fgcom.flightgear.org ?)

Mixing these 2 points will makes the task harder to help a user.
Between, I will add the PTT information in the dialog + messages so I'm sure it will help a lot to immediatly identify if the PTT is working fine.

Kind regards,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: [SOLVED] Looks like the space-bar doesn't work with my F

Postby F-JJTH » Tue Aug 19, 2014 11:42 am

Hi,

Andreas wrote in Thu Jul 31, 2014 7:37 am:- [...] the information about the property-tree could be mentioned there.
- FGCom could print a PTT-message if messages are enabled
- On the live-fgcom-page http://fgcom.flightgear.org/index.php (which is a great tool for trouble shooting) it's not clear what time-zone the "date" column refers to.


All these points have been worked.
- The property is indicated in the FGCom dialog (FG git)
- A checkbox is automatically checked as soon as you trigger the property with your PTT button (FG git)
- On http://fgcom.flightgear.org the "UTC" tag has been added beside "Date"

Regards,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am


Return to FGCom

Who is online

Users browsing this forum: No registered users and 2 guests

cron