Board index FlightGear Support Tools FGCom

New FGCom is compatible with old FGCom

FGCom is a realtime voice communication system specially designed for FlightGear.

New FGCom is compatible with old FGCom

Postby F-JJTH » Sun Jun 01, 2014 11:42 am

Hi,

Because we have a user on the forum who is diffusing the wrong information that new FGCom is not compatible with old FGCom
I'm doing the official announcement that old FGCom is compatible with the new FGCom.

The proof in less than 2 minutes of video:




Now everybody know that old FGCom is compatible with new FGCom.


Kind regards,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: New FGCom is compatible with old FGCom

Postby D-EKEW » Sun Jun 01, 2014 12:35 pm

Hi Clément,

First of all thank you for taking up the development of FGCOM, it is much appreciated!

Secondly I want to say I am using FGCOM2 (with Openradar) on your server while ATC-ing at ELLX with no problems since you setup your server. Thanks for that service also.

Thirdly maybe you can be a bit more precise what version of FGCOM client works with what version FGCOM server, because I think that is where the confusion comes from. We now all know all FGCOM clients work with your server.
But before it was setup, were using another server as the old "official" one was constantly giving us problems. As you can imagine, after FGCOM was integrated in FGFS and a lot of people are using GIT / the latest development version rather then stable, we got into problems. We were forced to use both FGCOM servers and that just did not work as people were talking at the same time etc.. Luckily this transition period is over since the release of FGFS 3.0 and for me there is no reason to use anything else but FGCOM.

Merci,

Eric
D-EKEW
 
Posts: 159
Joined: Mon Jan 10, 2011 8:22 pm
Callsign: D-EKEW, ELLX-TWR
Version: git
OS: Linux

Re: New FGCom is compatible with old FGCom

Postby F-JJTH » Sun Jun 01, 2014 2:34 pm

Hi Eric,

D-EKEW wrote in Sun Jun 01, 2014 12:35 pm:you can be a bit more precise what version of FGCOM client works with what version FGCOM server


Clearly, every version of FGCom client are compatible with fgcom.flightgear.org

I can't tell anything about other FGCom servers because I'm not the maintainer of these servers.
I recommend to simply ignore other FGCom servers because we have no proof that they work correctly. (Last time I heard about them I remember they were badly configured)


My server has been some month after I've started to maintain FGCom (may 2013, wow already 1 year ago :) ) But at this period the server was hosting in my house where my internet connection wasn't sufficient.
Since November 2013 fgcom.flightgear.org is hosted on a professionnal server with sufficient internet connection. I am the one who is paying this server with my personal money for the FlightGear community. Take it as a present ;)

I'm glad to see that everything works fine for you and hundreds of other user (looking at the "number of connections vs the number of bug report" I'm confident that my work is a success)

Kind regards,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am


Return to FGCom

Who is online

Users browsing this forum: No registered users and 2 guests