Board index FlightGear Support Tools FGCom

Problem with FGCom 3.0

FGCom is a realtime voice communication system specially designed for FlightGear.

Problem with FGCom 3.0

Postby gameman1 » Wed Apr 16, 2014 10:41 am

When I try to start FGCom, it tells me that I don´t have permissions.
I tried both ways with the run_fgcom.command file or manually with the terminal.

I´m on Mac OS Mavericks and using FGCom 3.0 and I need the standalone because I want to use OpenRadar.

When I try with the file, it says "Die Datei „run_fgcom.command“ konnte nicht ausgeführt werden, da Sie nicht über die notwendigen Zugriffsrechte verfügen."
When I try with the Terminal, it says:
Code: Select all
"maximilians-mbp:~ Max$ /Applications/FGCom/bin/fgcom -Sfgcom01.flightgear.org
-bash: /Applications/FGCom/bin/fgcom: Permission denied"


Plesae help me, I don´t know what to do any more!
gameman1
 
Posts: 3
Joined: Wed Apr 16, 2014 10:13 am
OS: Mac OS Mavericks

Re: Problem with FGCom 3.0

Postby PH-JAKE » Wed Apr 16, 2014 3:59 pm

Hi,

I assume you picked up fgcom-3.0.0_mac.zip from fgcom.flightgear.org, so let's start from there.
Any program/script needs execute permission. When unzipping this file the contents doesn't have that permission.
So it must be assigned, that's what run_fgcom.command is trying to do. But I guess it's needs to have execute permission as well.
Well, then make it so, as follows: "chmod +x run_fgcom.command". Now try again.

PS: did you know OpenRadar comes with build in FGCom these days?
Last edited by PH-JAKE on Fri Apr 18, 2014 6:05 am, edited 1 time in total.
PH-JAKE
 
Posts: 108
Joined: Tue Mar 11, 2014 11:53 pm
Callsign: PH-JAKE
Version: 2016.2.1
OS: Debian jessie

Re: Problem with FGCom 3.0

Postby gameman1 » Wed Apr 16, 2014 4:33 pm

I know that open radar has FGCom built in but I think this does´t work with Mac OS or did they fix that with V3.0?
gameman1
 
Posts: 3
Joined: Wed Apr 16, 2014 10:13 am
OS: Mac OS Mavericks

Re: Problem with FGCom 3.0

Postby F-JJTH » Wed Apr 16, 2014 5:04 pm

The run_fgcom.command and test_fgcom.command have all the required command in order to avoid this error.
The only things that you need is to set the run/test_fgcom.command as executable with the command line given by PH-JAKE.

Last time that I had info from a Mac user he told me that double-clicking on run/test_fgcom.command show up a popup with a message something like "This script is provided by a non-verified developper, are you sure you wnat to open it ?" and you have a "Yes" and "No" button that you can click. But it looks like your Mac has not the same behaviour and make the choice to don't open the script instead of asking you.

Once you have found how to authorize your Mac to execute this script you will be able to use FGCom. (You can even ask for help on a dedicated Mac forum maybe)

Regards,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: Problem with FGCom 3.0

Postby PH-JAKE » Wed Apr 16, 2014 8:31 pm

gameman1 wrote in Wed Apr 16, 2014 4:33 pm:I know that open radar has FGCom built in but I think this does´t work with Mac OS or did they fix that with V3.0?


I would have to go and see, but that will take a few days. Or one of the OpenRadar developers beat me to it.
PH-JAKE
 
Posts: 108
Joined: Tue Mar 11, 2014 11:53 pm
Callsign: PH-JAKE
Version: 2016.2.1
OS: Debian jessie

Re: Problem with FGCom 3.0

Postby elgaton » Thu Apr 17, 2014 8:14 pm

Sorry if I chime in - to give execute permissions, the command should be
Code: Select all
chmod +x run_fgcom.command

instead of "-x".
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

Re: Problem with FGCom 3.0

Postby PH-JAKE » Fri Apr 18, 2014 6:07 am

elgaton wrote in Thu Apr 17, 2014 8:14 pm:Sorry if I chime in - to give execute permissions, the command should be
Code: Select all
chmod +x run_fgcom.command

instead of "-x".


Oops. :oops: FIxed, thanks.
PH-JAKE
 
Posts: 108
Joined: Tue Mar 11, 2014 11:53 pm
Callsign: PH-JAKE
Version: 2016.2.1
OS: Debian jessie

Re: Problem with FGCom 3.0

Postby skilled » Mon Apr 28, 2014 1:23 am

Slightly of the the subject but when i use FGcom my whole flightgear crashes :( bit annoying when using multiplayer
skilled
 
Posts: 43
Joined: Mon Apr 14, 2014 8:27 am
Location: Australia
Version: 3.2.0
OS: Windows 8&OS X

Re: Problem with FGCom 3.0

Postby F-JJTH » Mon Apr 28, 2014 7:27 am

Please open a new topic for your own problem and provide more information else we can't help you.

Regards,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am


Return to FGCom

Who is online

Users browsing this forum: No registered users and 2 guests