Board index FlightGear Support Tools FGCom

FGCOM strange sounds on echo test mode

FGCom is a realtime voice communication system specially designed for FlightGear.

FGCOM strange sounds on echo test mode

Postby BRT » Tue Nov 08, 2011 7:57 pm

Hi

I have just found out that when i use FGCOM and test the microphone, the only sound i hear is a whooshing sound like echoing waves, i dont think the mic is broken because it happens even if i unplug it.
$ fgcom.exe -Sfgcom.flightgear.org.uk -i0.5 -o0.5 -p16661 -f910

THIS IS THE MESSAGE:

fgcom.exe - a communication radio based on VoIP with IAX/Asterisk
(c)2007 by H. Wirtz <wirtz@dfn.de>
Version 1.2.2 build 226M (with FGComGui patch)
Using iaxclient library Version SVN UNKNOWN

Successfully parsed commandline options.
Reading list of airports...done.
Initializing IAX client as guest:xxxxxxxxxxx@fgcom.flightgear.org.uk
Call 0 accepted
Call 0 answered


Does anyone have any idea what this is ?


im using WINXP 32
and flightgear 2.4-- whether that makes a difference?

i would really appreciate help

thanks
BRT
 
Posts: 191
Joined: Wed May 25, 2011 3:58 pm

Re: FGCOM strange sounds on echo test mode

Postby Tuxklok » Tue Nov 08, 2011 8:21 pm

Have you tried with other recording software to make sure your sound setup is ok? That would at least narrow the problem down to fgcom specific or not.

cheers
The Austria Scenery Project - more info
fg-scenery-tools - gitorious | videos
fgcomgui - Open source, cross platform, gui front end for fgcom. more info

More random musings and doings can be found on my personal site. (work in progress)
User avatar
Tuxklok
 
Posts: 1326
Joined: Tue Apr 21, 2009 6:04 pm
Location: Orlando, FL
Callsign: Tuxklok / N1292P
OS: GNU/Linux

Re: FGCOM strange sounds on echo test mode

Postby BRT » Wed Nov 09, 2011 4:21 pm

Thanks that a good idea ill try that :) :)
BRT
 
Posts: 191
Joined: Wed May 25, 2011 3:58 pm

Re: FGCOM strange sounds on echo test mode

Postby scighera » Sat Dec 17, 2011 6:24 am

So ... what the results ????

I'm having exactly the same problem (the console give exactly the same output; extraterrestrial sounds only, when in testing mode (with fq 910)

I checked my system with skype: it works perfectly.

Yesterday I tried fgcom in EDDF: I was capable to ear the other simmer (including atc-jomo :) ) ... but when I was speaking the listners were reporting a heavy sound disturbance only. So I was kindly asked to give up :oops:

I started FGCOM after FG. (In FG I added the following string: --generic=socket,out,10,localhost,16661,udp,fgcom)
The FGCOM GUI (in Normal Mode) says:
Code: Select all
$ //PAOLO-PC/Users/Paolo/Desktop/fgcomgui-win32-bundle-01192010/fgcom.exe
-Sfgcom.flightgear.org.uk -i0.99 -o0.99 -p16661
\\PAOLO-PC\Users\Paolo\Desktop\fgcomgui-win32-bundle-01192010\fgcom.exe
- a communication radio based on VoIP with IAX/Asterisk
(c)2007 by H. Wirtz <wirtz@dfn.de>
Version 1.2.2 build 226M (with FGComGui patch)
Using iaxclient library Version SVN UNKNOWN

Successfully parsed commandline options.
Reading list of airports...done.
Initializing IAX client as guest:xxxxxxxxxxx@fgcom.flightgear.org.uk
Selected frequency: 127.320
Airport Frankfurt-main (EDDF TWR at 127.320 MHz) is in range ( 1.0 km)
Call 0 accepted
Call 0 answered
Airport Frankfurt-main (EDDF TWR at 127.320 MHz) is in range ( 1.0 km)
Airport Frankfurt-main (EDDF TWR at 127.320 MHz) is in range ( 1.0 km)


The FGCom GUI, in Test Mode, reports:
Code: Select all
$ //PAOLO-PC/Users/Paolo/Desktop/fgcomgui-win32-bundle-01192010/fgcom.exe -Sfgcom.flightgear.org.uk -i0.99 -o0.99 -p16661 -f910
\\PAOLO-PC\Users\Paolo\Desktop\fgcomgui-win32-bundle-01192010\fgcom.exe - a communication radio based on VoIP with IAX/Asterisk
(c)2007 by H. Wirtz <wirtz@dfn.de>
Version 1.2.2 build 226M (with FGComGui patch)
Using iaxclient library Version SVN UNKNOWN

Successfully parsed commandline options.
Reading list of airports...done.
Initializing IAX client as guest:xxxxxxxxxxx@fgcom.flightgear.org.uk
Call 0 accepted
Call 0 answered


I do ear extraterrestrial sound but no echo of my voice !!

My PC data:
Code: Select all
- Computer: DELL Precision T1600
- Processor: Intel Xeon 3.1 Ghz
- RAM: 8 GB
- OS: Windows 7 (x64)
- Graphic Card:Nvidia Quadro 600 (Dedicated memory: 1 GB; Total Memory 4 GB)


Some other, hopefully usefull info:
The sound card should be a Realtek High Definition Audio; and the driver (updated) is (I think) RtDCpl64.exe (RTlUpd64.exe)

When trying to record through "Window Sound Recorder" the microphone doesn't work

The microphone works properly with skype and with audacity.exe

Suggestion will be appreciated
thanks in advance
Last edited by scighera on Sun Dec 18, 2011 7:10 am, edited 1 time in total.
Callsign: I-SCIG
The hangar: http://digilander.libero.it/scighera_fg/index.html
The "happy motorbiker" - http://web.tiscali.it/kclub
User avatar
scighera
 
Posts: 328
Joined: Thu Nov 19, 2009 8:29 am
Location: LIME-Bergamo-Italy
Callsign: scighera
Version: 2dot6
OS: Windows 7

Re: FGCOM strange sounds on echo test mode

Postby BRT » Sat Dec 17, 2011 5:01 pm

Same problem with me.

an the microphone works still.

Some Error maybe,

do any experts have any ideas?

thanks
BRT
 
Posts: 191
Joined: Wed May 25, 2011 3:58 pm

Re: FGCOM strange sounds on echo test mode

Postby Johan G » Sun Dec 18, 2011 11:21 am

I've had similars problems in the past and actually given up on FGcom, :( audio recording software (Audacity) and TeamSpeak3 works ok though. Having FGcom would be nice.

I noted that I have a Realtek High Definition Audio device as well.
Low-level flying — It's all fun and games till someone looses an engine. (Paraphrased from a YouTube video)
Improving the Dassault Mirage F1 (Wiki, Forum, GitLab. Work in slow progress)
Johan G
Moderator
 
Posts: 5294
Joined: Fri Aug 06, 2010 5:33 pm
Location: Sweden
Callsign: SE-JG
IRC name: Johan_G
Version: 3.0.0
OS: Windows 7, 32 bit

Re: FGCOM strange sounds on echo test mode

Postby Tuxklok » Sun Dec 18, 2011 9:57 pm

Only guess that springs to mind is that it could be due to an OpenAL configuration problem. I am not versed in how one properly updates and/or configures OpenAL outside of Linux however.

cheers
The Austria Scenery Project - more info
fg-scenery-tools - gitorious | videos
fgcomgui - Open source, cross platform, gui front end for fgcom. more info

More random musings and doings can be found on my personal site. (work in progress)
User avatar
Tuxklok
 
Posts: 1326
Joined: Tue Apr 21, 2009 6:04 pm
Location: Orlando, FL
Callsign: Tuxklok / N1292P
OS: GNU/Linux

Re: FGCOM strange sounds on echo test mode

Postby nocusuzo » Fri May 25, 2018 8:19 pm

I know this is an old post, but I also have the exact same problem with the newest version of ATC Pie, which uses FGCOM.
nocusuzo
 
Posts: 12
Joined: Fri May 25, 2018 8:17 pm

Re: FGCOM strange sounds on echo test mode

Postby mickybadia » Sat May 26, 2018 7:43 am

I too get the loud looping sound on echo test, but no trouble otherwise. This to me is normal because the echo test is picking up its own signal and sending it back, so it comes back with acoustic resonance. Skype and other such software will be bad comparison tests as they usually embed algorithms to filter those out.

You should basically assume FGCom is working if you get this echo at all, or use headphones while you are testing if you want to hear what FGCom does with sound without resonance.
mickybadia
 
Posts: 394
Joined: Tue Sep 24, 2013 9:12 am


Return to FGCom

Who is online

Users browsing this forum: No registered users and 2 guests