Board index FlightGear The FlightGear project News

Release Progress (2.4.0)

News from the ever evolving world of FlightGear.

Re: Release Progress (2.4.0)

Postby Torsten » Mon Aug 08, 2011 10:00 pm

Back to topic, please provide further feedback to the MacOS release candidate here:
http://www.flightgear.org/forums/viewtopic.php?f=21&t=13013 to make sure Tat finds it.

Continuing the release process, we will be able to fix some last minutes bugs until Aug. 13th (Sat). 20.00 UTC. At that time the release/2.4.0 branches will be closed and we start all the necessary work to have the release version ready and published by Aug. 17th (Wed). I don't expect any release blocking bugs to show up but we won't be bug-free, either. That's probably not the worst thing to have - it makes people looking forward to release 2.6.0 scheduled for February 2012!
flightgear.org - where development happens.
User avatar
Torsten
 
Posts: 628
Joined: Fri Feb 01, 2008 9:22 pm
Location: near Hamburg, Germany
Callsign: offline
Version: next
OS: Linux

Re: Release Progress (2.4.0)

Postby Ernest1984 » Mon Aug 08, 2011 11:12 pm

Here's what it looks at my Mac:

EPWA Warsaw Frederic Chopin Intl:

Image

What is interesting, i have copied from my old FG 2.0.0 folder some custom polish scenery, made by one of polish FG users (this scenery was NOT sent to the official database), and it appears! So i presume, the problem is with the terrasync database, which don't want to download :(
EPWA-hub: ERJ-195 clsgn: ERNIE
-----------------------------------
Around The World with B1900D!
callsign: AROUNDw - currently suspended till the FG will have a proper look on different locations
User avatar
Ernest1984
 
Posts: 438
Joined: Wed Dec 01, 2010 3:47 pm
Location: Poland / Canada
Callsign: ERNIE
Version: 2.10
OS: Mac OS X 10.8.2

Re: Release Progress (2.4.0)

Postby bschack » Mon Aug 08, 2011 11:36 pm

Tristar wrote in Mon Aug 08, 2011 5:08 pm:hi
i downloaded it (mac) and opened it:

following disk image could not be opened:
FlightGear-2.4.0-RC1.dmg reason : not recognized


I had the same problem. The reason was that the download was being prematurely terminated. I'm not sure why it was happening, but I'm guessing the problem had something to do with SourceForge. My solution was to use 'wget' on the command line:

Code: Select all
% wget --tries=0 "http://downloads.sourceforge.net/project/macflightgear/FlightGear/2.4.0-RC1/FlightGear-2.4.0-RC1.dmg?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fmacflightgear%2Ffiles%2FFlightGear%2F2.4.0-RC1%2FFlightGear-2.4.0-RC1.dmg%2Fdownload%3Fuse_mirror%3Dautoselect&ts=1312755541&use_mirror=master"


It's pretty ugly, and I don't know if all of it was necessary, but it worked. On the downside, it requires using the command line (which is actually not that bad, although we tend to talk of it in apocalyptic terms), and you have to download 'wget'.

Brian
bschack
 
Posts: 195
Joined: Tue Jul 01, 2008 9:04 am

Re: Release Progress (2.4.0)

Postby VicMar » Tue Aug 09, 2011 7:54 am

OK, my dimmer/dark effect must be related to my graphics card. By unselecting the material shaders my FG becomes much brighter. With the shaders on, I can see the lovely water effect, but my frame rate goes down to 3/5 - not very helpful for flying.

I go back to my previous message: I will just have to be left behind with Version 2.0.0

Cheers,
Vic
Time flies like an arrow
Fruit flies like a banana
User avatar
VicMar
 
Posts: 2029
Joined: Sun Apr 06, 2008 5:53 pm
Location: Lancing. UK (EGKA)
Callsign: VicMar
Version: 2018.2.1
OS: OS X 10.12.6

Re: Release Progress (2.4.0)

Postby Trez » Tue Aug 09, 2011 6:30 pm

hmn i dont think that is really worth it thx

i can w8 9 days :)
User avatar
Trez
 
Posts: 437
Joined: Thu Jul 14, 2011 10:50 am
Location: Netherlands
Callsign: Trez
Version: 2.8 GIT
OS: OSX10.8, Mint 14

Re: Release Progress (2.4.0)

Postby Ernest1984 » Tue Aug 09, 2011 7:50 pm

I encounter very large lag when city effect is on - something like 2-4 fps. When i fly off the city area, like water for example, the fps is going back to some 10-12 fps.
Mac os x 10.6 macbook pro, 4GB RAM, core2duo 2.66Ghz
is that what suppose to be?? :(
EPWA-hub: ERJ-195 clsgn: ERNIE
-----------------------------------
Around The World with B1900D!
callsign: AROUNDw - currently suspended till the FG will have a proper look on different locations
User avatar
Ernest1984
 
Posts: 438
Joined: Wed Dec 01, 2010 3:47 pm
Location: Poland / Canada
Callsign: ERNIE
Version: 2.10
OS: Mac OS X 10.8.2

Re: Release Progress (2.4.0)

Postby ThorstenB » Tue Aug 09, 2011 8:30 pm

Ernest1984 wrote in Tue Aug 09, 2011 7:50 pm:I encounter very large lag when city effect is on


The "urban shader" is a very nice effect (pays off when flying quite low), but it's also one of the heavier effects. It may require a pretty strong graphics card - especially when combined with other effects (clouds etc).
User avatar
ThorstenB
 
Posts: 160
Joined: Fri Nov 19, 2010 9:49 am
Location: Germany
Callsign: D-TB7
Version: GIT
OS: openSUSE

Re: Release Progress (2.4.0)

Postby ThorstenB » Tue Aug 09, 2011 8:41 pm

And, here we go again: we have an updated release candidate for Windows (FG2.4.0rc5):

http://mirrors.ibiblio.org/pub/mirrors/ ... 4.0rc5.exe

Compared to Windows rc4 it contains a number of fixes, mainly for METAR live weather (for those living in Eastern/Asian time zones), work-around for a "NumLock not working issue", a few fixes to the "Help System" and some updates to the manual.

This likely is the last Windows release candidate - since the official release is scheduled for next week. Time for final tests...

Please download, install, run and test.

(Also note that the RC-numbers of the Mac and Windows release candidates are not in sync - "Windows rc5" is only slightly newer than "Mac rc1").
User avatar
ThorstenB
 
Posts: 160
Joined: Fri Nov 19, 2010 9:49 am
Location: Germany
Callsign: D-TB7
Version: GIT
OS: openSUSE

Re: Release Progress (2.4.0)

Postby Ernest1984 » Tue Aug 09, 2011 9:31 pm

Too bad, i really like it and it's impossible to use it at my machine :(
EPWA-hub: ERJ-195 clsgn: ERNIE
-----------------------------------
Around The World with B1900D!
callsign: AROUNDw - currently suspended till the FG will have a proper look on different locations
User avatar
Ernest1984
 
Posts: 438
Joined: Wed Dec 01, 2010 3:47 pm
Location: Poland / Canada
Callsign: ERNIE
Version: 2.10
OS: Mac OS X 10.8.2

Re: Release Progress (2.4.0)

Postby Zexe » Thu Aug 11, 2011 5:46 am

Hi,

Just downloaded FG pre-release and noticed a change in the mouse yoke control. It seems as though the mouse yoke skips/jumps when you want to make a smooth gesture (especially left and right). Can anyone else confirm this? Thanks,
-Zexe

EDIT: To be specific, when in mouse mode 1, when the cross hair reaches it's boundary, it centers again. This is actually normal. So normally when pulling on the mouse in order to gain altitude, you can continue to pull back smoothly in one gesture as the cross hair returns to the center and is pulled back even more. However in this pre-release, it seems as though when the cross hair returns to center, FG thinks I want to center my plane, so instead of increasing alt., it puts the nose down to stabilize the plane. This goes for all directions with the cross hair. As long as I keep the cross hair within its boundaries, there won't be any jerky movements. I changed the constraint to false which seems to help, but just wondering why the latest version of FG suddenly changed.
Zexe
AIRPORTS: CYYJ, KHAF, RJTT, KEYW
PLANES: m33, grob115, pa22, Goose, MD-81, Velocity-XL, Rallye, F-5E Tiger II, Bocian,
User avatar
Zexe
 
Posts: 190
Joined: Thu May 21, 2009 7:12 am

Re: Release Progress (2.4.0)

Postby ThorstenB » Thu Aug 11, 2011 6:10 am

Zexe, that's interesting. Actually a similar issue has already been reported - but we were unable to reproduce it so far. Apparatenly, that's an issue not happening everywhere - but we haven't found out yet, who/which systems are affected.

Also, maybe some more people can try to specifically test the mouse behaviour - and report if it's working for them.

Any you could add comments to this bug report:
http://code.google.com/p/flightgear-bug ... ail?id=359

Which OS are you using (Windows, I guess?), are you observing this in "full-screen" or "Window" mode (or both), or does it happen with a specific aircraft only?
User avatar
ThorstenB
 
Posts: 160
Joined: Fri Nov 19, 2010 9:49 am
Location: Germany
Callsign: D-TB7
Version: GIT
OS: openSUSE

Re: Release Progress (2.4.0)

Postby HanselVB » Thu Aug 11, 2011 7:16 am

This happens on my Mac too, in full-screen mode.
Nothing better than the elegance of flying.
User avatar
HanselVB
 
Posts: 56
Joined: Tue Mar 29, 2011 7:19 pm
Location: Belgium (EBBR)
Version: 240
OS: Mac OS X

Re: Release Progress (2.4.0)

Postby Zexe » Thu Aug 11, 2011 7:47 am

ThorstenB wrote in Thu Aug 11, 2011 6:10 am:Zexe, that's interesting. Actually a similar issue has already been reported - but we were unable to reproduce it so far. Apparatenly, that's an issue not happening everywhere - but we haven't found out yet, who/which systems are affected.

Also, maybe some more people can try to specifically test the mouse behaviour - and report if it's working for them.

Any you could add comments to this bug report:
http://code.google.com/p/flightgear-bug ... ail?id=359

Which OS are you using (Windows, I guess?), are you observing this in "full-screen" or "Window" mode (or both), or does it happen with a specific aircraft only?


I am using Win 7 64bit, Full screen. It happens with all aircraft, especially after making sharp turns, or pulling on the yoke hard. After that when you try to bank sharp it skips the smooth gesture and jerks the plane. When you try to compensate the over banking, it oversteers to the opposite side. As long as you keep the cross hair within the boundaries the issue doesn't persist. An easy fix is to make the constraint false and up the factor.

I've been toying around to see what exactly is happening. Upon closer observation, once you pass a certain threshold, the boundaries of the mouse yoke become a double tap like function where it accelerates the mouse and quadruples the function (in this case steering the plane). If you don't touch these boundaries, the plane can stabilize, but if you touch them then the plane will go to the extreme of whatever direction you're trying to fly to.


On another note, does it seem as though this pre-release is heavier than the summer snapshots? My average FPS has dropped to 20, before on the snapshots it was 40-60fps in fair weather.
Zexe
AIRPORTS: CYYJ, KHAF, RJTT, KEYW
PLANES: m33, grob115, pa22, Goose, MD-81, Velocity-XL, Rallye, F-5E Tiger II, Bocian,
User avatar
Zexe
 
Posts: 190
Joined: Thu May 21, 2009 7:12 am

Re: Release Progress (2.4.0)

Postby ThorstenB » Thu Aug 11, 2011 8:11 pm

Unfortunately I'm unable to reproduce the "jumping mouse axis" issue (doesn't happen on Linux). But I have pushed an experimental patch and I need someone to test this on Windows. If you saw the issue, please see here:
http://code.google.com/p/flightgear-bug ... id=359#c19 (comment 19).

Remember, it's normal for the mouse cursor to jump to the center - but it's not normal for an axis to move at the same time.

Let me know if the patch has changed/fixed the issue.
User avatar
ThorstenB
 
Posts: 160
Joined: Fri Nov 19, 2010 9:49 am
Location: Germany
Callsign: D-TB7
Version: GIT
OS: openSUSE

Re: Release Progress (2.4.0)

Postby flightgeardownloads » Fri Aug 12, 2011 9:40 am

Errm do i have to delete my existing flightgear to use this one when i comes out!

Cheers
flightgeardownloads
 
Posts: 55
Joined: Wed Apr 20, 2011 1:00 pm

PreviousNext

Return to News

Who is online

Users browsing this forum: No registered users and 1 guest