Board index FlightGear Support Multiplayer

P51 burning over the MP

Trouble getting online, setting up a server?
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- copy&paste your commandline.

Please, also see Requesting Technical Help.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Re: P51 burning over the MP

Postby Richard » Fri Apr 06, 2018 5:37 am

V12 wrote in Fri Apr 06, 2018 5:19 am:But this is not answer why yesterday tests was without fire and smoke.


I'm sure that bool[25] being 0 is the cause of the problem; and setting it to non-zero should fix the problem, provided that I haven't screwed up the fix.

A whole load of changes were merged in from onox's repo on the 18/feb/2018 - so if you are using a model that is earlier than that, or a FlightGear version after 2017.2 it will not show the fire.
Richard
 
Posts: 699
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: P51 burning over the MP

Postby OK-F » Fri Apr 06, 2018 5:42 am

Good job Richard! Thx for that!
OK-F
 
Posts: 48
Joined: Mon Mar 26, 2018 12:26 am

Re: P51 burning over the MP

Postby V12 » Fri Apr 06, 2018 8:53 am

Richard wrote in Fri Apr 06, 2018 5:37 am:A whole load of changes were merged in from onox's repo on the 18/feb/2018 - so if you are using a model that is earlier than that, or a FlightGear version after 2017.2 it will not show the fire.

This is answer why my tests was flawless.
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1332
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: P51 burning over the MP

Postby OK-F » Fri Apr 06, 2018 8:42 pm

So for Jomo the plane is still burning. He said he is using the latest FG release. He downloaded the P 51 with Richard fix.. still burning. He downloaded the plane from Flightgear website the date is 6th April so it should be the updated version right?

Is the updated version both on FG wiki addon website and Flightgear web directory? it is the same thing? He mentioned that the unpacked file shows still the date 19th feb. Dont know if that is relevant or not. thx He also mentioned that he is using some kind of special program along with FG dont know what he meant.
Last edited by OK-F on Fri Apr 06, 2018 9:32 pm, edited 1 time in total.
OK-F
 
Posts: 48
Joined: Mon Mar 26, 2018 12:26 am

Re: P51 burning over the MP

Postby OK-F » Fri Apr 06, 2018 9:21 pm

I guess the problem is not in what Richard did but in something else. For other pilots the P51 appears OK. The problem will be on Jomos side.
OK-F
 
Posts: 48
Joined: Mon Mar 26, 2018 12:26 am

Re: P51 burning over the MP

Postby wkitty42 » Fri Apr 06, 2018 11:19 pm

don't guess ;)

yes, the problem is on jomo's side because he apparently has not gotten the updated craft... AFAIK it is only on the master server (aka repository) until such time as the aircraft archive script is run to update the archives and make them available... when that will happen, i don't know... AIUI, the script is run automatically by some sort of cron job... that may only be when new releases are packaged into RC status...

as noted in the other topic, it is apparently in the repository at this time...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5501
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: P51 burning over the MP

Postby swampthing » Sun Apr 08, 2018 8:39 am

My original code for this from the P47 was
Code: Select all
<condition>
 <equals>
  <property>sim/multiplay/generic/int[0]</property>
  <value>0</value>
 </equals>
</condition>
www.opredflag.com
I have sworn upon the altar of God, eternal hostility against every form of tyranny over the mind of man. -Thomas Jefferson-
swampthing
 
Posts: 528
Joined: Wed Oct 28, 2015 4:10 am
Location: Missouri
Callsign: swamp
Version: 2018.2
OS: multiple

Re: P51 burning over the MP

Postby wkitty42 » Sun Apr 08, 2018 3:49 pm

there was another fix for this problem applied to the craft in the repository yesterday.... it was to fix the property and create it if it didn't exist IIRC the commit message correctly...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5501
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: P51 burning over the MP

Postby Richard » Mon Apr 09, 2018 7:19 am

wkitty is right - there is a second change that should create bool[25] if it doesn't exist.

I've tested 2016.2(p51d) with 2016.2 (ufo) and 2081.2(ufo) and confirm that on both of these the engine isn't on fire.
Richard
 
Posts: 699
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Previous

Return to Multiplayer

Who is online

Users browsing this forum: No registered users and 1 guest

cron